Announcement

Collapse
No announcement yet.

AMD Catalyst 9.4 Finally Brings X Server 1.6 Support

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #71
    Compilation error on kernel 2.6.29

    Originally posted by mcgreg View Post
    Does it support Kernel 2.6.29 - or ever newer?

    Greg
    I get this compilation error on kernel 2.6.29:

    http://groups.google.com/group/linux.../browse_thread
    /thread/9a10efde9c50b8ce/bf7ce3f715cd1434?lnk=raot

    With the 9.4 source this is:

    /usr/src/modules-2.6.26-fglrx-9.2/fglrx/firegl_public.c:1444: error: ?struct task_struct? has no member named ?euid?
    /usr/src/modules-2.6.26-fglrx-9.2/fglrx/firegl_public.c:1818: error: ?struct task_struct? has no member named ?cap_effective?
    /usr/src/modules-2.6.26-fglrx-9.2/fglrx/firegl_public.c:1822: error: ?struct task_struct? has no member named ?cap_effective?

    Comment


    • #72
      Originally posted by Milyardo View Post
      You need to rebuild your kernel module. You've probably updated your kernel at some point. Use dkms or just reinstall the driver.
      That's what I do each time. The last kernel update for Debian Lenny was about a week ago, I only installed this driver two days ago after using fglrx-uninstall and rm -rf'ing /etc/ati/.

      What I posted above also happens on another box with Debian Lenny and with a 2600xt. One is using 64bit and the other 32bit os's.

      It was late at night when I posted the kneejerk "I'm done" reaction. After two days of use, I like the improvements in 9.4 overall but the savage2 thing has really struck me hard as a gamer, especially with a clanwar coming up.

      Comment


      • #73
        Originally posted by storma View Post
        That's what I do each time. The last kernel update for Debian Lenny was about a week ago, I only installed this driver two days ago after using fglrx-uninstall and rm -rf'ing /etc/ati/.

        What I posted above also happens on another box with Debian Lenny and with a 2600xt. One is using 64bit and the other 32bit os's.

        It was late at night when I posted the kneejerk "I'm done" reaction. After two days of use, I like the improvements in 9.4 overall but the savage2 thing has really struck me hard as a gamer, especially with a clanwar coming up.
        whats wrong with savage2? Mine plays fine.

        EDIT:
        Actually it doesn't:
        Code:
        X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
          Major opcode of failed request:  139 (XFree86-DRI)
          Minor opcode of failed request:  8 ()
          Resource id in failed request:  0x2000009
          Serial number of failed request:  84
          Current serial number in output stream:  110

        Comment


        • #74
          Originally posted by tball View Post
          I have had alot of trouble getting dualhead working with amdcccle in 9.3. But randr worked perfectly with compiz etc. Though the randr gui in kde seems kinda broken, so I just use the xrandr cli. Just type 'xrandr -q' and you should see your tv-out.
          Yeah, I already tried xrandr with 9.4 and now it does list my TV output (contrary to driver 9.3). But gnome doesn't use the complete screen.

          Is there any way to create a second screen in xrandr? I don't want a stretched desktop, I want two separate desktops (no window dragging between them).

          When I setup with
          Code:
          aticonfig --intial=dual-head --adapter=0
          I get the dual-head setup I want and for screen 0 xrandr shows:
          Code:
          xrandr -q --screen 0
          Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1280
          DFP2 disconnected (normal left inverted right x axis y axis)
          CRT1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
             1280x1024      60.0 +   75.0* 
             1280x960       60.0  
             1152x864       75.0     60.0  
             1280x768       59.9  
             1280x720       60.0  
             1024x768       75.0     70.1     60.0  
             800x600        72.2     75.0     70.0     60.3  
             720x480        60.0  
             640x480        75.0     72.8     60.0  
             640x432        60.0  
             640x400        75.1     59.9  
             640x350        70.1  
             512x384        60.0     74.9  
             400x300        75.0     60.7  
             320x240        75.6     60.0  
             320x200        75.5     60.1  
          CRT2 disconnected (normal left inverted right x axis y axis)
          TV disconnected (normal left inverted right x axis y axis)
          COMPONENT_VIDEO disconnected (normal left inverted right x axis y axis)
          For screen 1 xrandr shows:
          Code:
          xrandr -q --screen 1
          Screen 1: minimum 320 x 200, current 1024 x 768, maximum 1024 x 1024
          DFP2 disconnected (normal left inverted right x axis y axis)
          CRT1 disconnected (normal left inverted right x axis y axis)
          CRT2 disconnected (normal left inverted right x axis y axis)
          TV connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
             1024x768       30.0*+
             800x600        30.0  
             720x576        30.0  
             720x480        30.0  
             640x480        30.0  
             640x432        30.0  
             640x400        30.0  
             512x384        30.0  
             400x300        30.0  
             320x240        30.0  
             320x200        30.0  
          COMPONENT_VIDEO disconnected (normal left inverted right x axis y axis)
          But on CRT1 (my main screen) gnome uses only 1024x768 pixels of the available 1280x1024. So the panels don't stretch over the screen.

          I can setup my main screen properly, when not having dual head. But I don't know how to create a second screen with xrandr... I can only address `screen 1' (the 2nd one) if it is already there.

          Comment


          • #75
            Can somebody please post the fglrx version of Catalyst 9.4?
            I'm playing around with Ubuntu 9.04 and I have there 8.60.3 running.
            But with this version Team Fortress 2 is crashing in current Wine and Crossover games when a map is starting. On the wine page somebody got it running with fglrx version 8.60.40. So I have the feeling that I'm running the Ubuntu Catalyst and not the real one, even though I installed from Catalyst 9.4 install file.

            Thank you in advance

            Comment


            • #76
              Originally posted by Hans Bausewein View Post
              I get this compilation error on kernel 2.6.29:

              http://groups.google.com/group/linux.../browse_thread
              /thread/9a10efde9c50b8ce/bf7ce3f715cd1434?lnk=raot

              With the 9.4 source this is:

              /usr/src/modules-2.6.26-fglrx-9.2/fglrx/firegl_public.c:1444: error: ?struct task_struct? has no member named ?euid?
              /usr/src/modules-2.6.26-fglrx-9.2/fglrx/firegl_public.c:1818: error: ?struct task_struct? has no member named ?cap_effective?
              /usr/src/modules-2.6.26-fglrx-9.2/fglrx/firegl_public.c:1822: error: ?struct task_struct? has no member named ?cap_effective?
              try this patch

              Comment


              • #77
                Originally posted by Hans Bausewein View Post
                I get this compilation error on kernel 2.6.29:

                http://groups.google.com/group/linux.../browse_thread
                /thread/9a10efde9c50b8ce/bf7ce3f715cd1434?lnk=raot

                With the 9.4 source this is:

                /usr/src/modules-2.6.26-fglrx-9.2/fglrx/firegl_public.c:1444: error: ?struct task_struct? has no member named ?euid?
                /usr/src/modules-2.6.26-fglrx-9.2/fglrx/firegl_public.c:1818: error: ?struct task_struct? has no member named ?cap_effective?
                /usr/src/modules-2.6.26-fglrx-9.2/fglrx/firegl_public.c:1822: error: ?struct task_struct? has no member named ?cap_effective?
                try this patch: xorg-driver-video-fglrx-2.6.29.patch

                Comment


                • #78
                  Originally posted by Hasenpfote View Post
                  Can somebody please post the fglrx version of Catalyst 9.4?
                  I'm playing around with Ubuntu 9.04 and I have there 8.60.3 running.
                  But with this version Team Fortress 2 is crashing in current Wine and Crossover games when a map is starting. On the wine page somebody got it running with fglrx version 8.60.40. So I have the feeling that I'm running the Ubuntu Catalyst and not the real one, even though I installed from Catalyst 9.4 install file.

                  Thank you in advance
                  You got the real one. Mine is also 8.60.3. The 8.60.4 must be a beta.

                  Comment


                  • #79
                    I reported this on the bugzilla, but this is a problem that intermittently appeared with monthly fglrx since June or July 2008.

                    I would really like that someone could take care of it since it seems to me it is a bit critical. (Xorg fails to start due to this)

                    Code:
                    Apr 19 14:47:06 Obi-Wan BUG: scheduling while atomic: X/5585/0x00000002
                    Apr 19 14:47:06 Obi-Wan Modules linked in: vboxnetflt vboxdrv uvcvideo fglrx(P) asus_laptop [last unloaded: microcode]
                    Apr 19 14:47:06 Obi-Wan Pid: 5585, comm: X Tainted: P           2.6.28-tuxonice-r9-BeN-g8fdd299 #3
                    Apr 19 14:47:06 Obi-Wan Call Trace:
                    Apr 19 14:47:06 Obi-Wan [<ffffffff806716f0>] 0xffffffff806716f0
                    Apr 19 14:47:06 Obi-Wan [<ffffffff8023142a>] 0xffffffff8023142a
                    Apr 19 14:47:06 Obi-Wan [<ffffffff80231e23>] 0xffffffff80231e23
                    Apr 19 14:47:06 Obi-Wan [<ffffffffa000ba18>] 0xffffffffa000ba18
                    Apr 19 14:47:06 Obi-Wan [<ffffffff80253800>] 0xffffffff80253800
                    Apr 19 14:47:06 Obi-Wan [<ffffffffa00236e7>] 0xffffffffa00236e7
                    Apr 19 14:47:06 Obi-Wan [<ffffffffa0024ce6>] 0xffffffffa0024ce6
                    Apr 19 14:47:06 Obi-Wan [<ffffffffa00d5bd1>] 0xffffffffa00d5bd1
                    Apr 19 14:47:06 Obi-Wan [<ffffffffa00df6e5>] 0xffffffffa00df6e5
                    Apr 19 14:47:06 Obi-Wan [<ffffffff8028a49c>] 0xffffffff8028a49c
                    Apr 19 14:47:06 Obi-Wan [<ffffffffa00d4ed9>] 0xffffffffa00d4ed9
                    Apr 19 14:47:06 Obi-Wan [<ffffffffa0025b37>] 0xffffffffa0025b37
                    Apr 19 14:47:06 Obi-Wan [<ffffffffa0019354>] 0xffffffffa0019354
                    Apr 19 14:47:06 Obi-Wan [<ffffffffa0018435>] 0xffffffffa0018435
                    Apr 19 14:47:06 Obi-Wan [<ffffffff802c0d6f>] 0xffffffff802c0d6f
                    Apr 19 14:47:06 Obi-Wan [<ffffffff802bd5cb>] 0xffffffff802bd5cb
                    Apr 19 14:47:06 Obi-Wan [<ffffffff8023e4b5>] 0xffffffff8023e4b5
                    Apr 19 14:47:06 Obi-Wan [<ffffffff802406d8>] 0xffffffff802406d8
                    Apr 19 14:47:06 Obi-Wan [<ffffffff802407b3>] 0xffffffff802407b3
                    Apr 19 14:47:06 Obi-Wan [<ffffffff80240832>] 0xffffffff80240832
                    Apr 19 14:47:06 Obi-Wan [<ffffffff8020b94b>] 0xffffffff8020b94b

                    Comment


                    • #80
                      Anyone solved savage2 bug ? or got a workaround ? on final 9.4 it doesnt even start, but on 9.4RC was working like a charm ;/

                      Comment

                      Working...
                      X