No announcement yet.

AMD Catalyst 9.4 Finally Brings X Server 1.6 Support

  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    Hi Yall.

    @ Schugy

    Is the RS690M, listed as suppored by 9.4?

    I could not see it.

    GreekGeek :-)


    • #52
      I would use just any driver that really works.


      • #53
        @gfxdrone: 9.4 doesn't support 2.6.29, I think. But even if it does, it won't start with newest Debian packages (or am I wrong?). The package libdrm2 2.4.5 makes fglrx to crush the system on X startup. I don't know if it is fixed with 9.4 or newer libdrm2 but you can check this by downgrading libdrm2 to lenny (2.3.1), and of course by using older kernel.


        • #54
          Does anyone know how often the openSUSE ATI repository gets updated?
          I added it in the beginning of March, seeing it already had an RPM for Catalyst 9.2, but now it doesn't even provide 9.3...
          I'd install the driver manually if it worked, but somehow I couldn't get any manual install working after I switched to openSUSE


          • #55
            Well I truly had no idea, but it seems like my integrated crappy thing was indeed an old chip and now dropped here.

            So now it's time for me to say goodbye to fglrx. I tried the new free driver and it runs somewhat better than previously,
            even novelty direct render with unusably slow 3d, but at least Xv doesn't hop around anymore!

            Well so long fglrx, composite & 3d on this craptop, you fought bravely.


            • #56
              Originally posted by bridgman View Post
              If you are having problems when resizing to full screen, check and see if the "unredirect fullscreen windows" option is set in Compiz. There were some reports of problems with on-the-fly redirecting; if that's your issue then turning off the unredirect option should help.
              Problems still appear. I can send to you all debug if you want.


              • #57
                Apr 18 13:48:37 Obi-Wan [fglrx] Firegl kernel thread PID: 5543
                Apr 18 13:48:38 Obi-Wan [fglrx] Gart cacheable size:1000 M.
                Apr 18 13:48:38 Obi-Wan [fglrx] Reserved FB block: Shared offset:0, size:1000000 
                Apr 18 13:48:38 Obi-Wan [fglrx] Reserved FB block: Unshared offset:fdff000, size:201000 
                Apr 18 13:48:38 Obi-Wan [fglrx] Reserved FB block: Unshared offset:1fffb000, size:5000 
                Apr 18 13:48:38 Obi-Wan BUG: scheduling while atomic: X/5371/0x00000002
                Apr 18 13:48:38 Obi-Wan Modules linked in: vboxnetflt vboxdrv fglrx(P) uvcvideo [last unloaded: microcode]
                Apr 18 13:48:38 Obi-Wan Pid: 5371, comm: X Tainted: P           2.6.28-tuxonice-r9-BeN-g8fdd299 #2
                Apr 18 13:48:38 Obi-Wan Call Trace:
                Apr 18 13:48:38 Obi-Wan [<ffffffff80672fb0>] 0xffffffff80672fb0
                Apr 18 13:48:38 Obi-Wan [<ffffffff8023142a>] 0xffffffff8023142a
                Apr 18 13:48:38 Obi-Wan [<ffffffff80231e23>] 0xffffffff80231e23
                Apr 18 13:48:38 Obi-Wan [<ffffffffa0014a18>] 0xffffffffa0014a18
                Apr 18 13:48:38 Obi-Wan [<ffffffff80253800>] 0xffffffff80253800
                Apr 18 13:48:38 Obi-Wan [<ffffffffa002c6e7>] 0xffffffffa002c6e7
                Apr 18 13:48:38 Obi-Wan [<ffffffffa002dce6>] 0xffffffffa002dce6
                Apr 18 13:48:38 Obi-Wan [<ffffffffa00debd1>] 0xffffffffa00debd1
                Apr 18 13:48:38 Obi-Wan [<ffffffffa00e86e5>] 0xffffffffa00e86e5
                Apr 18 13:48:38 Obi-Wan [<ffffffff8028a49c>] 0xffffffff8028a49c
                Apr 18 13:48:38 Obi-Wan [<ffffffff8028ad63>] 0xffffffff8028ad63
                Apr 18 13:48:38 Obi-Wan [<ffffffffa00dded9>] 0xffffffffa00dded9
                Apr 18 13:48:38 Obi-Wan [<ffffffffa002eb37>] 0xffffffffa002eb37
                Apr 18 13:48:38 Obi-Wan [<ffffffffa0022354>] 0xffffffffa0022354
                Apr 18 13:48:38 Obi-Wan [<ffffffffa0021435>] 0xffffffffa0021435
                Apr 18 13:48:38 Obi-Wan [<ffffffff802c0d6f>] 0xffffffff802c0d6f
                Apr 18 13:48:38 Obi-Wan [<ffffffff802bd5cb>] 0xffffffff802bd5cb
                Apr 18 13:48:38 Obi-Wan [<ffffffff8023e4b5>] 0xffffffff8023e4b5
                Apr 18 13:48:38 Obi-Wan [<ffffffff802406d8>] 0xffffffff802406d8
                Apr 18 13:48:38 Obi-Wan [<ffffffff802407b3>] 0xffffffff802407b3
                Apr 18 13:48:38 Obi-Wan [<ffffffff80240832>] 0xffffffff80240832
                Apr 18 13:48:38 Obi-Wan [<ffffffff8020b94b>] 0xffffffff8020b94b
                nice! ain't it??
                It appeared compiling asus_laptop built-in.
                Rebuilding the kernel, leaving asus_laptop as a module did work.

                ehhhhhhhhhhhh!?!??! what the heck do those things match!?

                should I open a ticket for that?
                Obviously it crashes my system.


                • #58
                  i just installed 9.4 on my slackware 12.2. Its a pretty good improvemnt. i got a 3500+ on my glxgears, for fglrx 9.3 i only got max 2000. But the video tearing is still persistent, i can play counter strike condition zero flawlessly, its almost better than i play in windows i think. I installed quake 4, but its not very playable.

                  So far, cs condition zero is the only game i can perfectly play on my slackware. I wonder is it because of the engine that cs use that makes it play so smooth? But overally, good job in the new release.


                  • #59
                    think i should correct that. Actually the tearing only occur when im playing videos from youtube, especially HD video in fullscreen. Other than that, its all good. No more tearing when playing videos using mplayer, even at high resolution like 1080p the video plays perfectly. Im using a HD 2400.

                    hope the youtube tearing video can be fixed.


                    • #60
                      Yeah, playing videos with mplayer has improved considerably.