Announcement

Collapse
No announcement yet.

X.Org ATI Driver Supports New Power Options

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #71
    Originally posted by glock24 View Post
    Neither works
    Also are you talking about fglrx or the latest xf86-video-ati built from git ?
    Last edited by bridgman; 04-18-2009, 05:30 PM.

    Comment


    • #72
      aticonfig --lsp
      Error: POWERplay is not supported on your hardware.

      aticonfig --od-gettemperature
      ERROR - ATI Overdrive(TM) is not supported on the Default Adapter - ATI Mobility Radeon HD 3650

      This is with fglrx. The last time I tested the adeon or radeonhd it didn't even work, just got a white screen, or a gray, caleoidoscope-like screen, but that was long ago.

      Where do I set DynamicPM or ForceLowPowerMode options? xorg.conf? aticonfig?

      Comment


      • #73
        Originally posted by glock24 View Post
        aticonfig --lsp
        Error: POWERplay is not supported on your hardware.

        aticonfig --od-gettemperature
        ERROR - ATI Overdrive(TM) is not supported on the Default Adapter - ATI Mobility Radeon HD 3650

        This is with fglrx. The last time I tested the adeon or radeonhd it didn't even work, just got a white screen, or a gray, caleoidoscope-like screen, but that was long ago.

        Where do I set DynamicPM or ForceLowPowerMode options? xorg.conf? aticonfig?
        Those options are only relevant for the open source radeon driver, not fglrx. If you want to try them with the radeon driver, you'd put them in the device section of your xorg.conf.

        Comment


        • #74
          Yeah, I think Overdrive is a desktop fglrx option, not mobility. Not 100% sure about that though.

          The new power options are for the radeon driver, so aticonfig won't work (it's part of fglrx). The power management options for radeon are set in xorg.conf.

          If you're going to run the radeon driver, you'll need to uninstall fglrx first and reboot to make sure the fglrx kernel module isn't running. Some distros will take care of this for you automatically. If you haven't run radeon for a while then you probably don't have the new drm with 6xx/7xx support -- get that from the 6xx-7xx-support branch of mesa/drm. Finally you'll need the latest radeon driver from git.

          Comment


          • #75
            This is a Mobility HD3650 by the way, in an Asus F8Va. Could this be a BIOS issue? If I remember, vesa driver didn't work either (X did not start).

            Comment


            • #76
              Originally posted by glock24 View Post
              This is true! It does not work on my HD3650.
              It doesn't neither work on my HD3650

              Comment


              • #77
                tball, before we go through the same dance, are you saying that the new power management options don't work with the latest xf86-video-ati driver, or are you talking about the powerplay and overdrive options on fglrx ?

                Comment


                • #78
                  Originally posted by bridgman View Post
                  tball, before we go through the same dance, are you saying that the new power management options don't work with the latest xf86-video-ati driver, or are you talking about the powerplay and overdrive options on fglrx ?
                  I am talking about the fglrx powerplay. Sorry for the confusion :-)
                  Haven't tried the new ati rewrite yet. Will do when we have better 3D support for r600 :-)

                  Comment


                  • #79
                    Sounds good. Thanks !!

                    Comment


                    • #80
                      I set the options, but i don't know if it does anything. How can i test this?

                      Comment

                      Working...
                      X