Announcement

Collapse
No announcement yet.

Dual Monitors on Opensource ATI driver works in gnome not KDE/XFCE (9.04 beta)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dual Monitors on Opensource ATI driver works in gnome not KDE/XFCE (9.04 beta)

    My problem is simple, I can get dual head working fine on my fanless ATI HD4550 if I use gnome.

    My card has a DVI, a HDMI and a VGA. I use the VGA and DVI, but on KDE both screens are seen as the same. SO when i click detect screens it shows VGA-0/DVI-0 on both screens.

    So its pretty confused.

    XFCE only sees one screen. and basically clones them.

    here is my xorg.conf file

    Section "Screen"
    Identifier "Configured Screen Device"
    Device "Configured Video Device"
    SubSection "Display"
    Virtual 3840 1200
    EndSubSection
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    EndSection

    Section "ServerFlags"
    Option "DontZap" "False"
    EndSection

    And the output of xrandr -q

    Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 3840 x 1200
    VGA-0 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
    1920x1200 60.0*+
    1600x1200 60.0
    1280x1024 75.0 60.0
    1152x864 75.0
    1024x768 75.0 60.0
    800x600 75.0 60.3
    640x480 75.0 59.9
    720x400 70.1
    HDMI-0 disconnected (normal left inverted right x axis y axis)
    DVI-0 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
    1920x1200 60.0*+
    1600x1200 60.0
    1280x1024 75.0 60.0
    1152x864 75.0
    1024x768 75.0 60.0
    800x600 75.0 60.3
    640x480 75.0 59.9
    720x400 70.1

    Any help would be appreciated!

  • audir8
    replied
    I use kde with two monitors, and the kde configuration tools suck for this. Here's the command my .bashrc does twice (konsole always starts at startup).. once does not work for some reason (it just turns off one monitor).

    xrandr --output VGA-0 --pos 0x0 --mode 1920x1200 --output DVI-0 --pos 1920x0 --mode 1920x1200

    I'm using the latest releases and sometimes git.

    Leave a comment:


  • lordmozilla
    replied
    default ubuntu 9.04 beta drivers and logs Xorg.0.log shows stuff like this :

    Code:
    Blank CRTC 1 success
    Disable CRTC 1 success
    Disable CRTC memreq 1 success
    Enable CRTC memreq 0 success
    Enable CRTC 0 success
    Unblank CRTC 0 success
    Enable CRTC memreq 1 success
    Enable CRTC 1 success
    Unblank CRTC 1 success
    Output CRT2 disable success
    Output DIG dpms success
    Enable CRTC memreq 0 success
    Enable CRTC 0 success
    Unblank CRTC 0 success
    Output CRT2 enable success
    Enable CRTC memreq 1 success
    Enable CRTC 1 success
    Unblank CRTC 1 success
    Output DIG dpms success

    Leave a comment:


  • tettamanti
    replied
    Hum
    What driver are you using (and what version)? Do you see anything suspicious in the log file?

    Leave a comment:


  • lordmozilla
    replied
    yes that's exactly what I meant

    Leave a comment:


  • tettamanti
    replied
    Originally posted by lordmozilla View Post
    nope the xrandr command does nothing :-(
    "nothing" as in "there's no output at all and the screens stay cloned"?

    Leave a comment:


  • lordmozilla
    replied
    nope the xrandr command does nothing :-(

    Any ideas?

    Leave a comment:


  • tettamanti
    replied
    Originally posted by lordmozilla View Post
    My problem is simple, I can get dual head working fine on my fanless ATI HD4550 if I use gnome.

    My card has a DVI, a HDMI and a VGA. I use the VGA and DVI, but on KDE both screens are seen as the same. SO when i click detect screens it shows VGA-0/DVI-0 on both screens.
    AFAICS you cannot unclone the screens using KDE4 "System Settings". You can do that using xrandr:

    Code:
    xrandr --output DVI-0 --right-of VGA-0 --auto
    (of course you can adjust the position according to your own needs)

    I use a similar setup daily and KDE4 seems to remember the configuration so you just need to configure it once. And BTW if you open Display Settings it will revert to cloning

    Leave a comment:


  • lordmozilla
    replied
    sorry for posting it in the wrong section, can someone move it to the opensource forum? cheers?

    Leave a comment:

Working...
X