Announcement

Collapse
No announcement yet.

weird green dots on desktop (with fglrx only)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vigilantpa1adin
    replied
    I've been having the same problem

    I have been having the same exact problem.

    The only circumstance that I can get them to disappear is when I move my mouse over the dots. Does anyone have a solution?

    Leave a comment:


  • barc
    replied
    Thanks for the info, my problem remained the same throughout those driver versions.
    The green dots change a bit when I reboot I believe, but are always in the bottom right corner of the screen on my desktop, no matter if I have an application open underneath them or not. They do not change when my system is running and don't show up on screenshots.
    The only way to capture them is by photographing my monitor like I did.

    I've never experienced anything like that.

    Leave a comment:


  • cutterjohn
    replied
    Some of the older catalysts, 9.2 or later IIRC had a screen corruption problem, but it was fixed in 9.4? 9.5?

    Since 9.5? or 9.6? I've now gotten a new type of corruption where random rectangles (primarily on applications) will have black backgrounds which forcing a screen refresh "fixes". Dunno if that's a GNOME/GTK/X.org problem, a catalyst problem, or a combo of the two. (Other users have reported this as well, so it's not hw.)

    Leave a comment:


  • barc
    replied
    Sorry to dig this out again, but the problem remains. I tried the newest fglrx driver (9.8 if I remember correctly) without luck. This is really annoying me. Any ideas what to do?

    Leave a comment:


  • tball
    replied
    Originally posted by barc View Post
    $ aticonfig --lsp
    Error: POWERplay is not supported on your hardware.

    Guess mine says the same... I heart that the 48xx series has problems with powerplay which is not fully supported. Anything I could change about that?
    I have a 3650 though.
    You could try and see if it is not supported by the drivers, which doesn't show weird dots.

    Leave a comment:


  • barc
    replied
    $ aticonfig --lsp
    Error: POWERplay is not supported on your hardware.

    Guess mine says the same... I heart that the 48xx series has problems with powerplay which is not fully supported. Anything I could change about that?

    Leave a comment:


  • tball
    replied
    Originally posted by barc View Post
    Thanks for your help, I really appreciate it!
    Could it be a failing powerplay? Mine says:

    Code:
    $ aticonfig --lsp
    Error: POWERplay is not supported on your hardware.
    Guess my laptop has a good heatsink (asus)

    Leave a comment:


  • barc
    replied
    Might be, but I can play games without problems under windows. I haven't seen them once there. The card is pretty new and could be faulty, but it sounds unlikely to me if its working fine under windows.

    Those artifacts are not moving and appear only under X.

    Leave a comment:


  • grantek
    replied
    Those look exactly like the artifacts you get on Windows when a GPU (or its RAM) is overheating/overclocked too much (I've never seen them on Linux but I've never run an overclocked GPU on Linux). It might be a pure software bug, but it might also be a failing card that only gets pushed hard enough by the versions of fglrx you're using.

    Leave a comment:


  • barc
    started a topic weird green dots on desktop (with fglrx only)

    weird green dots on desktop (with fglrx only)

    I have a strange problem. When using the 9.2, 9.3 or the Ubuntu Intrepid fglrx driver, I get small green lines/dots on the bottom right of my screen.
    The only way to capture them is by shooting a photo, they are not displayed on a screenshot.

    I use an ATI 4830 card and are currently on Crunchbang which bases on Ubuntu Intrepid.


    the white and black things are traybar icons.


    This does not(!) happen using windows or the radeonhd driver, so I suppose this is a fglrx bug? Is there anything I can do to get rid of those dots?

    Thanks for your help, I really appreciate it!

    my xorg.conf:

    Code:
    Section "ServerLayout"
    	Identifier     "aticonfig Layout"
    	Screen      0  "aticonfig-Screen[0]-0" 0 0
    	Option         "AIGLX" "on"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
        Load        "glx"
    EndSection
    
    Section "ServerFlags"
    	Option	    "AIGLX" "on"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]-0"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]-0"
    	Driver      "fglrx"
    	BusID       "PCI:1:0:0"
        Option      "XAANoOffscreenPixmaps" "on"
        Option      "TexturedVideo" "on"
        Option      "VideoOverlay" "off"
        Option      "OpenGLOverlay" "off"
        Option      "Textured2D" "on"
        Option      "UseFastTLS" "1"
        Option      "BackingStore" "on"
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]-0"
    	Device     "aticonfig-Device[0]-0"
    	Monitor    "aticonfig-Monitor[0]-0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "DRI"
        Group       "Video"
        Mode        0666
    EndSection
    
    Section "Extensions"
        Option      "RENDER" "Enable"
        Option      "DAMAGE" "Enable"
        Option      "Composite" "Enable"
    EndSection
    Last edited by barc; 30 March 2009, 11:15 AM.
Working...
X