No announcement yet.

AMD Catalyst 9.3 Brings OpenGL Composite Support

  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by cutterjohn View Post
    Well, I hope that bridgman or some other ATI guys reads this, but I just upgraded to catalyst 9.3 today and turned compiz/beryl back on in Ubuntu 8.10, which worked out OK.

    However, I then left my notebook sitting long enough for it to suspend, and it froze at the password dialog box to log in. CTRL-ALT-BACKSPACE wouldn't kill X11, and other key combos including blindly attempting entering the pw failed to produce any results, so I was forced to poweroff. (I was unable to ssh in to see if the machine was still up as my desktops are down ATM until I have time to check them over.)

    Prior to this, I had thought that something I added or something with fixing the hdd laptop killer bug in 8.10 fixed the resume from suspend problem. It would now seem that turning compiz/beryl OFF is what fixed it.

    hw is MSI GT725-074US + x86-64 Ubuntu 8.10

    X3 Reunion under wine is also turning up black textures all over the place(some things render OK, others are just big black things) and main menu text does not render, if anyone cares. (Trying to see if there's any additional workarounds, as adding some wine Direct3D specific entries helped it a little, as in originally the lower left corner of the display was a big black rectangle.)
    (wine 1.1.18 + 2.6.27-11 kernel + Cat 9.2/3 + X3R v2.5)

    (X2 linux native rendered fine under 9.2, plus some simpler (non-shader requiring)windows games run under wine rendered fine.)
    Well, I got the very same problem with suspend. At least now I know I'm not the only one :-) HD 3650, intrepid


    • Are these compatible with Jaunty? I have an ATI Xpress X1270 on my laptop, and when I try to install, I get this message:

      ATI Technologies Linux Driver Installer/Packager

      Error: ./ does not support version
      default:v2:i686:lib::none:2.6.28-11-generic; make sure that the version is being
      correctly set by --iscurrentdistro

      Removing temporary directory: fglrx-install.hThgGR
      Right now im using de Open Source drivers, and they are excelent, but when it comes to 3D games or Google Earth, well it sucks.


      • Over a month and no one has any idea why composited opengl is not working on some hardware? Im using a 9800XT and this driver is complete gargage. No compositing, opengl apps crash upon opening, poor video playback.. a working driver as the last supported release for legacy hardware would have been great.


        • ATi drivers suck man, just get used to it. Window or Linux they're just absolute bullshit.

          On a card like yours you should get decent support with the open source driver. Otherwise just learn from your mistake and avoid ATi hardware.


          • Thanks man, FGLRX 9.3 doesnt support XORG 1.6 (the one on jaunty) and 9.4 doesnt support my card, so, as I want any 3d support (world of goo, Google earth, Half-life) Im going back to Ubuntu Hardy or Intrepid, or to Fedora 10.
            The Open Source drivers are quite impressive for being open source. I gotta say, ATI sucks.


            • I thought since the ATI 9.3 installer had the option for Jaunty, and since the packages built and installed properly, that the driver would work.

              First I got an unaccelerated desktop because I forgot to run aticonfig --initial after installing the packages with dpkg.

              Then after reboot, I got an error saying that the driver didn't support my device.

              I have an ATI Radeon Mobility X1400 and ATI/AMD recommend the 9.3 driver for my model since it does composite 3D and is the last proprietary driver for my model since my model belongs to the R300 series. (rather problematic...I wish I could use 9.4 and an X2300 as is found on the refresh of my laptop, although I think that GPU is slower)

              I guess this explains why Ubuntu hasn't released 9.3 (8.53X whereas 9.4 is 8.600) through its restricted drivers manager.


              • Originally posted by h3xis View Post
                Same with me. I'm running compiz on Debian Squeeze with kernel and I see no noticeable difference. glxgears still stays in place when I drag the window.
                Same here with Ubuntu 9.04. GL windows flicker and dont keep up when moving the window. Using Catalyst 9.5 and HD 3200 card.


                • Are you sure that 9.5 really got installed ?

                  AFAIK the restricted driver included with 9.04 did not provide support for flicker-free OpenGL under a compositor, maybe you're still running some pieces of that driver ?
                  Test signature


                  • for people with "freeze on X startup" problem: in kernel config, disable "Processor Type and Features -> MTRR -> x86 PAT support"

                    mplayer video playback in compiz: try options vo=x11, zoom=yes + patch from


                    now a question about 9.3 / 9.5: guys do you get anti-aliasing in redirected OpenGL app windows under Compiz? I don't..


                    • Originally posted by ypcx View Post
                      mplayer video playback in compiz: try options vo=x11
                      That's a joke and you know it :P

                      now a question about 9.3 / 9.5: guys do you get anti-aliasing in redirected OpenGL app windows under Compiz? I don't..
                      Me neither.