No announcement yet.

Is it possible to enable OpenGL 4.5 on my AMD Radeon D6750 GPU?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Is it possible to enable OpenGL 4.5 on my AMD Radeon D6750 GPU?

    Problem: I am trying to play Arma 3 via Steam on Ubuntu 18.04 LTS, but it requires OpenGL 4.1 which is not installed.

    Steps I've Taken: everything described in the linked post on the AMD forum. Basically I've tried newer and older distros of Linux, oibaf graphics drivers, and AMD supported drivers all to no avail. I believe it should be possible to run this game as I ran it on the same build just with Windows instead of Linux. I refuse to believe that Windows can do something that Linux can't so I am trying my best to fix the problem.

    Any potential solutions or approaches would be appreciated.
    Could be a Linux issue with the AMD Driver installed for Linux. Found this several years old Ubuntu Thread with the exact same issue you are having with the

  • #2
    What GL version are you seeing now ? Probably 3.3...

    AFAIK the issue is that your GPU does not have 64-bit floating point math support, which is a hard requirement for GL 4.0. There is some FP64 emulation code being worked on, but don't think it is available for your hardware yet.

    That said, since there are essentially zero apps which actually use 64-bit floating point you should be able to over-ride the GL version and run the game. Start with something like MESA_GL_VERSION_OVERRIDE=4.1 MESA_GLSL_VERSION_OVERRIDE=4.1 <program>

    If Arma requires a GL compatibility program then you might need something like MESA_GL_VERSION_OVERRIDE=4.1COMPAT rather than =4.1.
    Test signature


    • #3
      Yes I am seeing OpenGL 3.3. The part I don't understand is why my device is listed as being compatible up to OpenGL 4.4, but this information could just be wrong. I will try your solution when I am near my computer again and let you know of the result. I should really just look into the workings of the override commands within steam because I am not sure what the program is expecting when you specify <program> for example. I do understand that the other settings just force the value of the environment variables according to
      AMD Juniper, 700 MHz, 720 Cores, 36 TMUs, 16 ROPs, 1024 MB GDDR5, 1150 MHz, 128 bit