Announcement

Collapse
No announcement yet.

Slamd64 (64 Bit slackware) and ATI Radeon (catalyst) driver problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Y'learn something new every day . I had never heard of a pastebin before!

    Anyways, here is the output of dmesg and the X log file;

    First of all, dmesg;
    http://www.pastebin.ca/1369456

    And then the X server's log;
    http://www.pastebin.ca/1369457

    hope this helps!

    ljones

    Comment


    • #12
      From your dmesg dump:
      fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
      fglrx: Unknown symbol pci_disable_msi
      fglrx: Unknown symbol pci_enable_msi
      This is the same error as on Slackware 32bit. The requirements for the AMD kernel module have changed in 9.1 and above, without any mention in the changelog: it now requires PCI_MSI enabled in the kernel and this is not the case in the standard Slackware kernel (or Slamd64). You will need to recompile your kernel with this turned on for the newer fglrx to work. Otherwise you have to go back to 8.12 or prior.

      Slackware-current with 2.6.28.8 has now PCI_MSI enabled by default in the kernel and so does Slamd64-current. However I haven't tried fglrx in -current yet (do not want to upgrade to kde4 just yet).

      Hope this is helpful
      Last edited by ArTourter; 23 March 2009, 07:04 PM.

      Comment


      • #13
        Originally posted by ArTourter View Post
        From your dmesg dump:


        This is the same error as on Slackware 32bit. The requirements for the AMD kernel module have changed in 9.1 and above, without any mention in the changelog: it now requires PCI_MSI enabled in the kernel and this is not the case in the standard Slackware kernel (or Slamd64). You will need to recompile your kernel with this turned on for the newer fglrx to work. Otherwise you have to go back to 8.12 or prior.

        Slackware-current with 2.6.28.8 has now PSI_MSI enabled by default in the kernel and so does Slamd64-current. However I haven't tried fglrx in -current yet (do not want to upgrade to kde4 just yet).

        Hope this is helpful
        Yep looks like I'll have to compile a kernel. I checked the normal slackware current version (it is currently 2.6.28.8 as you say) however the slamd64 kernel current appears to be different (example here - ftp://ftp.gtlib.gatech.edu/pub/slamd...t/slackware/a/ ), they are using 2.6.28.7 . I tried installing this on the offchance that PSI_MSI would be enabled, but no luck, installing the newer kernel made no difference, no accelration.

        Guess its time to download a kernel and compile it !

        EDIT
        Now things might have worked -- after reinstalling the drivers at the command line and typing aticonfig --initial things may be working (plus reboot). Glxinfo now says "yes" to direct rendering; glxgears gives me around 521 FPS, while fgl_glxgears comes in at just a little more, around 644 FPS. Though I have no idea if those numbers are bad, good or about normal!

        As for KDE 4 I see its packages are in current, however I have no idea which packages to install! (I don't think *everything* KDE 4 in slackware needs is in the KDE/ directory).

        Should anyone need it btw after installing the new kernel bits 'n' pieces (from here - ftp://ftp.gtlib.gatech.edu/pub/slamd...t/slackware/a/ ) and installing these files :


        kernel-firmware-2.6.28.7-noarch_slamd64-1.tgz
        kernel-generic-2.6.28.7-x86_64_slamd64-1.tgz
        kernel-huge-2.6.28.7-x86_64_slamd64-1.tgz
        kernel-modules-2.6.28.7-x86_64_slamd64-1.tgz
        kernel-source-2.6.28.7-noarch_slamd64-1.tgz


        I also adjusted my lilo.conf (and and ran lilo) to point at /boot/vmlinuz-huge-2.6.28.7

        Here's the X server log after doing the above:
        http://www.pastebin.ca/1369730

        And the output of dmesg:
        http://www.pastebin.ca/1369732

        uname -r reports 2.6.28.7

        If this is all working now I must type it all out as a sequence of steps so I can follow it through! And the system didn't restart if I exited X !

        ljones
        Last edited by ljones; 23 March 2009, 07:36 PM.

        Comment


        • #14
          Originally posted by ljones View Post
          Yep looks like I'll have to compile a kernel. I checked the normal slackware current version (it is currently 2.6.28.8 as you say) however the slamd64 kernel current appears to be different (example here - ftp://ftp.gtlib.gatech.edu/pub/slamd...t/slackware/a/ ), they are using 2.6.28.7 . I tried installing this on the offchance that PSI_MSI would be enabled, but no luck, installing the newer kernel made no difference, no accelration.

          Guess its time to download a kernel and compile it !
          Hmm, if the 2.6.28.7 in slamd64 does not work, then I am not quite sure what else needs to be done as from the config file
          CONFIG_PCI_MSI=y
          Do you actually get the same error, or do you get something else?

          Comment


          • #15
            I have a reply to prior your edit somehow stuck in moderation (probably due to a url I included)

            but if fgl_glxgears actually runs, that means that the fglrx driver is running which seems to be a huge improvement to your previous situation.

            regarding the framerate, I would not know as it is not something I really care about myself.

            Out of interest, did you recompile your kernel at all or this is still the stock slamd64-current kernel where you only recompile the AMD driver and initialised it?

            BTW, to explain the version difference between slackware and slamd64, the changes appear first in slack and are then ported to slamd64. 2.6.28.8 should appear in slamd64-current at the next batch of changes unless .9 or newer is released since then and slackware has it in the tree.

            Comment


            • #16
              You really use lilo? I currently switched over to grub2 for next system and you do not even use grub? With something like update-grub to integrated kernels automatically... Wow, that is really a legacy system.

              Comment


              • #17
                @Kano
                go and troll somewhere else, will ya?

                Comment


                • #18
                  Well best install grub if possible lilo is really outdated. You have to reinstall it everytime, grub only needs config file updates.

                  Comment


                  • #19
                    yes because simply typing lilo is really hard and complicated.

                    listen, you use what you want and let every body else use what works for them, ok? your arrogant attempt at evangelism is out of place.

                    as I said earlier, troll somewhere else.

                    Comment


                    • #20
                      x.x

                      There still seems to be just one more problem!

                      If I run X and (let's say) fgl_glxgears as root, no problems.

                      But as a normal (non-root) user, X crashes on first run with a blank screen, I have to stop it and restart it then it works. But then fgl_glxgears fails as non-root;

                      Code:
                      libGL error: open DRM failed (Operation not permitted)
                      libGL error: reverting to (slow) indirect rendering
                      X Error of failed request : GLXBadDrawable
                       Major opcode of failed request:  144 (GLX)
                       Minor opcode of failed request:  5 (X_GLXMakeCurrent)
                       Serial number of failed request: 45 
                       Current serial number in output stream: 45
                      BTW I used the slamd64-current kernel.

                      I don't get the error message as root, and direct rendering works - but only as root!

                      EDIT
                      Ok, I've half solved the one with the fgl_glxgears not working as root with the following:

                      Code:
                      Section "DRI"
                       Mode 0666
                      EndSection
                      Though X as non root still fails first time as non-root!

                      Looks like there's something wrong in dmesg; (look at lines 360 onwards);

                      dmesg --
                      http://pastebin.ca/1370762

                      And even when X was working, I noticed this:

                      (from /var/log/Xorg.0.log)
                      Code:
                      AIGLX error: dlopen of /usr/lib64/xorg/modules/dri/fglrx_dri.so failed (/usr/lib64/xorg/modules/dri/fglrc_dri.so : cannot open shared object file : no such file or directory)
                      But I managed to fix that missing file with ' ln -s /usr/X11R6/lib64/modules/dri/fglrx_dri.so /usr/lib64/xorg/modules/dri/fglrx_dri.so !

                      X Still died on 1st run though as non root.....

                      ljones
                      Last edited by ljones; 24 March 2009, 03:05 PM.

                      Comment

                      Working...
                      X