Announcement

Collapse
No announcement yet.

new 6900 xt, memory staying at 1000mhz

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • new 6900 xt, memory staying at 1000mhz

    so i noticed really high idle temps and power usage with my 6900 xt i just got. digging around i noticed that the memory frequency is being stuck at 1000mhz.
    Code:
    [orlfman@linux64: ~]$ sudo cat /sys/class/drm/card0/device/pp_dpm_mclk
    [sudo] password for orlfman:
    0: 96Mhz
    1: 456Mhz
    2: 673Mhz
    3: 1000Mhz *
    [orlfman@linux64: ~]$
    i'm not sure if this is normal considering it is showing four power states for memory. anyone else with a 6900 xt or even a 6800 xt notice this behavior? I have the following:
    Code:
     Kernel: 5.10.11-arch1-1 Firmware: 20201218.646f159-1 Mesa: 20.3.4
    i also have amdgpu added to /etc/mkinitcpio.conf for early KMS. at first i figured it might be my monitor, as i have a 165hz 1440p ips screen. but changing refresh rate down to 60hz doesn't change the memory clock.

  • #2
    ok so after asking on gamingonlinux forum as well, i got back quite a few replies from owners of 6800, 6800 xt's, and 6900 xt's that are noticing the same behavior problem too.

    from digging around some more:
    Code:
    [orlfman@linux64: ~]$ sudo cat /sys/class/drm/card0/device/power_dpm_state
    [sudo] password for orlfman:
    performance
    [orlfman@linux64: ~]$
    as you can see, it reports back performance for its power state. i think default should be balanced.
    Code:
    [orlfman@linux64: ~]$ sudo echo "balanced" > /sys/class/drm/card0/device/power_dpm_state
    [sudo] password for orlfman:
    [orlfman@linux64: ~]$ sudo cat /sys/class/drm/card0/device/power_dpm_state
    balanced
    [orlfman@linux64: ~]$
    core frequency changes are as aggressive as performance, memory still stuck at 1000mhz. the card still behaves as performance.
    Code:
    echo "low" > /sys/class/drm/card0/device/power_dpm_force_performance_level
    issuing low to force the lowest possible power state doesn't change anything either. i think as of right now, only the performance power mode is the only state supported. which can explain why the memory frequency doesn't change. only core frequency changes but it is aggressive in switching. hopefully we can get more power states in newer firmware or kernel drivers.

    ultimately this isn't necessary bad. its not going to hurt the card. its no different than system memory that runs at its maximum speed 24/7. it just causes slightly higher power consumption and slightly more heat at idle.

    i also "fixed" my high idle temps by "fixing" the fan stop problem.
    Code:
    [orlfman@linux64: ~]$ sudo echo "1" > /sys/class/drm/card0/device/hwmon/hwmon4/pwm1_enable
    [sudo] password for orlfman:
    [orlfman@linux64: ~]$ sudo echo "40" > /sys/class/drm/card0/device/hwmon/hwmon4/pwm1
    40 sets the fan's to spin at 15% of their rated pwm speed. i don't mind doing this as if i used windows i would be using the control panel to take control of the fan speed too. i really don't like fan stop. when i game i'll just either reset it back to auto or set it to 70% (179).

    to set fan control back to the cards vbios control issue:
    Code:
    sudo echo "2" > /sys/class/drm/card0/device/hwmon/hwmon4/pwm1_enable
    or just reboot. all changes from everything above are reverted back to default after a reboot.

    i have compositing disabled too.

    Comment


    • #3
      i want to give an update. I installed windows on its own ssd to mess around with 3dmark benchmarking, and I noticed high idle power usage (same as Linux) and vram clocked at 1000mhz (2000mhz reported under windows). So this doesn't appear to be a Linux only issue. AMD must have a good reason why they are clocking the ram so high at idle on Navi 2.

      Comment


      • #4
        Having just installed mine this week mine too does the same, Temps for me are fine (30 ish idle) Though that maybe due to water cooling.

        What I am finding is rocm(opencl) refuses to work for me

        Shame as opencl on my Vii worked great .

        Comment


        • #5
          Originally posted by fafreeman View Post
          i want to give an update. I installed windows on its own ssd to mess around with 3dmark benchmarking, and I noticed high idle power usage (same as Linux) and vram clocked at 1000mhz (2000mhz reported under windows). So this doesn't appear to be a Linux only issue. AMD must have a good reason why they are clocking the ram so high at idle on Navi 2.
          G'day, I know this is an old thread but I've got a 6900XT as well and my clocks are also stuck at 1GHz even under load.

          Shouldn't the memory be at least 2GHz specially under load?
          ‚Äč
          I've got a Powercolor liquid devil ultimate 6900xt

          Comment


          • #6
            Originally posted by DanglingPointer View Post

            G'day, I know this is an old thread but I've got a 6900XT as well and my clocks are also stuck at 1GHz even under load.

            Shouldn't the memory be at least 2GHz specially under load?
            The clock rate exposed in the driver is the actual clock rate, not the effective transfer rate. See the driver documentation for more information:

            Comment


            • #7
              Originally posted by agd5f View Post

              The clock rate exposed in the driver is the actual clock rate, not the effective transfer rate. See the driver documentation for more information:
              https://www.kernel.org/doc/html/late...od-clk-voltage
              I see, But should the memory clock not alter due to load though ? Mine is constantly stuck @1000Mhz whether its sat on the desktop or playing a game .

              Comment


              • #8
                Originally posted by pete910 View Post

                I see, But should the memory clock not alter due to load though ? Mine is constantly stuck @1000Mhz whether its sat on the desktop or playing a game .
                There are some cases when the memory clock is fixed at maximum, like having multiple monitors or high refresh rates. This is a question that is asked quite a lot, and I've never seen a case where it wasn't "correct". How and why this happens is for someone else to answer though, since I just know this is normal.

                Comment

                Working...
                X