Announcement

Collapse
No announcement yet.

Dell G5 15 (RX5600M) Help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • zakhrov
    replied
    OpenGL games ramp the clock speed down to around 400MHz. The speeds ramp back up once they are closed


    Leave a comment:


  • zakhrov
    replied
    Proton+DXVK games run on the dGPU at around 800MHz The clock speed in the screenshot above is from the iGPU. I had forgotten to set the pci_dev parameter in MangoHud. Here are updated screenshots





    Last edited by zakhrov; 24 August 2020, 09:09 AM.

    Leave a comment:


  • zakhrov
    replied
    Originally posted by agd5f View Post
    Make sure the OpenGL application is actually running on the dGPU rather than the APU.
    It is as far as I know. Running without DRI_PRIME set lets it run on the integrated graphics. The APU runs at 1500MHz but the dGPU runs at a much lower clock speed

    Leave a comment:


  • agd5f
    replied
    Make sure the OpenGL application is actually running on the dGPU rather than the APU.

    Leave a comment:


  • zakhrov
    replied
    OK I just got Mangohud working and I can confirm that it is specific to OpenGL. Assassin's Creed running on Proton+DXVK works flawlessly with the 5600M running at 1500MHz

    Leave a comment:


  • zakhrov
    started a topic Dell G5 15 (RX5600M) Help

    Dell G5 15 (RX5600M) Help

    I recently bought a Dell G5 15 SE gaming laptop with a Ryzen 5 4600H and the Radeon RX5600M discrete graphics card. The laptop works fine with the amdgpu.runpm=0 kernel parameter but I have observed some strange behaviour with the 5600M. If I run any GPU intensive OpenGL workload like Unigine Heaven, Gallium Hud shows its clock speed ramping to only around 400MHz. Forcing the high power profile using
    Code:
    echo high > /sys/class/drm/card0/device/power_dpm_force_performance_level
    does not help. I can see it running at the rated 1700MHz when running glxgears but once I fire up Heaven it ramps back down to 400MHz. I know it is not thermal throttling because the temperatures are below 70C and I can see through Gallium hud that the clock speed ramps up with a decrease in GPU load. It is not specific to Heaven eather, Tomb Raider also shows a similar behaviour. I havent ben able to get clock speed information for DXVK games though so I am not sure if Vulkan is similarly affected. I am running openSUSE Tumbleweed with kernel 5.8 and Mesa 20.1.4
    https://imgur.com/Z2IBDxR

Working...
X