Announcement

Collapse
No announcement yet.

ATI Radeon 9550 (almost working?)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI Radeon 9550 (almost working?)

    Hi,

    I'm happy to have found this forum!

    Anyways... I've tried installing the drivers from the ATI site (btw... why is "x86_64" always part of the installer file even when you don't specify 64-bit?).

    The install process runs smoothly (thanks to help I've found searching this forum, and partha's website). But after I run 'aticonfig --initial', I get this when running fglrxinfo:

    Code:
    Xlib:  extension "XFree86-DRI" missing on display ":0.0".
    display: :0.0  screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
    So, although I didn't get any errors whatsoever during the install, it's clear that the ATI drivers are not being used.

    Also, when I reboot my computer X doesn't start... and so I do a rescue to change the xorg.conf file so I can get X started again.

    Any suggestions?

  • #2
    Ok... I tried a reinstall, and now I'm having more serious problems. When I try to run something simple like aterm I get this error:

    aterm: error while loading shared libraries: /usr/lib/xorg/libGL.so.1: cannot restore segment prot after reloc: Permission denied


    Should I just stop while I'm ahead?

    Cheers.

    Comment


    • #3
      The ATI installer uses a combined 32-bit and 64-bit package. The driver will work whether your using i386 or x86_64 Linux.

      As far as your problems go, how are you installing the drivers? Are you using a buildpkg command or the graphical interface? The GUI path won't work on newer distributions.

      What Linux distribution are you using?
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #4
        Thanks for responding.

        I'm using FC6 (i686), just reinstalled the latest kernel today.

        From the command line:

        ./ati-drivername-.run --buildpkg Fedora/FC6

        That's what I used.

        Comment


        • #5
          Output of:

          cat /var/log/Xorg.0.log | grep EE
          Michael Larabel
          http://www.michaellarabel.com/

          Comment


          • #6
            Code:
            cat /var/log/Xorg.0.log | grep EE
            
                    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
            (II) Loading extension MIT-SCREEN-SAVER
            (EE) AIGLX: Screen 0 is not DRI capable
            (EE) AIGLX: Screen 1 is not DRI capable
            I noticed you moved this to the AMD/ATI thread. You'll have to forgive me if I'm a complete idiot... but do these drivers only work with AMD?

            I got the x86_64 ones working with my radeon xpress 200M on my laptop no problem (AMD 64). But what I'm working on now in my desktop, and it's Intel (not by choice!).

            Comment


            • #7
              AMD bought out ATI. They are the AMD drivers.

              Aha, that output makes it an easy fix.

              Make sure you have:

              Section "Extensions"
              Option "Composite" "Off"
              Option "AIGLX" "Off"
              EndSection

              In your xorg.conf.
              Michael Larabel
              http://www.michaellarabel.com/

              Comment


              • #8
                Hmm... I did have that at one point, but I'll try it again.

                Basically, since X didn't start, I let it try to start itself with a default configuration.

                So then i tried to do the install process again by doing a

                Code:
                yum remove ATI-fglrx
                but when I try to install the rpms again, it says that the 'package kernel-module-ATI-fglrx-2.6.blahblah.. is already installed.

                So I tried a rpm -e on that specific rpm, but then it tells me that it isn't installed!

                I must be losing it. But basically I have to do the install again anyways.

                Comment


                • #9
                  Do you know how I can start over without having to reinstall fc6?

                  Comment


                  • #10
                    You could reinstall them with --force argument.
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment

                    Working...
                    X