No announcement yet.

Catalyst 9.2 monitor resolution problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst 9.2 monitor resolution problems

    I have been using Catalyst 9.1 with hd 4670 graphic card before i upgradet to 9.2.

    Installation went well, and after restarting X everything looked like before. Next i wanted to test the video playback with metacity compositing enabled (its disabled by default so i had to enable it through gconf-editor). While resizing mplayer window my machine crashed. I had to hardreset bcos no keystrokes were accepted and the screen was just black.

    After reboot the first unexpected behavoir was that gdm starts up with 1600x1200 resolution. Before it was 1280x1024. After doing some kind of research (web & logs) i discovered, that fglrx is using the supported edid modes. If i try to apply custom modelines in my xorg.conf it just fails by being ignored by fglrx.

    (II) fglrx(0): ***Display: ConnectedDisplayTypes=0x00000010, disabled=0x00000000
    (II) fglrx(0): Connected Display1: CRT on secondary DAC [crt2]
    (II) fglrx(0): Display1 EDID data ---------------------------
    (II) fglrx(0): Manufacturer: SNY  Model: 571  Serial#: 6031663
    (II) fglrx(0): Year: 2002  Week: 20
    (II) fglrx(0): EDID Version: 1.2
    (II) fglrx(0): Analog Display Input,  Input Voltage Level: 0.700/0.300 V
    (II) fglrx(0): Sync:  Separate  Composite  SyncOnGreen
    (II) fglrx(0): Max H-Image Size [cm]: horiz.: 33  vert.: 24
    (II) fglrx(0): Gamma: 2.50
    (II) fglrx(0): DPMS capabilities: Off; RGB/Color Display
    (II) fglrx(0): First detailed timing is preferred mode
    (II) fglrx(0): GTF timings supported
    (II) fglrx(0): redX: 0.625 redY: 0.340   greenX: 0.280 greenY: 0.605
    (II) fglrx(0): blueX: 0.155 blueY: 0.070   whiteX: 0.283 whiteY: 0.298
    (II) fglrx(0): Supported VESA Video Modes:
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected] (interlaced)
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): [email protected]
    (II) fglrx(0): Manufacturer's mask: 0
    (II) fglrx(0): Supported Future Video Modes:
    (II) fglrx(0): #0: hsize: 640  vsize 480  refresh: 85  vid: 22833
    (II) fglrx(0): #1: hsize: 800  vsize 600  refresh: 85  vid: 22853
    (II) fglrx(0): #2: hsize: 1024  vsize 768  refresh: 85  vid: 22881
    (II) fglrx(0): #3: hsize: 1152  vsize 864  refresh: 85  vid: 22897
    (II) fglrx(0): #4: hsize: 1280  vsize 960  refresh: 75  vid: 20353
    (II) fglrx(0): #5: hsize: 1280  vsize 960  refresh: 85  vid: 22913
    (II) fglrx(0): #6: hsize: 1280  vsize 1024  refresh: 85  vid: 39297
    (II) fglrx(0): #7: hsize: 1600  vsize 1200  refresh: 75  vid: 20393
    (II) fglrx(0): Supported additional Video Mode:
    (II) fglrx(0): clock: 94.5 MHz   Image Size:  312 x 234 mm
    (II) fglrx(0): h_active: 1024  h_sync: 1072  h_sync_end 1168 h_blank_end 1376 h_border: 0
    (II) fglrx(0): v_active: 768  v_sync: 769  v_sync_end 772 v_blanking: 808 v_border: 0
    (II) fglrx(0): Ranges: V min: 48  V max: 170 Hz, H min: 30  H max: 96 kHz, PixClock max 220 MHz
    (II) fglrx(0): Monitor name: CPD-G220
    (II) fglrx(0): Serial No: 6031663
    (II) fglrx(0): EDID (in hex):
    (II) fglrx(0): 	00ffffffffffff004dd971052f095c00
    (II) fglrx(0): 	140c01020e2118962b0cc9a057479b27
    (II) fglrx(0): 	12484cffff803159455961597159814f
    (II) fglrx(0): 	81598199a94fea240060410028303060
    (II) fglrx(0): 	130038ea1000001e000000fd0030aa1e
    (II) fglrx(0): 	6016000a202020202020000000fc0043
    (II) fglrx(0): 	50442d473232300a20202020000000ff
    (II) fglrx(0): 	00363033313636330a202020202000a4
    (II) fglrx(0): End of Display1 EDID data --------------------
    (II) fglrx(0): Output DFP1 using monitor section Sony
    (II) fglrx(0): Output DFP3 has no monitor section
    (II) fglrx(0): Output CRT1 has no monitor section
    (II) fglrx(0): Output CRT2 has no monitor section
    (II) fglrx(0): Output TV has no monitor section
    (II) fglrx(0): Output COMPONENT_VIDEO has no monitor section
    (II) fglrx(0): Output DFP1 disconnected
    (II) fglrx(0): Output DFP3 disconnected
    (II) fglrx(0): Output CRT1 disconnected
    (II) fglrx(0): Output CRT2 connected
    (II) fglrx(0): Output TV disconnected
    (II) fglrx(0): Output COMPONENT_VIDEO disconnected
    (II) fglrx(0): Output CRT2 using initial mode 1600x1200
    As you can see in the last lines fglrx is using my monitor section from xorg.conf to DFP1. But DFP1 is not connected. The only connected monitor is on crt2. How can i force fglrx to use monitor section ("Sony") with crt2? Below is my xorg.conf.

    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "Screen1" 0 0
    	InputDevice    "Generic Keyboard"
    	InputDevice    "Configured Mouse"
    Section "Files"
    #	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
    #	FontPath	"/usr/share/fonts/X11/cyrillic"
    #	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
    #	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    #	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    #	FontPath	"/usr/share/fonts/X11/Type1"
    #	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
    #	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
    #	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
    	# path to defoma fonts
    	FontPath     "/usr/share/fonts/X11/misc"
    	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    Section "Module"
    	Load  "bitmap"
    	Load  "ddc"
    	Load  "extmod"
    	Load  "freetype"
    	Load  "glx"
    	Load  "int10"
    	Load  "vbe"
    Section "InputDevice"
    	Identifier  "Generic Keyboard"
    	Driver      "kbd"
    	Option	    "CoreKeyboard"
    	Option	    "XkbRules" "xorg"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "de"
    	Option	    "XkbVariant" "nodeadkeys"
    Section "InputDevice"
    #	Option		"ButtonMapping"	"1 2 3 6 7 8"
    #	Option		"Buttons"	"8"
    #	Option		"Phys"	"*/input0"
    #	Option		"Name" 	"Logitech USB-PS/2 Optical Mouse"
    #	Option		"Dev Phys" "usb-0000:00:03.1-2/input0"
    #	Option          "evBits"        "+1-2"
    #	Option          "keyBits"       "~272-287"
    #	Option          "relBits"       "~0-2 ~6 ~8" 
    	Identifier  "Configured Mouse"
    	Driver      "evdev"
    	Option	    "CorePointer"
    	Option	    "Device" "/dev/input/by-id/usb-Logitech_USB-PS.2_Optical_Mouse-event-mouse"
    #	Option		"ZAxisMapping"	"4 5"
    Section "Monitor"
    	Identifier   "Sony"
    	HorizSync    30.0 - 96.0
    	VertRefresh  48.0 - 170.0
    	ModeLine     "[email protected]" 89.6 800 880 1040 1120 600 602 614 640
    	Option	    "VendorName" "Some Vendor"
    	Option	    "ModelName" "Some Model"
    	Option	    "DPMS" "on"
    Section "Device"
    #	Option	    "UseFastTLS" "1"
    #	Option "NvAGP" "0"
    ##	Option "NoLogo" "True"
    #	Option "AllowGLXWithComposite" "1"
    #	Option "AddARGBGLXVisuals" "True"
    #	Option "DisableGLXRootClipping" "True"
    #	Option "Coolbits" "1"
    #	Option "TripleBuffer" "1"
    #	Option "RenderAccel" "True"
    #	Option "AccelMethod" "EXA"
    #	Option "ConnectedMonitor" "CRT"
    #	Option "BackingStore" "true"
    #	Option "DamageEvents" "true"
    #	Option		"TexturedXrender" "on"
    #	Option	    "XaaNoOffscreenPixmaps" "true"
    #	Option	    "MonitorLayout" "CRT,CRT"
    #	Option	    "Textured2D" "on"
    #	Option	    "EnableMonitor" "crt2"
    	Identifier  "RV730XT"
    	Driver      "fglrx"
    	Option	    "ForceMonitors" "crt1,crt2"
    	BusID       "PCI:1:00:0"
    Section "Screen"
    	Identifier "Screen1"
    	Device     "RV730XT"
    	Monitor    "Sony"
    	DefaultDepth     24
    	SubSection "Display"
    		Depth     4
    		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    	SubSection "Display"
    		Depth     8
    		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    	SubSection "Display"
    		Depth     15
    		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    	SubSection "Display"
    		Depth     16
    		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    	SubSection "Display"
    		Depth     24
    		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "[email protected]" "640x480"
    Section "DRI"
    	Mode         0666
    I really dont know whats wrong. Before the crash everything worked like expected. Is it possible that this crash damaged my hardware? If you need further information dont bother to ask.

    Before i forget. When i open amd control Center it take about 15 seconds to open. While loading the programm my monitor is flickering a bunch of times. I found out, that every flickering produces output in my xorg log files.

    Obviously switching back to 9.1 does not solve anything. Since the crash everything is fucked up
    Last edited by stancil; 02-27-2009, 09:41 AM.

  • #2
    Same problem with CCC for me except that it freezes my machine(same driver and same graphic card 4670)

    Last edited by bibi; 02-24-2009, 05:29 AM.


    • #3
      The only resolution working here (x1650 card) is [email protected]
      and the flickering is giving me a headache.

      Fglrx 9.2 is detecting incorrect modelines.
      It also ignores any custom modelines in xorg.conf
      (II) fglrx(0): Printing DDC gathered Modelines:
      (II) fglrx(0): Modeline "1024x768"x0.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz)
      (II) fglrx(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
      (II) fglrx(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500-hsync -vsync (37.5 kHz)
      (II) fglrx(0): Modeline "640x480"x0.0   25.20  640 656 752 800  480 490 492 525-hsync -vsync (31.5 kHz)
      (II) fglrx(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449-hsync +vsync (31.5 kHz)
      (II) fglrx(0): Modeline "1024x768"x0.0   78.80  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.1 kHz)
      (II) fglrx(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
      (II) fglrx(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
      (II) fglrx(0): Modeline "1280x1024"x59.9  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync (63.7 kHz)
      Here are a few proper modelines from the xorg log with 9.1:
      (II) fglrx(0): Modeline "1024x768"x85.0   94.50  1024 1072 1168 1376  768 769 772 808 (68.7 kHz)
      (**) fglrx(0):  Default mode "1024x768": 78.8 MHz (scaled from 0.0 MHz), 60.0 kHz, 75.0 Hz
      (II) fglrx(0): Modeline "1024x768"x75.0   78.75  1024 1040 1136 1312  768 769 772 800 (60.0 kHz)
      (**) fglrx(0):  Default mode "1024x768": 78.4 MHz (scaled from 0.0 MHz), 57.7 kHz, 72.0 Hz
      (II) fglrx(0): Modeline "1024x768"x72.0   78.43  1024 1080 1192 1360  768 769 772 801 +hsync (57.7 kHz)
      (**) fglrx(0):  Default mode "1024x768": 75.0 MHz (scaled from 0.0 MHz), 56.5 kHz, 70.0 Hz
      (II) fglrx(0): Modeline "1024x768"x70.0   75.00  1024 1048 1184 1328  768 771 777 806 +hsync +vsync (56.5 kHz)
      (**) fglrx(0):  Default mode "1024x768": 65.0 MHz (scaled from 0.0 MHz), 48.4 kHz, 60.0 Hz
      (II) fglrx(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 +hsync +vsync (48.4 kHz)
      (**) fglrx(0):  Default mode "1024x768": 44.9 MHz (scaled from 0.0 MHz), 35.5 kHz, 43.0 Hz (I)
      (II) fglrx(0): Modeline "1024x768"x43.0   44.90  1024 1032 1208 1264  768 768 772 817 interlace (35.5 kHz)
      (**) fglrx(0):  Default mode "800x600": 56.2 MHz (scaled from 0.0 MHz), 53.7 kHz, 85.0 Hz
      (II) fglrx(0): Modeline "800x600"x85.0   56.25  800 832 896 1048  600 601 604 631 (53.7 kHz)
      This output from the 9.2 log concerns me too:
      (II) fglrx(0): Output DFP1 using monitor section aticonfig-Monitor[0]-0
      (II) fglrx(0): Output DFP2 has no monitor section
      (II) fglrx(0): Output CRT1 has no monitor section
      (II) fglrx(0): Output CRT2 has no monitor section
      (II) fglrx(0): Output TV has no monitor section
      (II) fglrx(0): Output COMPONENT_VIDEO has no monitor section
      (II) fglrx(0): Output DFP1 disconnected
      (II) fglrx(0): Output DFP2 disconnected
      (II) fglrx(0): Output CRT1 connected
      (II) fglrx(0): Output CRT2 disconnected
      (II) fglrx(0): Output TV disconnected
      (II) fglrx(0): Output COMPONENT_VIDEO disconnected
      (II) fglrx(0): Output CRT1 using initial mode 1280x1024
      (**) fglrx(0): Display dimensions: (330, 240) mm
      (**) fglrx(0): DPI set to (98, 135)
      Why does CRT1 have no monitor section?
      How would I go about adding one?

      Found that adding
      Option	    "Monitor-CRT1" "aticonfig-Monitor[0]-0"
      to the "Device" section, eliminates the message "CRT1 has no monitor section".
      Doesn't help the situation though.
      Oh well. Back to 9.1 for now.
      Last edited by lurch; 02-25-2009, 03:59 PM.


      • #4
        I have this problem too, has someone filed a bug report with ATI?

        It keeps detecting my monitor as 1600x1200 when it is in fact 1920x1200. Can't change this in xorg or xrandr, even set up a monitor section for CRT1 (it did nothing). I hope that I can get 9.1 to work.

        I am really really sick of these horrible fglrx releases. I've spent hours getting fglrx to work; I'm never buying from them again.

        Also, CCC takes forever to start and the screen keeps flashing while it's opening. When starting X the screen repeatedly flashes for about 10 seconds before showing anything.


        • #5
          Originally posted by stancil View Post
          Obviously switching back to 9.1 does not solve anything.
          I don't use normal distros, graphical logon or know how you are doing install/uninstall, so this method may not work for you or bugger things up even worse!.

          What I do is uninstall by running the script in /usr/share/ati/ after you have done that rm -r /etc/ati
          then reinstall and run aticonfig --initial.

          If you have a working /etc/xorg.conf you want to use you could back that up first and reinstate rather than aticonfig initial.

          I haven't used fglrx much lately, but did notice that since 8-12 it stopped using the resolution I specified in xorg.conf, instead prefering the last used from it's database in /etc/ati. Probably not an issue unless like me you like to use different startx scripts to start with different res/window managers depending on what you want to do.

          I did manage to confuse it into submission by starting with an xorg.conf that had a custom modeline. It didn't start with it, but it became available in amdcccle and I could switch to it, which I did. Quitting X and restarting with with a config without that modeline meant it actually respected the res I asked for. I didn't test for long (I haven't even used 9.2) but it seemed that the new res didn't then get saved as the last res used, so I could start with various configs and it worked like it used to.


          • #6
            Problem solved for me

            I've downloaded Catalyst 8.12 from Ati then executed /usr/share/ati/ and rm -rf /etc/ati .

            After installation of 8.12 i backed up the newly created /etc/ati and installed 9.2 without running any uninstall scripts and without removing /etc/ati. The old problem occured (watch 1st post) again.

            I have diff'ed the old and new amdpcsdb which is created inside of /etc/ati.

            The output looks as follows:

            --- ati_old/amdpcsdb	2009-02-27 00:32:16.749246065 +0100
            +++ ati_new/amdpcsdb	2009-02-27 00:42:43.694362325 +0100
            @@ -126,16 +126,11 @@
            -DALR6 CRT2_MaxModeInfo=R00000000000800000006000000000000A0000000
            +DALR6 CRT2_MaxModeInfo=R0000000040060000B00400000000000055000000
            @@ -146,20 +141,9 @@
             DALR6 CRT2=R0000000000000000000000006400000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000640000006419000000000000000000000000000000000000000000000000000000000000
            -DALR6 CRT21024x768x0x60=R000000000000000000000000000000000000000000000000010000000100000000000000000000000000000000000000
            -DALR6 CRT21024x768x0x85=R000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
            +DALR6 CRT21600x1200x0x75=R000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
             DALR6 CRT21280x1024x0x85=R000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
            Because i am in a hurry i have no time to do more research until tomorrow so i just copied the old file in the new directory and it worked like in previous versions. So the answer is probably in the posted diff.

            EDIT: Is this file (amdpcsdb) somehow documented?
            Last edited by stancil; 02-26-2009, 11:59 PM.


            • #7
              Could you please post your whole amdpcsdb file? I'm running Ubuntu 9.04 and have no option of going back to an older Catalyst version than Catalyst 9.4.


              • #8
                Put under [AMDPCSROOT/SYSTEM/DDX]

                That should solve the problem, if its like mine issue.


                • #9
                  Originally posted by stancil View Post
                  Put under [AMDPCSROOT/SYSTEM/DDX]

                  That should solve the problem, if its like mine issue.
                  I realized that I have spent weeks trying get ATI graphics cards to work for me (I had a laptop with one as well). I'm sick and tired and quite frankly, it's not worth my time. I ordered a Nvidia card yesterday. They seem to be somewhat on top of things anyways, like video acceleration etc.

                  I hope the open source drivers catch up and get into a position where they support features like Video acceleration, 3D acceleration etc. Not until I see that it's working well with those drivers will I look at ATI again.