No announcement yet.

M2A-VM HDMI nightmare!

  • Filter
  • Time
  • Show
Clear All
new posts

  • M2A-VM HDMI nightmare!

    I have an asus "M2A-VM HDMI".

    I got a gentoo on that mobo, and got a tv as output with hdmi, using fglrx.

    Sometimes the screen is blue (as "no signal") at startup. The "blue status" survives the reboot, so i have to poweroff the pc and restart it, then it works.

    I have kdm running at startup with autologin to an user, and I give commands usually with ssh from another pc.

    The screen is an "HD Ready" TV, so the resolution inside xorg.conf is set to 1280x720.

    No configuration changes between "blue status" and "normal work". Nor the log (as it seems)

    Today it stopped completely to work, only blue screen. I tried to update the ati-driver (gentoo's fglrx package), the kernel (from 2.6.25 to 2.6.27) and tried even radeonhd and radeon. No luck.

    A strange problem happened when I tried to revert to pre-update status.
    This happens when the computer is switched off for 10 minutes circa.
    The monitor shows on the osd that it's receiving a black 720p signal for a short time, then it returns on the console. seems X starts, then there is a message on the log saying
    "(II) fglrx(0): Shutdown CMMQS"
    then (or before, can't tell) kdm goes in timeout and kills the attempt of X to startup.
    Further attempts (even after a reboot) go to the "blue screen" status.

    Is there anyone who can understand what it's happening?

    Unfortunately I overwritten the xorg.conf and logs of when it worked, but I can provide logs of the actual status.

  • #2
    well, the blue screen is in the bios too? is it a linux problem or a motherboard problem?

    btw, I can't help you, but I have the same motherboard used with tv-out, so, just for information, are you able to play HD video? do you notice any tearing? using which software?


    Good luck with your problem


    • #3
      I was able until yesterday to see HD videos using mplayer, fglrx and X.

      The bios is visible, the "blue screen" (seems it's a message from the tv that it's not receiving signal) happened sometimes at X startup, where a restart resolved (most of the times).

      Yesterday blue screen remained for an entire day of retries. No, in fact after having the pc shut off for 10 minutes it now shows a black screen (coming from X) at 720p, and after a second it returns to the console. I'll post log as soon I can get my hands on it.


      • #4
        I'm not very expert, but have you tried to delete /etc/ati/amdpcsdb and reboot when the blue screen doesn't go away?


        • #5
          Originally posted by kkkk View Post
          I'm not very expert, but have you tried to delete /etc/ati/amdpcsdb and reboot when the blue screen doesn't go away?
          I did that, I tested even aticonfig --initial and such, but no luck


          • #6
            ok I have some logs
            first: starting X from terminal

            second: my xorg.conf

            third: /var/log/Xorg.0.log
            (the "Shutdown CMMQ" line appears when I ctrl-C the X server process)

            The LCD TV is blue (no-signal status)

            Does anyone have an idea about how to resolve this?