Announcement

Collapse
No announcement yet.

Problems with Catalyst 9.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with Catalyst 9.1

    I can't get ati to work as OpenGL renderer with 9.1 it falls back to mesa.
    It works with 8.12 with same settings.

    This is what i see in the Xorg.log
    Code:
    (II) AIGLX: Screen 0 is not DRI capable
    (II) Loading sub module "GLcore"
    (II) LoadModule: "GLcore"
    (II) Loading /usr/lib/xorg/modules/extensions//libGLcore.so
    (II) Module GLcore: vendor="X.Org Foundation"
            compiled for 1.4.2, module version = 1.0.0
            ABI class: X.Org Server Extension, version 0.3
    (II) GLX: Initialized MESA-PROXY GL provider for screen 0
    (II) fglrx(0): Restoring recent mode: [email protected]
    In 8.12 It's dri capable.
    Code:
    (II) AIGLX: Loaded and initialized /usr/lib/xorg/modules/dri/fglrx_dri.so
    (II) GLX: Initialized DRI GL provider for screen 0
    (II) fglrx(0): Restoring recent mode: [email protected]
    complete logs:
    8.12 http://nille.pastebin.com/fe124e28
    9.1 http://nille.pastebin.com/f9a7a6a7

    Also resizing windows in kde4.2 is real slow with Catalyst driver.

    *edit: this is on an Lenovo Thinkpad t60 with an Ati x1400.
    Last edited by Nille_kungen; 02 February 2009, 10:42 AM.

  • #2
    Well on my other laptop i use the opensource driver.
    But on this one i want to use the fglrx driver for 3D.

    Comment


    • #3
      Error occurs much earlier during initialization as logfile shows
      Code:
      (WW) fglrx(0): Failed to open DRM connection
      (EE) fglrx(0): [FB] Can not get FB MC address range.
      Haven't seen this one before though.
      Transition from 8.12 to 9.1 was smooth for me (Mobility X1900) - but that won't help you...

      *EDIT*

      Yeah, I know, my quick answer was just a bit too quick. So forget what I said in my original version of the post...

      Cheers,
      knutbert
      Last edited by knutbert; 02 February 2009, 01:08 PM.

      Comment


      • #4
        Knutbert i hope you saw that i posted 2 logs one for 8.12 and one for 9.1 (8.12 works but not 9.1)
        Code:
        (II) ATI Proprietary Linux Driver Version Identifier:8.57.2
        (II) ATI Proprietary Linux Driver Release Identifier: 8.573                                
        (II) ATI Proprietary Linux Driver Build Date: Jan 13 2009 23:21:19
        I tried with 'Option "IgnoreABI" "on"' and it still doesn't work.

        Thanks for your try Nille

        Comment

        Working...
        X