Announcement

Collapse
No announcement yet.

Linux Will Finally Stop Flickering With AMD Stoney Ridge On 4K Displays

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • WGH_
    replied
    Lol, reminds me that turning IOMMU on breaks audio output through HDMI on my 6+ year old Intel laptop.

    Leave a comment:


  • foobaz
    replied
    Originally posted by pegasus View Post
    My rx550 does that too on 4k screen
    My RX 560 flickered on 1440p. These commands fixed it but I had to run them every reboot:

    echo manual > /sys/class/drm/card0/device/power_dpm_force_performance_level
    echo 1 > /sys/class/drm/card0/device/pp_dpm_mclk


    There are three possible values for memory clock: 0, 1 and 2. Change it to 0 for low power or 2 for high performance.

    Leave a comment:


  • agd5f
    replied
    Originally posted by intelfx View Post

    Hmm, then wouldn't have it sufficed to only disable IOMMU if the board is actually experiencing the condition you describe (display buffer in system memory)?
    The IOMMU driver needs to load way before the device drivers do, so we'd end up needing to pull a lot of GPU driver logic into the IOMMU driver to figure out if it should be enabled for not.

    Leave a comment:


  • M@GOid
    replied
    So I noticed the IOMMU is disabled by default in BIOS on the boards I have. Actually I only enabled it on a Gigabyte AM3+ board for a FX8350 I had, because of USB problems.

    So what exactly would I loose if I disable it? Because if is disable by default on most BIOS/UEFI, it must not be that important for normal use.

    Leave a comment:


  • intelfx
    replied
    Originally posted by agd5f View Post
    For a little background, this only affects Stoney boards with limited vram (carve out) where the display buffer ends up in system memory because there is not enough room in vram. The IOMMU adds extra latency on top of the additional latency required for the GPU page tables required for creating the linear map of the system memory pages in the GPU's address space. IOMMU + GFX was never plan of record for displays in system memory and windows never used the IOMMU at all. All Linux SKUs had a larger carve out by default to accommodate this limitation. Most stoney boards had a larger carve out so they never hit this case in the first place. Even if you did hit this case, things like the display timing and speed of memory could have affected it so you may not have actually had any flickering.
    Hmm, then wouldn't have it sufficed to only disable IOMMU if the board is actually experiencing the condition you describe (display buffer in system memory)?

    Leave a comment:


  • lowlands
    replied
    Kudos to the devs for providing a fix for aging hardware.

    Leave a comment:


  • dwagner
    replied
    Originally posted by pegasus View Post
    My rx550 does that too on 4k screen but not on 1080p screen. I'll try disabling iommu to see if there's any difference.
    "disable iommu" is among the frequently rumored miracle cures for all kinds of amdgpu driver ailments, but don't bet your money on it.

    Leave a comment:


  • pegasus
    replied
    My rx550 does that too on 4k screen but not on 1080p screen. I'll try disabling iommu to see if there's any difference.

    Leave a comment:


  • agd5f
    replied
    For a little background, this only affects Stoney boards with limited vram (carve out) where the display buffer ends up in system memory because there is not enough room in vram. The IOMMU adds extra latency on top of the additional latency required for the GPU page tables required for creating the linear map of the system memory pages in the GPU's address space. IOMMU + GFX was never plan of record for displays in system memory and windows never used the IOMMU at all. All Linux SKUs had a larger carve out by default to accommodate this limitation. Most stoney boards had a larger carve out so they never hit this case in the first place. Even if you did hit this case, things like the display timing and speed of memory could have affected it so you may not have actually had any flickering.
    Last edited by agd5f; 02-20-2020, 03:23 PM.

    Leave a comment:


  • horizonbrave
    replied
    wow, only 4 years....

    Leave a comment:

Working...
X