No announcement yet.

how to get XV, DRI working on HD 3300 (rv620) ??

  • Filter
  • Time
  • Show
Clear All
new posts

  • I'm not seeing any obvious problems there; you might want to post to the radeonhd mailing list and include a link to your pastebin'ed log


    • Well, okay.
      The only thing i found out, was that xrandr gives me the following message when i try to plugin and activate the second screen after booting:
      [email protected]:~$ xrandr --output DVI-D_1 --mode 1024x768 --right-of PANEL
      X Error of failed request:  BadMatch (invalid parameter attributes)
        Major opcode of failed request:  155 (RANDR)
        Minor opcode of failed request:  21 ()
        Serial number of failed request:  19
        Current serial number in output stream:  19
      I have the feeling it's a xrandr problem, but i can't prove it... Is there a way to completly reinstall xrandr or at leat to delete old config files of it? (without reinstalling the whole xserver...)


      • can you post the output from xrandr -q ?


        • Originally posted by algury View Post
          3) I followed this wiki (just for the prerequisites packages section):

          Heh, I'm glad it helped someone. (BTW, thanks for reminding me about that page. I really need to get off my lazy @ss and update it.)


          • @bridgman: Sure, here it is:
            Screen 0: minimum 320 x 200, current 1280 x 800, maximum 2560 x 2560
            VGA_1 disconnected (normal left inverted right x axis y axis)
            DVI-D_1 connected (normal left inverted right x axis y axis)
               1440x900       59.9 +   74.9     60.0  
               1280x1024      75.0     59.9  
               1280x960       59.9  
               1152x864       75.0     74.9  
               1024x768       75.1     70.1     60.0  
               832x624        74.6  
               800x600        72.2     75.0     60.3     56.2  
               640x480        75.0     72.8     66.7     60.0  
               720x400        70.1  
            PANEL connected 1280x800+0+0 (normal left inverted right x axis y axis) 338mm x 211mm
               1280x800       60.0*+   60.0  
               2560x2048Scaled   60.5  
               2560x1600Scaled   60.5  
               2048x1536Scaled   60.5  
               1920x1200Scaled   60.4  
               1920x1080Scaled   60.5  
               1600x1200Scaled   60.4  
               1680x1050Scaled   60.3  
               1400x1050Scaled   60.3  
               1440x960Scaled   60.4  
               1280x1024Scaled   60.5  
               1280x960Scaled   60.4  
               1280x854Scaled   60.4  
               1280x768       60.0  
               1280x720Scaled   60.4  
               1152x768Scaled   60.3  
               1024x768       60.0  
               1024x768Scaled   60.4  
               800x600        60.3  
               800x600Scaled   60.3  
               768x576Scaled   60.4  
               854x480Scaled   59.8  
               720x480Scaled   59.8  
               640x480        59.9  
               640x480Scaled   60.1  
               320x240Scaled   57.6  
               320x200Scaled   55.7
            I can change the resolution of my Panel, but as soon as i try to activate the other screen there comes the error message.


            • OK, first thought is that the virtual size is probably 2560x2560, which is not enough to run both screens side-by-side in their preferred mode. I don't think this should be a problem, but it wouldn't hurt to get that out of the way first by adding a line something like "Virtual 3000 1500" to your xorg.conf and restarting X.

              Next, just so we can figure out which parameter it doesn't like, do you know what happens if you do something like "xrandr --auto" ? Maybe try that after adding the Virtual line.


              • If i add this virtual size and restart the xserver, it won't load the right driver but returns to low graphics mode. The Xorg.0.log after this is here:
                After deleting this virtual-option everythings works fine again and the radeonhd driver is used.
                That's very strange...

                But even if i try to extend the second screen with a very low resolution, so that it wouldn't extend 2560x2560, but i get the same error message.


                • It occurred to me after the coffee worked its magic that the driver might want some power-of-two-ness in the Virtual sizes. Maybe try 3072 x 1536 or something like that ?

                  The log only included vesa driver output, which makes sense I guess.
                  Last edited by bridgman; 03-15-2009, 11:25 AM.


                  • Strange behaviour on HD 3200

                    Hi everybody

                    Please, don't kill me if i posted this message in the wrong place.

                    New RHD driver from git (with current drm of course) is working like a charm on my HD4870, great job guys

                    But, when i want to use it on my laptop (HP tx2550ew which have HD3200) it behaves veeery strangely.

                    First of all, radeon and drm kernel module doesn't load automagically.
                    Second thing is that when i starting X after loading this modules by hand it shows me very nice 'plasma effect' and that's it, anything that I can do is just hard reboot
                    Check this plasma effect or download it (if you don't trust flv player on my site :P)

                    Here is dmesg, kernel config, lspci -vvnn, and of course Xorg.log, all on

                    dmesg is taken after dmesg -c and loading drm/radeon kernel modules, if it's not enough for You, i can send a full one.

                    Of course i can help with some debugging etc...


                    • *sigh* ...

                      so with all the support drop news, I decided to give the radeonHD driver another push.

                      Now, it does load and everything, but kwin compositing doesn't work with opengl. xrender isnt an option, as it is * b u t t * slow.

                      Also, xv is a no go. xvinfo says it can't find screens.

                      Otherwise I can certify that every pixel looks like it's the right size and color. I guess that's a start..