No announcement yet.

rs780g powerplay catalyst 9.1 fedora 10 - problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • rs780g powerplay catalyst 9.1 fedora 10 - problem

    I have a hp 6735s puma based rs780g laptop, running fedora 10 x64 with latest updates, catalyst 9.1 from rpmfusion
    The aticonfig --lsp returns information that my hardware does not support that feature, while the ati/amd clearly states that it does.
    Has anyone gotten powerplay to work in hd3200 graphics or am i doing something wrong?
    I am pretty frustrated with it as I would really love my laptop to last more than an hours work on battery!
    I have had the same error since catalyst 8.11, and I am losing hope to ever see it working.

  • #2

    I've got the same laptop, PowerPlay doesn't work for me - You see AMD claims that AMD M780G with HD3200 supports it :
    "The ATI Radeon? HD 3200 graphics powers an exceptionally energy-efficient notebook without compromising performance. Take advantage of ATI PowerPlay? and AMD Vari-Bright?2 technologies that maximize your experience when plugged in, as well as on the move." - link1
    But on their site about PowerPlay link2 they don't mention about this card - in catalyst control center ther is no option about PowerPlay too.


    • #3
      But some guy at this
      forum has managed to get it working.
      In vista, the graphics core frequency can be adjusted from 317MHz to 500MHz. So it is sane to believe the hardware has is, isn't it.
      It seems that the AMDCCCLE version 1.0 enables the powerplay in every driver, even though the --lsp option does not see any capable hardware.
      I do lack the knowledge how to downgrade the AMDCCCLE, so some hint would be useful.


      • #4
        it should!

        as far as i know and as far as graphics core frequencies in vista confirm it (317mhz and 500mhz) it is available!
        Moreover a guy with the same hardware and catalyst control centre version 1.0 has posted in amd forum a screenshot which prowes it works!
        And inhis case the aticonfig --lsp gives the same result.So i believe it should work.
        Maybe someone knows the way to downgrade amdcccle to downgrade to amdcccle to 1.0?
        here is the link

        Can you please post the result of:

        aticonfig --pplib-cmd="get clock"

        Last edited by smagic; 02-04-2009, 04:57 PM.


        • #5

          bash-3.2# aticonfig --pplib-cmd="get clock"
          Engine Clock Range: 500-500 MHZ; Memory Clock Range: 333-333 MHZ;

          amdcccle v.1.0
          no PowerPlay tab,
          I've installed Vista on it - no difference, still no PowerPlay.
          Where do You have "graphics core frequencies in vista (317mhz and 500mhz)"?


          • #6
            AMD Power Monitor Version 1.2.3 from amd processor support download page.
            It displays the frequency for the north bridge. I rarely see it vary between 317 and 500 in case of 3d apps, but it does...


            • #7
              AMD Power Monitor shows me the voltage of the northbridge, but the field with frequency remains empty. I've updated bios to F08 and still no difference.


              • #8
                I've installed AMD OverDrive Utility, it shows GPU engine clock 494.04MHz and memory 400MHz, these values are constant so I still don't believe that ati PowerPlay works on HP 6735s. I've also updated BIOS to rev. F.08 - still no defferences.


                • #9
                  Hello, same Catalyst version, same graphics chip and same problem. Here is also the same output. ButI am on Ubuntu 64b bit. Could the BIOS (a bad/buggy one) prevent to change the frequency or is it only a thing of catalyst?
                  Thanks so far. (Hoping for free drivers still... )


                  • #10
                    The person in the forum I mentioned before has got some different catalyst/fglrx version working on fedora 10 (not mentioned which though).
                    His output is (on the same 6735s hardware):

                    aticonfig --pplib-cmd="get clock"
                    Engine Clock Range: 200-200 MHZ; Memory Clock Range: 333-333 MHZ

                    This would definitely prove the powerplay is implemented in the rs780g in the hp6735s.

                    I might try to downgrade the bios, especially as it did not fix my not working brightness buttons, but i might as well wait for a working version of the driver (which will probably be a couple of years - but I REALLY hope I am wrong)
                    my amd power monitor shows the 317 mhz which in this case seems quite strange, as the lowest power option for the chipset would seem to be 200mhz.