No announcement yet.

AMD Catalyst 9.1 Brings OpenGL 3.0

  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Tried&used 9.01beta, 9.01 and 9.02beta -> And I got no problems whatsoever =D

    Cheers from a happy Kubuntu8.10 x86_64 kernel2.6.27 composite-enabled user!

    The xv-video is a bit shifted and therefore slightly cut, but I'm hopeful that that's gonna be fixed within 1-2 month

    My card is a 4850, too. Like the previous 'awesomeness' posts seem to all be 4850s... Maybe these drivers just work the best on these cards right now

    Awesome driver, thanks AMD/ATI! =D


    • #62
      Originally posted by h3xis View Post
      Well, this seems to be the first fglrx release that is giving me trouble. It's failing to install and gives me this via dmesg:

      fglrx: Unknown symbol pci_disable_msi
      fglrx: Unknown symbol pci_enable_msi

      I'm running Does this even support 2.6.28?
      Saw the same thing here.
      Need to have an option set in the kernel config:
      Message Signaled Interrupts (MSI and MSI-X)
      Bus options (PCI etc.) --->

      Module loaded fine after a recompile.


      • #63
        Originally posted by gloscherrybomb View Post
        This seems to be a pretty good release to me - big desktop worked first time and everything seems quickish. One problem though is that although the flickering has gone playing video under compiz, I now have a strange bug where the video is shifted downwards with a black bar about an inch thick. Still works fine fullscreen, and thats using VLC.
        Same here.
        Kubuntu 8.10
        Radeon HD3850


        • #64
          Originally posted by kraftman View Post
          Is xv working on Ati 1650XT with compositing and OS drivers or fglrx?
          Works great with xf86-video-radeon.

          @Topic: yeah, so I also tried the driver. Xv with compositing seems to work kind of. It doesn't flicker anymore, but totally messes up the window the movie is playing in.
          OpenGL3 support is great, but atm useless for everyone except developers. Of course it's still important it was implemented.
          Still I managed to crash my X Server several times, and so I switched back to radeon. There, everything "just works".


          • #65
            Well, I just install the new driver on Ubuntu 8.10, and I have to say "FINALLY"! Video playback now work with Compiz Fusion, and no more flicking. Although, there is a slight problem with the media screen during video playback, but all is still good. It's a step forward for AMD, and I hope they will continued to improve.

            There is one problem in Ubuntu 8.10 still bug me is that I can't login to Guest Account feature, due to video card HD2400 or my system hardware with Dell.
            Last edited by darkhack; 30 January 2009, 02:38 AM.


            • #66
              Originally posted by bridgman View Post
              loeppel, are you seeing a regression or just the same behaviour as the previous release ?
              are you fuckin kidding me? do you even read the posts? .. im not sure i even wanna try that driver. the only one that works decently here is 8.8 which requires me to use an old kernel & xorg server (and just so you know, 8.8 is still worse than other releases from early 2008..)

              And to Michael, you have just about zero journalistic integrity and credibility left. try not to loose it.


              • #67
                After some testing and playing around. I found lot of bug or error with the new driver.

                First, in compiz fusion, when I zoom in on my desktop to read websitess or other things since I'm visually impaired, now when access full screen video mode, the screen went black and can't move out or restart.

                Second, when playing some video, the media player screen seem sluggish.

                Third, I'm reverting back to 8.12 driver.


                • #68
                  Originally posted by Zhick View Post
                  Works great with xf86-video-radeon.
                  It's great to hear that All I want is to go away from binary blobs and it seems it can happen now.


                  Thanks a lot for your efforts in making great OS drivers.


                  • #69
                    I haven't experienced any the afore mentioned bugs so far.

                    I'm really liking this driver so far, with the event of OpenGL 3.0 world of Warcraft runs much better than before!

                    There is however the indoor/outdoor bug where it goes all psychedelic!

                    Video replay seems better too :>


                    • #70
                      Originally posted by BlueKoala View Post

                      I installed 9.1 and rebooted.
                      Everything was fine until the login screen.
                      I seem to get a hardlock.
                      I must be doing something wrong.

                      Ubuntu 8.10, HD4850

                      I'll look into it, I've got client computers to troubleshoot at the moment.

                      EDIT: It locks pretty damn hard, even my KVM switch stopped working lol.
                      Num lock doesn't come on or off either.
                      same here with HD3470 and Debian, it locks with a black screen and the system gets reset when I press CTRL+ALT+BACKSPACE or try to switch to another terminal.