Announcement

Collapse
No announcement yet.

AMD's RadeonSI Driver Finally Enables OpenGL 4.6 But You Need To First Enable NIR

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    just use radeonsi_enable_nir=true as environmental variable, no need for editing drirc

    Code:
    >radeonsi_enable_nir=true glxinfo | grep OpenGL
    ATTENTION: default value of option radeonsi_enable_nir overridden by environment.
    OpenGL vendor string: X.Org
    OpenGL renderer string: AMD NAVI10 (DRM 3.35.0, 5.4.0-1, LLVM 10.0.0)
    OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.0.0-devel (git-52aadbfd04)
    OpenGL core profile shading language version string: 4.60
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.0.0-devel (git-52aadbfd04)
    OpenGL shading language version string: 4.60
    OpenGL context flags: (none)
    OpenGL profile mask: compatibility profile
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.0.0-devel (git-52aadbfd04)
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
    OpenGL ES profile extensions:

    Comment


    • #12
      Originally posted by ObiWan View Post
      just use radeonsi_enable_nir=true as environmental variable, no need for editing drirc

      Code:
      >radeonsi_enable_nir=true glxinfo | grep OpenGL
      ATTENTION: default value of option radeonsi_enable_nir overridden by environment.
      OpenGL vendor string: X.Org
      OpenGL renderer string: AMD NAVI10 (DRM 3.35.0, 5.4.0-1, LLVM 10.0.0)
      OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.0.0-devel (git-52aadbfd04)
      OpenGL core profile shading language version string: 4.60
      OpenGL core profile context flags: (none)
      OpenGL core profile profile mask: core profile
      OpenGL core profile extensions:
      OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.0.0-devel (git-52aadbfd04)
      OpenGL shading language version string: 4.60
      OpenGL context flags: (none)
      OpenGL profile mask: compatibility profile
      OpenGL extensions:
      OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.0.0-devel (git-52aadbfd04)
      OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
      OpenGL ES profile extensions:
      Cheers, didn't know it had changed

      Comment


      • #13
        Originally posted by FireBurn View Post

        Cheers, didn't know it had changed
        It‘s always been possible to override driconf options with environment variables of the same name.

        Comment


        • #14
          Originally posted by Strunkenbold View Post

          They removed the nir debug environment variable for some unknown reason. You have to set drirc.
          You only have to set:

          radeonsi_enable_nir=true (bash / /etc/environment) or
          setenv radeonsi_enable_nir=true (tcsh)

          Thanks for your hint!

          Comment


          • #15
            Originally posted by nuetzel View Post
            radeonsi_enable_nir=true (bash / /etc/environment)
            This can be set in ~/.pam_environment as well:
            Code:
            radeonsi_enable_nir       DEFAULT=true

            Comment


            • #16
              Thank you to the commenters. I was also setting nir via ~/.drirc and didn't realize it wasn't being turned on.

              In addition to the ~/.pam_environment file (which I didn't know about thanks), to avoid writing to /etc/environment, you can throw a script in /etc/profile.d/, call it env.sh, or whatever you want. That env.sh can also just be a symbolic link to another file (say a cloud backed up file, so you could do ln -s ~/Dropbox/env.sh /etc/profile.d/env.sh and on every boot you'll have those variables set. (edit: the format in this env.sh should be: export radeonsi_enable_nir=true)
              Last edited by perpetually high; 11-28-2019, 12:01 PM.

              Comment


              • #17
                Yeah, this NIR environment variable things was a bit unfortunate... don't know how many test have been done under the wrong assumption when this changed silently to radeonsi_enable_nir=true. But good that it works now again :-)

                glxinfo -B
                name of display: :1
                ATTENTION: default value of option radeonsi_enable_nir overridden by environment.

                Comment


                • #18
                  Hello!

                  For CIV 6
                  radeonsi_enable_nir=true is enabled by default?

                  Comment

                  Working...
                  X