Announcement

Collapse
No announcement yet.

AMD OverDrive Overclocking To Finally Work For Radeon Navi GPUs With Linux 5.5 Kernel

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD OverDrive Overclocking To Finally Work For Radeon Navi GPUs With Linux 5.5 Kernel

    Phoronix: AMD OverDrive Overclocking To Finally Work For Radeon Navi GPUs With Linux 5.5 Kernel

    While most Linux gamers don't appear to be into GPU overclocking, one of the limitations of the Radeon RX 5000 "Navi" series support with the AMD open-source driver to date has been no overclocking support. With the upcoming Linux 5.5 kernel that is set to change...

    http://www.phoronix.com/scan.php?pag...i-Overclocking

  • #2
    great news if we also get the ability to downclock.

    Comment


    • #3
      It should be already possible via custom powerplay tables, though you should know what you're doing to avoid instantly frying your hardware.
      While it's disappointing that AMD kernel devs didn't implement Navi overdrive by themselves, at least there are great people in the FOSS community helping with such things. And also AMD employees putting efforts into reviewing and accepting commits.

      Comment


      • #4
        That's cool. I am using those features with my RX570 as it normally clocks even 200mhz less than max stock clock in Witcher 3. The thing is, that increasing power1_cap doesn't work as expected. With the 0xffffffff od features I am able to set it to 180W, and while it exceeds then the default 120W, it is not rising over 130W while it drops a clock and temperature is totally ok (not exceeding 70C). Has anyone faced such issue?
        PS. On Win 10 it easily reaches 174Wat full clock.

        Comment


        • #5
          faldzip I think it works fine here with Polaris. Please search the amdgpu bugtracker and post your findings there.
          Though 180W ASIC only (the whole card even consumes more than what the software shows you) is really rather unreasonable for Polaris 10/20/30. I've undervolted my 570 to 1330MHz/1025mV and hardly exceed the 120W threshold.

          Edit: To workaround you problem, you might want to try a custom powerplay table via upp (but be extra careful with it):
          https://github.com/sibradzic/upp
          Last edited by aufkrawall; 11-16-2019, 06:30 AM.

          Comment


          • #6
            Instead of overclocking, how about making the card actually usable
            Navi support on Linux is still a disaster.

            Comment


            • #7
              If it helps, here are the settings I'm using with my RX 580...or the script that WattmanGTK makes

              Code:
              #!/bin/bash
              echo "manual" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/power_dpm_force_performance_level
              echo 150000000 > /sys/class/hwmon/hwmon3/power1_cap
              echo "s 0 300 750" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/pp_od_clk_voltage
              echo "s 1 600 769" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/pp_od_clk_voltage
              echo "s 2 918 912" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/pp_od_clk_voltage
              echo "s 3 1167 1075" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/pp_od_clk_voltage
              echo "s 4 1239 1075" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/pp_od_clk_voltage
              echo "s 5 1282 1075" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/pp_od_clk_voltage
              echo "s 6 1326 1075" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/pp_od_clk_voltage
              echo "s 7 1366 1075" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/pp_od_clk_voltage
              echo "m 0 300 750" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/pp_od_clk_voltage
              echo "m 1 1000 800" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/pp_od_clk_voltage
              echo "m 2 2000 875" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/pp_od_clk_voltage
              echo "c" > /sys/devices/pci0000:00/0000:00:03.0/0000:03:00.0/pp_od_clk_voltage
              I'm also using "amdgpu.ppfeaturemask=0xfffd7fff" because I was having random issues with all f's back in March, what most places recommend, and switching to the d7 one cleared it right up -- WattmanGTK reports what to set there in its console output and that's what it recommended for me.

              If y'all want it, I have a systemd unit to load that from /usr/local/bin.

              Comment


              • #8
                skeevy420 Setting power_dpm_force_performance_level to manual is not necessary, as long as you don't want to have additional control like locking of single pstates etc (which the driver probably still forgets after suspend etc.).
                You also waste some power at low load by giving all pstates from 3-7 the same voltage. You also only need to specifiy the pstates you want to alter.

                Comment


                • #9
                  Still disappointed that there's no official control panel so we can control this as human beings instead of this command line crap.

                  Comment


                  • #10
                    Originally posted by Danny3 View Post
                    Still disappointed that there's no official control panel so we can control this as human beings instead of this command line crap.
                    Ya that aspect is sad that we are still in this situation going into 2020.

                    Although AMD has made massive strides in other aspects of Linux support so kudos for that.

                    Comment

                    Working...
                    X