Announcement

Collapse
No announcement yet.

AMD's Linux Driver Gets Power Management In Order For Unreleased "Arcturus" GPU

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD's Linux Driver Gets Power Management In Order For Unreleased "Arcturus" GPU

    Phoronix: AMD's Linux Driver Gets Power Management In Order For Unreleased "Arcturus" GPU

    Earlier this month AMD's Linux driver team sent out their initial open-source patches bringing up the "Arcturus" GPU as a new Vega family product. Today a second batch of patches adding in two thousand more lines of Linux kernel driver code were sent out...

    http://www.phoronix.com/scan.php?pag...urus-PowerPlay

  • #2
    I wish my my RX570 didn't idle at 30W (according to `sensors`) with the 2x monitors turned off. Anyone else know experience this?

    Comment


    • #3
      I've been having a power management problem...
      ​​​​​​Under load, the driver should raise the memory clock first before the GPU clock.
      However, since Linux 5.0, for some reason the driver prioritizes the GPU clock, which causes something as simple as watching a video to heat up my card very quickly, and I don't like it. Is there any way to go back to the older memory-clock-first behavior?

      Comment


      • #4
        With 2 monitors plugged my rx 480 8gb has constant memory clock at 2ghz. iirc its intentional. This might be power usage issue.

        Comment


        • #5
          Originally posted by phoronix View Post
          Phoronix: AMD's Linux Driver Gets Power Management In Order For Unreleased "Arcturus" GPU

          Earlier this month AMD's Linux driver team sent out their initial open-source patches bringing up the "Arcturus" GPU as a new Vega family product. Today a second batch of patches adding in two thousand more lines of Linux kernel driver code were sent out...

          http://www.phoronix.com/scan.php?pag...urus-PowerPlay
          I swear I saw someone posting the same issue and a detailled list of steps they did to solve that, earlier today. I can't search now, but maybe on reddit? Phoronix?

          Comment


          • #6
            Originally posted by [email protected] View Post

            I swear I saw someone posting the same issue and a detailled list of steps they did to solve that, earlier today. I can't search now, but maybe on reddit? Phoronix?
            Maybe it was this guy
            https://www.phoronix.com/forums/foru...59#post1116459
            https://www.reddit.com/r/linux_gamin...adv_is_usable/

            But AFAIK that is 5700XT

            Comment


            • #7
              Originally posted by 2bluesc View Post
              Anyone else know experience this?
              The amdgpu power management with Polaris is bad. Easiest you can do is `echo "low"> /sys/class/drm/card0/device/power_dpm_force_performance_level`, which should bring it down to ~10 W.
              However, check GPU and memory clocks. My sclk is fixed at max when a WQHD with 144 Hz monitor is active for no apparent reason, so it'll never go below 25 W.

              Comment


              • #8
                Originally posted by ElectricPrism View Post
                Ah yes, sorry about that, I was a bit tired… It also looks like I misquoted.

                Comment


                • #9
                  Originally posted by 2bluesc View Post
                  I wish my my RX570 didn't idle at 30W (according to `sensors`) with the 2x monitors turned off. Anyone else know experience this?
                  My Rx580 also idles at 30W if i use the normal Bios (it has a bios switch). With the silent (or mining as xfx calls it-- higher memory clock), it idles at 17W. These numbers also dont change if i undervolt (i.e. with the same settings from the silent one to the normal mode).
                  I didn't try the power_dpm_force_performance_level as juno mentioned though. For my usecase i didn`t see a difference btw the two bios modes and just use the silent one with some undervolting. I also never checked if the numbers that are reported are legit...

                  Comment


                  • #10
                    Originally posted by juno View Post

                    The amdgpu power management with Polaris is bad. Easiest you can do is `echo "low"> /sys/class/drm/card0/device/power_dpm_force_performance_level`, which should bring it down to ~10 W.
                    However, check GPU and memory clocks. My sclk is fixed at max when a WQHD with 144 Hz monitor is active for no apparent reason, so it'll never go below 25 W.
                    I tried this and a number of other things. My sclk jumps around, but the mclk is pegged at 1750 MHz in auto/manual/low modes. I wonder if it has something to do with the way MSI configures the RX570 Gaming X that I have and other RX570s don't have this issue?

                    Comment

                    Working...
                    X