Announcement

Collapse
No announcement yet.

ati driver makes my screen go away in F10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • midol
    replied
    little success with Centos 5.2 and fglrx

    Hi Bridgman,

    After your last reply I downloaded and installed Centos 64 bit and installed and updated it. Then I ran glxgears and got about 300-400 fps on the x1600. I saved the output from /var/log/X11/Xorg.0.log and the /etc/X11/xorg.conf. Then I downloaded the ATI proprietary driver and ran the install script. I took all defaults and it installed without incident.

    Running glxgears again gave me about 900 fps. A factor of three improvement is not to be sneezed at, but there is more. I'm doing this testing in order to have a relatively stable platform that will make effective use of the graphics card I have and which offers some prospect of allowing me to use the free drivers without much performance penalty. Well, it's the last part that seems to me to be giving me grief. My current production setup is F7 x86_64 with fglrx from about a year and a half ago. In that context glxgears gives about 5100 fps. I was hoping that an updated binary would give similar or better performance.

    You can see from earlier posters that advice is available about how to force fglrx to work with F10. I would prefer to not shoehorn the driver in because of the work involved and because then I have to forego such options as preupgrade in future and must instead, as far as I can see, install from scratch with all the attendant fuss and potential for data loss.

    I would be happy for your advice in diagnosing why the binary is so relatively slow, and also any advice you care to give about optimizing the free driver setup. I don't know what diagnostics or configuration information would be most useful to you; please ask.

    Thanks very much.

    Dave

    Leave a comment:


  • bridgman
    replied
    Our primary target distros (ie the ones our traceable customers use the most and where we focus resources) have primarily been SLES/SLED and RHEL, and in the last year we have added Ubuntu. Since OpenSuSE and SLES/SLED tend to be relatively close in terms of internals, we do the bulk of our SUSE-related testing on OpenSuSE rather than SLES/SLED and that gives us pretty good coverage of both.

    Since RHEL and Fedora are generally further apart internally, focusing our testing on Fedora does not give us enough RHEL coverage, so we focus our RH-related testing and bug fixing on RHEL rather than Fedora. Fedora ends up as an "unsupported OS" as a result -- we do not do QA testing on it, and our bug fixing priority is RHEL not Fedora. The drivers often work on Fedora, and many of the bugs we fix for other distros also benefit Fedora, but we aren't committing that each new driver release will work on Fedora (even if many of them do).

    If Fedora, rather than RHEL, ended up with the larger commercial client market share, or if Fedora and RHEL become "closer" internally, either of those might trigger a move to add official support for Fedora.
    Last edited by bridgman; 11 January 2009, 10:59 PM.

    Leave a comment:


  • midol
    replied
    Originally posted by bridgman View Post
    The proprietary driver does not support Fedora in general, and specifically does not work on F10 today. I believe one user was able to get it working but please stick with the open drivers for F10.

    There isn't much you can do about 3D performance immediately but if you enable EXA acceleration you should get pretty decent 2D performance. If you are willing to give up kernel modesetting you could probably also pick up the latest radeon release and get tear-free video playback as well, although I haven't tried the latest release on F10.

    AFAIK the standard F10 install does not have an xorg.conf file.
    yes, that seems to be correct. I blew away the install and started over.

    You said, "The proprietary driver does not support Fedora in general, and specifically does not work on F10 today." Can you elaborate on that a bit? Do you know why or if this is likely to change?

    Dave

    Leave a comment:


  • Christian_L
    replied
    The conf file you want is /etc/X11/xorg.conf.

    To prevent the loading/crashing of the graphical display, press "Esc" at the grub start-screen, then "a", and then add "3" (without quotes) to the grub parameters at start-up. Once at the shell prompt, /usr/share/ati/fglrx-uninstall.sh (as root) should help you remove the fglrx driver and let you reboot with the radeon driver. If that does not work, try to get /etc/X11/xorg.conf from somewhere else (your F7 installation?) and change the "Driver" line from "fglrx" to "radeon" or "radeonhd" (you may have to yum install xorg-x11-drv-radeonhd - I remember I had a problem where fglrx messed up radeon even after it was uninstalled, but radeonhd worked).

    To install fglrx on F10, follow this guide.
    http://forums.fedoraforum.org/showthread.php?t=155503

    Make sure you have a somewhat recent kernel installed, otherwise DRI will not work. 2.6.27.7-137 works for me, while the latest kernel gave me problems with connecting my headphones.

    Leave a comment:


  • bridgman
    replied
    The proprietary driver does not support Fedora in general, and specifically does not work on F10 today. I believe one user was able to get it working but please stick with the open drivers for F10.

    There isn't much you can do about 3D performance immediately but if you enable EXA acceleration you should get pretty decent 2D performance. If you are willing to give up kernel modesetting you could probably also pick up the latest radeon release and get tear-free video playback as well, although I haven't tried the latest release on F10.

    AFAIK the standard F10 install does not have an xorg.conf file.

    Leave a comment:


  • midol
    started a topic ati driver makes my screen go away in F10

    ati driver makes my screen go away in F10

    Hi,

    I recently installed Fedora 10 on a new disk and tried out the open radeon graphics driver included. Performance was lackluster on my 1600 (RV530) so I thought I'd try the proprietary driver. It downloaded and seemed to install ok but my mouse froze. On rebooting I have startup going partway through the sequence then a blank screen. I booted from the original media and got a mounted disk under /mnt/sysimage, only to find that I don't know where the .conf file is. I am familiar with the file layout in F7, my current version, but don't know either where to look to reconfigure or whether this is a known problem with a fix. Anyone care to advise me?

    Dave
Working...
X