Announcement

Collapse
No announcement yet.

RadeonSI Getting Fixed Up To Expose 10-bit VP9 Decode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RadeonSI Getting Fixed Up To Expose 10-bit VP9 Decode

    Phoronix: RadeonSI Getting Fixed Up To Expose 10-bit VP9 Decode

    Newer AMD GPUs are capable of offering hardware accelerated decoding for 10-bit VP9 content, but that wasn't the case with the RadeonSI Gallium3D driver. Fortunately, a simple patch is pending to expose this support...

    http://www.phoronix.com/scan.php?pag...-10-bit-Decode

  • #2
    Nice. Though it seems everybody forgot about this, preventing VAAPI deinterlacing outside primitive VAAPI renderers on AMD :
    https://bugs.freedesktop.org/show_bug.cgi?id=105145

    Comment


    • #3
      I'm more interested in encoding. Right now there isn't a straight forward way to encode using hardware acceleration. I'm referring to programs like Handbrake. Never had a problem with my old Nvidia card. All I had to do is install ffnvenc, but so far I haven't been able to use AMD's Hardware Accelerated encoding because the process of getting it to work is a pain in the rear.

      Comment


      • #4
        Originally posted by aufkrawall View Post
        Nice. Though it seems everybody forgot about this, preventing VAAPI deinterlacing outside primitive VAAPI renderers on AMD :
        https://bugs.freedesktop.org/show_bug.cgi?id=105145
        Progress is generally made in small steps, ane every progress is welcome. That bug is another topic but I agree: that's a nasty one.

        Comment


        • #5
          Originally posted by shanedav4 View Post
          I'm more interested in encoding. Right now there isn't a straight forward way to encode using hardware acceleration. I'm referring to programs like Handbrake. Never had a problem with my old Nvidia card. All I had to do is install ffnvenc, but so far I haven't been able to use AMD's Hardware Accelerated encoding because the process of getting it to work is a pain in the rear.
          There is VAAPI encoding in ffmpeg, it also works on AMD.

          Though it works really terribly in OBS, I have to use my Skylake IGP for it. I wonder if they ever will release AMF for Linux.

          Comment


          • #6
            This is great, because higher bitdepth gives better quality per bitrate (HDR or not), but is less amenable to software decoding, because it halves the SIMD throughput.

            Now, we just need more 10 bit content, which is the chicken and egg situation.

            Comment


            • #7
              And when will you expose 4:4:4 encode? If you don't do this soon I may be switching to Intel's GPU...

              Comment


              • #8
                Does anyone know if this would solve the following error when using mpv to play a 4K youtube video?

                Code:
                $ mpv 'https://www.youtube.com/watch?v=Bey4XXJAqS8'
                Playing: https://www.youtube.com/watch?v=Bey4XXJAqS8
                 (+) Video --vid=1 (*) (vp9 3840x2160 29.970fps)
                 (+) Audio --aid=1 --alang=eng (*) 'DASH audio' (opus 2ch 48000Hz) (external)
                     Subs  --sid=1 --slang=en 'vtt' (webvtt) (external)
                mesa: for the -simplifycfg-sink-common option: may only occur zero or one times!
                mesa: for the -global-isel-abort option: may only occur zero or one times!
                [B][ffmpeg/video] vp9: No support for codec vp9 profile 0.
                [ffmpeg/video] vp9: Failed setup for format vaapi_vld: hwaccel initialisation returned error.[/B]
                AO: [pulse] 48000Hz stereo 2ch float
                VO: [gpu] 3840x2160 yuv420p
                AV: 00:01:28 / 00:29:36 (4%) A-V:  0.000 Cache: 80s+155MB

                Comment


                • #9
                  Originally posted by perpetually high View Post
                  Does anyone know if this would solve the following error when using mpv to play a 4K youtube video?

                  Code:
                  $ mpv 'https://www.youtube.com/watch?v=Bey4XXJAqS8'
                  Playing: https://www.youtube.com/watch?v=Bey4XXJAqS8
                  (+) Video --vid=1 (*) (vp9 3840x2160 29.970fps)
                  (+) Audio --aid=1 --alang=eng (*) 'DASH audio' (opus 2ch 48000Hz) (external)
                  Subs --sid=1 --slang=en 'vtt' (webvtt) (external)
                  mesa: for the -simplifycfg-sink-common option: may only occur zero or one times!
                  mesa: for the -global-isel-abort option: may only occur zero or one times!
                  [B][ffmpeg/video] vp9: No support for codec vp9 profile 0.
                  [ffmpeg/video] vp9: Failed setup for format vaapi_vld: hwaccel initialisation returned error.[/B]
                  AO: [pulse] 48000Hz stereo 2ch float
                  VO: [gpu] 3840x2160 yuv420p
                  AV: 00:01:28 / 00:29:36 (4%) A-V: 0.000 Cache: 80s+155MB
                  Hi there,

                  not sure if the below is the output expected:

                  mpv 'https://www.youtube.com/watch?v=Bey4XXJAqS8'
                  Playing: https://www.youtube.com/watch?v=Bey4XXJAqS8
                  (+) Video --vid=1 (*) (vp9 3840x2160 29.970fps)
                  (+) Audio --aid=1 --alang=eng (*) 'DASH audio' (opus 2ch 48000Hz) (external)
                  Subs --sid=1 --slang=en 'vtt' (webvtt) (external)
                  AO: [pulse] 48000Hz stereo 2ch float
                  VO: [gpu] 3840x2160 yuv420p
                  AV: 00:00:28 / 00:29:36 (1%) A-V: 0.000 Cache: 39s+84MB
                  That is on arch linux with mesa 19.1.1 and kernel 5.1.15-arch1-1-ARCH, ffmpeg 1:4.1.3-1 with rx480 and i5 6600k (no mesa/ffmpeg warnings)


                  Comment


                  • #10
                    Originally posted by Grinness View Post

                    That is on arch linux with mesa 19.1.1 and kernel 5.1.15-arch1-1-ARCH, ffmpeg 1:4.1.3-1 with rx480 and i5 6600k (no mesa/ffmpeg warnings)
                    Thanks for the reply, I appreciate it.

                    So I get the same output as you if I revert my change in /etc/mpv/mpv.conf (default was hwdec=vaapi and I changed it to hwdec=auto).

                    I noticed with the default setting of hwdec=vaapi, I wasn't getting hardware decoding on any videos.

                    For example, on another YouTube video, with hwdec=auto, I get hardware decoding via vdpau:

                    ...
                    AO: [pulse] 44100Hz mono 1ch float
                    Using hardware decoding (vdpau).
                    VO: [gpu] 1280x720 vdpau[yuv420p]
                    AV: 00:00:13 / 00:07:10 (3%) A-V: 0.000 Cache: 57s+12MB
                    ​​
                    I'm on Ubuntu disco 19.04, kernel 5.1.15, Mesa 19.2 git, ffmpeg 4.1.3, RX 480

                    Comment

                    Working...
                    X