Announcement

Collapse
No announcement yet.

aticonfig segmentation fault

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • aticonfig segmentation fault

    The reason this post is somewhat lengthy is that it consists of the bulk of three that I posted on the openSUSE forum, but unfortunately was not able to receive the help I needed there.


    11.1 and a Radeon 9500 pro using latest Ati driver with installer or by generating rpm. Cannot configure with aticonfig or sax2. Aticonfig will say found unitialized file..configuring, then segmentation fault. Sax will run and configure in Kde but after reboot will not boot to desktop. I have run it simply by calling sax2 and by sax2 -r -m 0=fglrx. Sax will not run either way if I drop to runlevel 3 first. All I will get is a black screen.

    I am unable to install any Ati proprietary driver in 11.1.


    I used both the graphical installer from the Ati driver download pages and the wiki page instructions here:http://en.opensuse.org/Howto/ATI_Driver. I made sure everything was in the system this page and the driver release notes say I should that I could, however there are things that do not appear in Yast and I do not know how to make sure they are in the system:

    XFree86-Mesa-libGL
    XFree86-libs
    compat-libstdc++
    It needs glibc version 2.3 I have 2.9
    It needs libgcc I have libgcc43
    it needs libstdc++. I have libstdc++33
    It needs libdrm 2.3 I have 2.4


    During setup with the installer it says" //usr/X11R6/lib/modules/dri/fglrx_dri.so: File exists, but afterwards the file is there.

    After running sax2 or sax2 -r or sax2 -r 0=fglrx All I get is a black screen on reboot.

    After running sax3 -r -m -0-fglrx and rebooting it says runlevel 5 failed and if I type startx I get this error:



    -no matching device section for instance (Bus Id) PCI:[email protected]:0:1 found.

    That is not a typo the "@" was in the line.






    I put "BusId "PCI:[email protected]:0:1"" in xorg.conf in the device section and then it said the same thing plus: no matching device section for instance (Bus Id) PCI:[email protected]:0:0 as well. I put that in and nothing changed.


    fglrx-instal.log for installation using the driver installer shell script from runlevel 3.

    [Message] Kernel Module : Trying to install a precompiled kernel module.
    [Message] Kernel Module : Precompiled kernel module version mismatched.
    [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
    AMD kernel module generator version 2.1
    doing Makefile based build for kernel 2.6.x and higher
    rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
    make -C /lib/modules/2.6.27.7-9-default/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
    make[1]: Entering directory `/usr/src/linux-2.6.27.7-9-obj/i386/default'
    make -C ../../../linux-2.6.27.7-9 O=/usr/src/linux-2.6.27.7-9-obj/i386/default/. modules
    CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ?KCL_MEM_VM_GetRegionPhysAddrStr?:
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3221: warning: return makes pointer from integer without a cast
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3222: warning: return makes pointer from integer without a cast
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3223: warning: return makes pointer from integer without a cast
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3225: warning: return makes pointer from integer without a cast
    CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
    CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
    CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
    CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
    CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
    CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
    CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
    CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_wait.o
    LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.o
    Building modules, stage 2.
    MODPOST 1 modules
    CC /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
    LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
    make[1]: Leaving directory `/usr/src/linux-2.6.27.7-9-obj/i386/default'
    build succeeded with return value 0
    duplicating results into driver repository...
    done.
    You must change your working directory to /lib/modules/fglrx
    and then call ./make_install.sh in order to install the built module.
    - recreating module dependency list
    - trying a sample load of the kernel modules
    failed.
    [Error] Kernel Module : Failed to install compiled kernel module - please consult readme.


    I did this, but it just failed again:

    "You must change your working directory to /lib/modules/fglrx
    and then call ./make_install.sh in order to install the built module."

    I am no expert and have pretty much reached the limits of my abilities. If anyone can help me please do. If there is any other information you need please let me know an I will do my best to give it to you.

  • #2
    I don't have any additional ideas, except to say that I also get segmentation fault when using fglrx 8.12. I have tried this on both ubuntu (64bit) and kubuntu (32bit). I think it might be a bug. I downgraded to 8.11 and aticonfig works fine there.

    As for the blank screen. I have actually been wrestling with the exact same problem myself. I solved my issues just 10 min ago. In my case I first had to force output to the HDMI output, I then had to add a custom modeline to force the correct resolution. I think this has something to do with fglrx failing to recognize the EDID info sent by the monitor and instead defaults to VGA-output.

    Look at the following posts and see if it helps you in any way, good luck: http://www.phoronix.com/forums/showthread.php?t=14575 and http://www.phoronix.com/forums/showthread.php?t=14586

    Comment


    • #3
      If I'm not mistaken you are talking about using a television. I'm using a 26" crt presentation monitor with a standard rgb cable so I don't think what you are talking about applies to my situation.

      Thanks for the suggestion anyway.

      Comment


      • #4
        Please post your /etc/X11/xorg.conf. Use a pastebin if it's too large. Maybe aticonfig isn't getting along with it or something.

        Comment


        • #5
          Actually I was talking about using a HDMI cable connected to a projector. But you might still be right. I never had any problems with a VGA-cable.

          Comment


          • #6
            Thanks for replying chefcoch. Do you want a version that aticonfig has been run on or an original sax generated file?

            Comment


            • #7
              The one modified by atconfig, but it probably doesn't matter.

              Comment


              • #8
                Ok here it is.
                I don't think it modified it since it still says radeon and not fglrx, but then that's why I'm asking for help isn't it?
                Thanks.


                # /.../
                # SaX generated X11 config file
                # Created on: 2009-01-06T13:55:36-0800.
                #
                # Version: 8.1
                # Contact: Marcus Schaefer <[email protected]>, 2005
                # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
                #
                # Automatically generated by [ISaX] (8.1)
                # PLEASE DO NOT EDIT THIS FILE!
                #

                Section "Files"
                FontPath "/usr/share/fonts/misc:unscaled"
                FontPath "/usr/share/fonts/local"
                FontPath "/usr/share/fonts/75dpi:unscaled"
                FontPath "/usr/share/fonts/100dpi:unscaled"
                FontPath "/usr/share/fonts/Type1"
                FontPath "/usr/share/fonts/URW"
                FontPath "/usr/share/fonts/Speedo"
                FontPath "/usr/share/fonts/PEX"
                FontPath "/usr/share/fonts/cyrillic"
                FontPath "/usr/share/fonts/latin2/misc:unscaled"
                FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
                FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
                FontPath "/usr/share/fonts/latin2/Type1"
                FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
                FontPath "/usr/share/fonts/baekmuk:unscaled"
                FontPath "/usr/share/fonts/japanese:unscaled"
                FontPath "/usr/share/fonts/kwintv"
                FontPath "/usr/share/fonts/truetype"
                FontPath "/usr/share/fonts/uni:unscaled"
                FontPath "/usr/share/fonts/CID"
                FontPath "/usr/share/fonts/ucs/misc:unscaled"
                FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
                FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
                FontPath "/usr/share/fonts/hellas/misc:unscaled"
                FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
                FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
                FontPath "/usr/share/fonts/hellas/Type1"
                FontPath "/usr/share/fonts/misc/sgi:unscaled"
                FontPath "/usr/share/fonts/xtest"
                FontPath "/opt/kde3/share/fonts"
                InputDevices "/dev/gpmdata"
                InputDevices "/dev/input/mice"
                EndSection

                Section "ServerFlags"
                Option "AllowMouseOpenFail" "on"
                Option "ZapWarning" "on"
                EndSection

                Section "Module"
                Load "dbe"
                Load "freetype"
                Load "extmod"
                Load "glx"
                Load "dri"
                EndSection

                Section "InputDevice"
                Driver "kbd"
                Identifier "Keyboard[0]"
                Option "Protocol" "Standard"
                Option "XkbLayout" "us"
                Option "XkbModel" "microsoftpro"
                Option "XkbRules" "xfree86"
                EndSection


                Section "InputDevice"
                Driver "mouse"
                Identifier "Mouse[1]"
                Option "Buttons" "5"
                Option "Device" "/dev/input/mice"
                Option "InputFashion" "Mouse"
                Option "Name" "Logitech;MX310"
                Option "Protocol" "explorerps/2"
                Option "Vendor" "Sysp"
                Option "ZAxisMapping" "4 5"
                EndSection


                Section "Monitor"
                DisplaySize 520 391
                HorizSync 29-70
                Identifier "Monitor[0]"
                ModelName "NEC XM29XTRA"
                Option "DPMS"
                Option "PreferredMode" "1280x1024"
                VendorName "NEC"
                VertRefresh 43-120
                UseModes "Modes[0]"
                EndSection


                Section "Modes"
                Identifier "Modes[0]"
                Modeline "1280x1024" 106.97 1280 1360 1496 1712 1024 1025 1028 1059
                Modeline "1280x1024" 87.75 1280 1328 1360 1440 1024 1027 1034 1053 +HSync -Vsync
                Modeline "1280x960" 107.32 1280 1360 1496 1712 960 961 964 995
                Modeline "1280x960" 88.25 1280 1328 1360 1440 960 963 967 989 +HSync -Vsync
                Modeline "1280x800" 107.21 1280 1360 1496 1712 800 801 804 835
                Modeline "1280x800" 98.89 1280 1352 1488 1696 800 801 804 833
                Modeline "1280x800" 91.61 1280 1352 1488 1696 800 801 804 831
                Modeline "1280x800" 88.25 1280 1328 1360 1440 800 803 809 829 +HSync -Vsync
                Modeline "1280x800" 83.46 1280 1344 1480 1680 800 801 804 828
                Modeline "1152x864" 107.91 1152 1224 1352 1552 864 865 868 903
                Modeline "1152x864" 98.61 1152 1224 1344 1536 864 865 868 900
                Modeline "1152x864" 90.48 1152 1224 1344 1536 864 865 868 897
                Modeline "1152x864" 89.25 1152 1200 1232 1312 864 867 871 896 +HSync -Vsync
                Modeline "1280x768" 107.23 1280 1360 1496 1712 768 769 772 803
                Modeline "1280x768" 97.81 1280 1352 1488 1696 768 769 772 801
                Modeline "1280x768" 89.32 1280 1352 1488 1696 768 769 772 798
                Modeline "1280x768" 88.25 1280 1328 1360 1440 768 771 778 797 +HSync -Vsync
                Modeline "1280x768" 80.14 1280 1344 1480 1680 768 769 772 795
                Modeline "1280x720" 107.28 1280 1360 1496 1712 720 721 724 755
                Modeline "1280x720" 96.08 1280 1352 1488 1696 720 721 724 752
                Modeline "1280x720" 88.25 1280 1328 1360 1440 720 723 728 749 +HSync -Vsync
                Modeline "1280x720" 85.15 1280 1344 1480 1680 720 721 724 749
                Modeline "1024x768" 95.50 1024 1088 1200 1376 768 769 772 807
                Modeline "1024x768" 85.45 1024 1088 1200 1376 768 769 772 803
                Modeline "1024x768" 80.50 1024 1072 1104 1184 768 771 775 800 +HSync -Vsync
                Modeline "1024x768" 74.62 1024 1080 1192 1360 768 769 772 799
                Modeline "1280x600" 96.47 1280 1352 1488 1696 600 601 604 632
                Modeline "1280x600" 84.54 1280 1344 1480 1680 600 601 604 629
                Modeline "1280x600" 80.00 1280 1328 1360 1440 600 603 613 626 +HSync -Vsync
                Modeline "1280x600" 72.80 1280 1336 1472 1664 600 601 604 625
                Modeline "1280x600" 61.50 1280 1336 1464 1648 600 601 604 622
                Modeline "1024x600" 77.36 1024 1080 1192 1360 600 601 604 632
                Modeline "1024x600" 67.63 1024 1080 1184 1344 600 601 604 629
                Modeline "1024x600" 65.75 1024 1072 1104 1184 600 603 613 626 +HSync -Vsync
                Modeline "1024x600" 58.10 1024 1072 1176 1328 600 601 604 625
                Modeline "1024x600" 48.96 1024 1064 1168 1312 600 601 604 622
                Modeline "800x600" 60.07 800 840 928 1056 600 601 604 632
                Modeline "800x600" 53.25 800 848 880 960 600 603 607 626 +HSync -Vsync
                Modeline "800x600" 53.14 800 840 928 1056 600 601 604 629
                Modeline "800x600" 45.50 800 840 920 1040 600 601 604 625
                Modeline "800x600" 38.22 800 832 912 1024 600 601 604 622
                Modeline "768x576" 55.94 768 816 896 1024 576 577 580 607
                Modeline "768x576" 49.50 768 816 848 928 576 579 583 601 +HSync -Vsync
                Modeline "768x576" 48.71 768 808 888 1008 576 577 580 604
                Modeline "768x576" 41.66 768 800 880 992 576 577 580 600
                Modeline "768x576" 34.96 768 792 872 976 576 577 580 597
                Modeline "640x480" 37.89 640 672 736 832 480 481 484 506
                Modeline "640x480" 35.50 640 688 720 800 480 483 487 501 +HSync -Vsync
                Modeline "640x480" 33.48 640 672 736 832 480 481 484 503
                Modeline "640x480" 28.56 640 664 728 816 480 481 484 500
                Modeline "640x480" 23.86 640 656 720 800 480 481 484 497
                Modeline "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
                EndSection


                Section "Screen"
                DefaultDepth 24
                SubSection "Display"
                Depth 15
                Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
                Virtual 3840 1200
                EndSubSection
                SubSection "Display"
                Depth 16
                Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
                Virtual 3840 1200
                EndSubSection
                SubSection "Display"
                Depth 24
                Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
                Virtual 3840 1200
                EndSubSection
                SubSection "Display"
                Depth 8
                Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
                Virtual 3840 1200
                EndSubSection
                Device "Device[0]"
                Identifier "Screen[0]"
                Monitor "Monitor[0]"
                EndSection


                Section "Device"
                BoardName "R300 NE"
                Driver "radeon"
                Identifier "Device[0]"
                VendorName "ATI"
                EndSection



                Section "ServerLayout"
                Identifier "Layout[all]"
                InputDevice "Keyboard[0]" "CoreKeyboard"
                InputDevice "Mouse[1]" "CorePointer"
                Option "Clone" "off"
                Option "Xinerama" "off"
                Screen "Screen[0]"
                EndSection


                Section "DRI"
                Group "video"
                Mode 0660
                EndSection

                Section "Extensions"
                EndSection
                Last edited by Scott Swinyard; 01-08-2009, 12:28 AM.

                Comment


                • #9
                  Hmm... aticonfig has no problem modifying that file here. I also tried it on a clean install of opensuse 11.1. The installer and atconfig worked fine there. I have a radeon 9550, which should be similar enough.

                  Have you tried just changing the radeon driver line to fglrx?

                  Comment


                  • #10
                    Yes. I tried that. Something tells me that the driver isn't even being installed properly in any case:

                    "[Error] Kernel Module : Failed to install compiled kernel module - please consult readme."

                    I don't know whether the fact that aticonfig errors is due to or related to this or not.
                    Last edited by Scott Swinyard; 01-09-2009, 05:14 PM.

                    Comment

                    Working...
                    X