No announcement yet.

Hard Lockups With Vega 56 & Newer Kernels

  • Filter
  • Time
  • Show
Clear All
new posts

  • parityboy

    Thanks, will give that a try.

    Leave a comment:

  • parityboy
    started a topic Hard Lockups With Vega 56 & Newer Kernels

    Hard Lockups With Vega 56 & Newer Kernels

    My host machine is a Ryzen 7 1700 running KDE Neon 18.04 LTS with kernel 4.15.0-45-generic. I recently took delivery of a Pulse Vega 56, updated Mesa to 18.3.3 from the Padoka PPA (stable) and installed libvulkan 1.1.97 from the Bionic repo.

    I decided it would be an good idea to upgrade the kernel using UKUU (stable kernels only). I first tried kernel 5.0. It benched well in Unigine Valley, but when using tkg Wine Staging 4.0 with DXVK 1.0, I get a hard lock when Battle Net logs in and then attempts to display its main window. I then tried kernel 4.20 and got the same result. Same again for kernels 4.19 and 4.18. These kernels work fine in Unigine Valley (which uses OpenGL) but hard lock in Wine (DX11->Vulkan). Kernels 4.17 and 4.16 scored very low in Unigine Valley (35fps @ 1080p) so I didn't bother testing them further.

    Has anyone experienced hard locks in this scenario? Is there a known issue between Mesa 18.3.x and kernels newer than 4.15?


    I have libvulkan 1.1.97 installed, but the DXVK HUD shows vulkan 1.1.70.

    Last edited by parityboy; 09 March 2019, 05:46 PM.