Announcement

Collapse
No announcement yet.

R7 370 GCN 1.0 Best OpenCL driver configuration

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • R7 370 GCN 1.0 Best OpenCL driver configuration

    Hi,

    Concise but desperate:

    What is the best configuration to be able to use a Radeon R7 370 (GCN 1.0 I guess) with OpenCL?

    Nowadays I can work with the latest kernel in Arch 4.20, Xorg 1.20, radeon + amdgpu, and open source drivers: mesa OpenCL 1.1 for the GPU, amd app sdk OpenCL 1.2 for the CPU.
    But it gives OpenCL 1.1 for the GPU (problematic), and I cannot use important tools like CodeXL (needs AMD driver).

    Also, I know that in the past (1-2 years ago) I was tweaking/trying many configurations until I got the AMD proprietary drivers correctly, giving OpenCL 1.2 in both devices (and even thinking that up to OpenCL 2.0, but I am not sure now). I have been trying for days but impossible, both in Ubuntu 18.04 and in Arch. I tried reverting to kernel 4.9.11, xorg 1.18, xorg 1.17... with no luck.

    If I try to use the amdgpu-pro OpenCL driver (like this package: https://aur.archlinux.org/packages/opencl-amd/) I can use the clinfo to get the info, but a simple test when using the GPU fails with CL_OUT_OF_HOST_MEMORY. I tried also in older versions (amdgpu-pro 17.10, 17.50) with no luck.

    I don't mind about switching to other distros or doing crazy configurations, knowing that is possible to make it work. I need my Radeon R7 370 with OpenCL.

  • #2
    Originally posted by debianxfce View Post
    Sell your old card and buy a Polaris card, the rx560 card is faster than r7 370 and uses far less power. I can sell my Asus Radeon RX560 OC 2GB DDR5
    for 90 euros, one year warranty left. Or use your 2 year old software configuration. ROCm supports Polaris gpus.
    https://www.x.org/wiki/RadeonFeature/
    that's an awful answer, and rocm requires opencl 3.0 for fiji and polaris, but not any supported gpu before or after for some reason, and not all of us have systems with that. (I was looking to see if the pcie requirements had been.. fixed, and all I'm finding is it hasn't. That's why I'm even looking at this older thread)
    edit: as for something maybe leading to a solution related to this thread, SMOS, a linux distro for mining, has amdgpu-pro 18.10 working for pitcairn somehow. I have no idea how, but it works fine there so if no one that actually knows what the problem with normal installations is decides to chime in now, looking at SMOS might provide some hints.
    Last edited by kiaas; 03-14-2019, 12:49 AM.

    Comment


    • #3
      Originally posted by debianxfce View Post

      Sell your whole computer if you can not install RX560 to it.
      I installed a pair of 470s before the mining boom took off. I installed a 580 when it was dying off. I Still don't got rocm, and amdgpu-pro doesn't seem to want to work on a fresh install of Ubuntu 18.04.2, so I don't really got the PAL or Legacy opencl stack either atm. I'll get that sorted eventually, so it can then pin the packages that need to not update, but it sure would be nice if I rocm worked on my 970FX board.
      Last edited by kiaas; 03-14-2019, 06:27 PM.

      Comment


      • #4
        When it comes to the proprietary AMDGPU-PRO driver, AMD cares basically about three distros: Red Hat Enterprise, SUSE Linux Enterprise, Ubuntu.
        Your best bet is to install Ubuntu 18.04 (not 18.04.2) and leave HWE disabled.

        And disregard that debianxfce troll, he is active in many threads giving bad advice.

        Comment

        Working...
        X