Announcement

Collapse
No announcement yet.

random X freeze with latest ati driver

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exershio
    replied
    Ah alright, I see.

    (II) RADEON(0): ref_freq: 2700, min_out_pll: 20000, max_out_pll: 40000, min_in_pll: 40, max_in_pll: 3000, xclk: 19575, sclk: 250.000000, mclk: 195.750000

    Off Topic: and yeah, I noticed rovclock wasn't working too well. I tried overclocking my core from 250mhz to 450mhz (perfectly stable in Windows XP), but it didn't make any difference at all to performance, as if it wasn't even doing anything.

    Leave a comment:


  • agd5f
    replied
    Originally posted by Exershio View Post
    Are you sure about that? when I had AGP 1x set, my mem clock was 195mhz. When I bumped it up to 2x, it all of a sudden was reported as 390mhz (according to rovclock)
    Yes, I'm sure. I wouldn't trust rovclock too much. Last time I looked at it it was pretty buggy. The actual default clocks are printed in your xorg log, e.g.,

    (II) RADEON(0): ref_freq: 2700, min_out_pll: 64800, max_out_pll: 120000, min_in_pll: 600, max_in_pll: 1600, xclk: 40000, sclk: 600.000000, mclk: 500.000000

    sclk is the engine clock and mclk is the memory clock.

    Leave a comment:


  • Exershio
    replied
    Originally posted by agd5f View Post
    what do you mean by memory frequency? AGP mode doesn't affect the mem clocks on the card.
    Are you sure about that? when I had AGP 1x set, my mem clock was 195mhz. When I bumped it up to 2x, it all of a sudden was reported as 390mhz (according to rovclock)

    Leave a comment:


  • agd5f
    replied
    Originally posted by Exershio View Post
    Hmm, I think I figured this all out. In Windows XP, the ATI CCC always told me my card was running at AGP 4x, yet the memory freq was always 195mhz. Under Linux @ AGP 1x, my mem freq is 195mhz...

    When I changed it to 2x in Linux, all of a sudden my mem freq was 390mhz. I think the CCC in Windows was lying to me and was really running my card at 1x the entire time despite the fact it "said" it was running at 4x. So when I ran my card at 4x under Linux, it crashes. 1x and 2x do not crash however.

    Just figured I'd let you know about that if it's any help.
    what do you mean by memory frequency? AGP mode doesn't affect the mem clocks on the card.

    Leave a comment:


  • Exershio
    replied
    Hmm, I think I figured this all out. In Windows XP, the ATI CCC always told me my card was running at AGP 4x, yet the memory freq was always 195mhz. Under Linux @ AGP 1x, my mem freq is 195mhz...

    When I changed it to 2x in Linux, all of a sudden my mem freq was 390mhz. I think the CCC in Windows was lying to me and was really running my card at 1x the entire time despite the fact it "said" it was running at 4x. So when I ran my card at 4x under Linux, it crashes. 1x and 2x do not crash however.

    Just figured I'd let you know about that if it's any help.

    Leave a comment:


  • drees
    replied
    Looks like my bug https://bugs.freedesktop.org/show_bug.cgi?id=20348 is very similar to the original poster's.

    In my case, Firefox or OpenOffice typically triggers it. Screen freezes up with the mouse moving jerkily a couple times a second with X using 100% cpu.

    Only that that "works" for me is to disable DRI. I was thinking of trying different AGP/PCI settings since then I might be able to retain some acceleration, but if the GPU is onboard, it should be PCI by default, right? The Xorg.log doesn't seem to indicate either way.

    Leave a comment:


  • agd5f
    replied
    Originally posted by bitnick View Post
    Bug 22726 submitted.
    Could you please attach your xorg log and the output of lspci -vn?

    Leave a comment:


  • bitnick
    replied
    Bug 22726 submitted.

    Leave a comment:


  • agd5f
    replied
    Originally posted by bitnick View Post
    Now running (gentoo packages):
    x11-base/xorg-server-1.5.3-r6
    x11-base/xorg-x11-7.2
    x11-drivers/xf86-video-ati-6.12.1-r1
    x11-libs/gtk+-2.14.7-r2
    xfce-base/xfce4-4.6.1

    So I tried different combinations of settings in xorg.conf to get rid of it, and -lo and behold- Option "AGPMode" "4" did the trick (I thought this was the default?). At least I do no longer get the hang repeatably; perhaps it will still hang sometimes. But this setting absolutely had some effect on this bug for me.
    AGP is made of fail. The default in older versions of the xf86-video-ati driver was the lowest supported agp mode (1x or 4x), with newer versions we leave it at whatever mode the bios set up as that was more reliable overall. However, there are always a few combinations that work better with particular modes. Please file a bug (https://bugs.freedesktop.org) and attach your xorg log and I'll add a quirk to the driver for your card/agp bridge combination so it will work out of the box. Also, I would suggest trying xf86-video-ati from git master or the stable 6.12-branch as there have been a number of EXA related fixes since 6.12.1.

    Leave a comment:


  • bitnick
    replied
    I just stumbled upon this bug _in a repeatable way_, after updating my old computer, switching from gnome to xfce4 and updating a lot of X-related packages.

    Now running (gentoo packages):
    x11-base/xorg-server-1.5.3-r6
    x11-base/xorg-x11-7.2
    x11-drivers/xf86-video-ati-6.12.1-r1
    x11-libs/gtk+-2.14.7-r2
    xfce-base/xfce4-4.6.1

    Default xorg.conf, no changes except setting Option "AccelMethod" "EXA".

    Graphics card is R420 JI [Radeon X800PRO].
    PCI bridge: nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge (rev a2)

    I created a new account on the computer, and while setting up Thunderbird for the new user I "noticed" it always hung on the second page of the account wizard - where you enter your name and email address. (Same symptoms as before: dead keyboard, frozen screen except the mouse cursor moves around jerkily (a few Hz update frequency of the position), SysRq working, nothing in the logs... - the only dfference was this time it was repeatable.)

    So I tried different combinations of settings in xorg.conf to get rid of it, and -lo and behold- Option "AGPMode" "4" did the trick (I thought this was the default?). At least I do no longer get the hang repeatably; perhaps it will still hang sometimes. But this setting absolutely had some effect on this bug for me.

    I also tried "AGPFastWrite" "off", "GARTSize" "32", "MigrationHeuristics" "greedy", "AccelDFS" "false", "DynamicClocks" "on"/"off" with no effect (didn't test all combinations though).

    Unfortunately, I'm quite sure I tried setting the AGPMode option the last time I had the error, without effect. But perhaps it will give someone a clue.

    Leave a comment:

Working...
X