Announcement

Collapse
No announcement yet.

random X freeze with latest ati driver

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    The only thing that is helped me is to install new kenel 2.6.29 to be precise. I also get some information that you could fix this bug by using options
    Code:
    noapic acpi=off
    when boot, but i didn't try this. Hope this help
    @juuhu
    Thank you for information.

    Also i thank to Fedora community.

    Comment


    • #62
      Originally posted by bitnick View Post
      When using firefox-2 or thunderbird I get very frequent hangs. The screen freezes and I hear a faint whistling noise from the computer (some CPU/GPU at 100%?). The mouse pointer is still alive but moves jerkily, updated a few times per second. I can sync disks and reboot with SysRq.

      (Firefox 3 does not seem to trigger the bug.)

      This is on an R420 JI, ChipID 0x4a49 (Radeon X800 Pro), AGP.
      This, in particular seems identical to what happened on my rig (Firefox 2 would crash frequently, but not v3. Thunderbird, in particular, reliably crashed in this manner when popping up a password dialog box.

      Personally, I've switched versions (am now running the GEM/KMS/DRI2 branches of the DRM, ddx and mesa from git), and find that these don't exhibit the same problem.

      Comment


      • #63
        Does the patch I attached to comment #21 in bug 16198 help?
        https://bugs.freedesktop.org/show_bug.cgi?id=16198

        Comment


        • #64
          The level "beginers journey three" in xmoto extra level set is sure way to lock graphic system inside drm calls. (Using Ubuntu jaunty and radeon-rewrite+modesetting-gem) I haven't yet find any others as reliable way to reproduce the hang. Intresting point is that there is 3 applications locking in heavy drm lock. Xorg and xmoto is there but I don't know what is the 3rd application (compiz is disabled).

          When drm is locked gdb is often unable to attach to a blocked process.

          Card is mobility x1400 with turion processor.
          EXA, migration smart, dynamic clocks and page flip are set in xorg.conf.

          Comment


          • #65
            I just did a fresh pull from git yesterday and the resulting driver locked up on me within about 10 seconds of the desktop being drawn. i reverted back to the April 21 version and it's running for now. (Commit 228b9ac87...) i haven't dug any further to see exactly what broke.

            Comment


            • #66
              Does anybody care?

              Does anybody of the developers still investigate this issue? I still get lockups, every day. Mostly when browsing the web using firefox.

              Sometimes, my system works for 10 hours, sometimes it locks up three times in twenty minutes. The situation is completely unacceptable, esspecially now, when my hardware is not supported by fglrx, anymore.

              So please, look into this! Let me know all the information you need. I am able to compile a kernel or kernel module, I am able to apply a patch, but you might have to direct me to the right sources.

              Comment


              • #67
                I suppose you have R500 or R690 chipset?
                If so, check https://bugs.freedesktop.org/show_bug.cgi?id=16198
                To minimize the occurrence of the lockups you should be using xf86-video-ati from git. For me it still happen, but much less frequently.

                Comment


                • #68
                  Originally posted by slacker View Post
                  I suppose you have R500 or R690 chipset?
                  No, R300 (Mobility Radeon 9700/64MB)

                  Originally posted by slacker View Post
                  To minimize the occurrence of the lockups you should be using xf86-video-ati from git. For me it still happen, but much less frequently.
                  I use the latest builds from Tormod Volden's PPA (currently git20090531.7599dc40).

                  Comment


                  • #69
                    opensuse 11.1 KDE 4.3svn
                    xorg 1.6.1
                    ati mobility radeon x1600

                    I updated mesa+drm+radeon (from git master) on the 2009-05-21 and since than I never experienced a X server crash again. Used to crash every time I login after some minute/hours.

                    Comment


                    • #70
                      You might want to try the drm patch in bug 21849:
                      http://bugs.freedesktop.org/show_bug.cgi?id=21849
                      Dave just pushed it to Linus in his last round of drm fixes.

                      Comment

                      Working...
                      X