No announcement yet.

Catalyst 8.11 requires --initial -f for every reboot

  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst 8.11 requires --initial -f for every reboot


    today I installed the Catalyst 8.11 on my Ubuntu 8.04 server. Everything went fine, and my server booted like normal.

    But when I rebooted my server the Ubuntu failsafe kicked in after it tried to start gdm (I suppose) for several times and failed.

    When I do a "sudo aticonfig --initial -f" the server boots normal. I don't think this is the normal behavior.

    Unfortunately, the logs either contain no errors or warnings because of the normal start with fglrx or only the log from the failsafe boot. This goes for the xorg.0.log.old, too.

    Any ideas what I can try or what I can post/log/investigate?

  • #2
    Looks like lrm is running. If you don't know how to disable it just run:


    • #3
      Thanks for the tip, but it didn't help.
      Here is the log right after a restart without aticonfig --initial -f:

      and after a restart with --initial -f:

      You can see the rebuild of the config database.

      Any clue what to try next?


      • #4
        Ok, I kinda solved it.
        I just installed catalyst 8.9.

        Now everything works like before. And I have my tearfree video back.


        • #5
          Originally posted by hal2100 View Post
          Ok, I kinda solved it.
          I just installed catalyst 8.9.

          Now everything works like before. And I have my tearfree video back.
          That's not a solution... that's giving up and going back to September's driver.

          Has anyone else duplicated this issue? Let's be organized about this and figure out if it's a real issue with the driver or an oddity with this particular configuration.


          • #6
            It is indeed a solution, but not a very good on.

            Just let me clear a few things up:
            1. I am a consumer, not a developer nor a beta tester.
            2. I bought a board with an internal graphics accelerator which was advertised as "accelerating HD decoding", though not explicit for Linux, fore a HTPC.
            3. A few month later AMD/ATI discovered they cannot enable HD acceleration in Linux because of their insufficient design.
            4. Don't get me wrong, Nvidia is not better.
            5. Now my Media server is working.
            6. The trouble with my girlfriend is less, because Greys Anatomy doesn't stutter or flicker.

            My offer is still valid to look for clues why this driver failed to work. If someone can tell me what to try or where to look.


            • #7
              In my case 8.10 and 8.11 don't work either, unless I use

              aticonfig --initial=dual-head -f

              See this topic:

              It is a bit unclear what the exact reason is... might have something to do with dual-head. It seemed X was not able to start sooner when I changed some overscan options of my connected TV. But with more testing it appeared that X didn't start either when I didn't change any options at all... So I went back to 8.9 and everything works again without problems.
              Last edited by Heiko; 10 December 2008, 04:16 AM.