No announcement yet.


  • Filter
  • Time
  • Show
Clear All
new posts

  • XVideo?

    According to the RadeonHD wiki page at, XVideo support was added in version 1.2.2.

    I currently have xorg-x11-drv-radeonhd-1.2.3-1.5.20081112git.fc9.x86_64 on a Fedora 9 system, running with a Radeon X34x0 (RV620). But I don't seem to have XVideo.

    Does the XVideo announcement apply only to some other models of cards?

  • #2
    Xv support was added for 5xx and RS690 in the 1.2.2 release.

    Support for the 3D engine in 6xx/7xx (which includes your card) has not been released but is going through final IP review now.


    • #3
      Would you like elaborate exactly how XV is supposed to work with radeonhd ? (I must be missing something in xorg.conf .. This time the HW is R520.)

      Some amusement for you :

      I used to have 32bit AMD-XP, kt600 and various AGP cards from RV100 to R481. Each time I tried fglrx both XV and HDTV modelines were broken. Reporting bugs did not lead to anything (both via official route and unofficial bugzilla). - Luckily the radeon driver always worked well (up to R350 that is - nowadays also others).

      Now I happened to upgrade the box (HTPC). The promise of FOSS drivers lead to RS780. Basic frame-buffer support was already available with radeon/hd .. so not huge problems there. (It isn't?t ideal - but beats dark screen )

      The proper FOSS support seems to take time .. So I tried with fglrx 8.552. That turned out to be a big mistake ! After recompiling the kernel over and over again always adding some odd obsoleted option I was finally able to install the binary blob (via gentoo ebuild). The first experience was some odd unusable mode after setting a right mode with the catalyst panel. The only thing it catalysed was a steaming between my ears . Finally I was able to fight the right mode trough. (It was as exotic as [email protected] GTF timings.)

      OK, finally the fglrx seemed to work - but only seemed . No matter what I did the XV was completely skewed with anything based on xine/-lib. VLC worked somehow. In the end the biggest gain was fgl-gears running .. Then I though that this could be a bug with only the RS780. So I put one spare R520 in. And the result was exactly the same.

      At this phase I got some flashbacks from the time when www-ati-com was Artificial Turd Industries and the page was filled with an image of dog poop. Somehow it was fitting .. and still would be what comes to fglrx.

      Couple of hours later I was finally able to clear the box everything the fglrx left behind. And now radeonhd from git is up and running.. Only XV is still missing

      I really hope the ip review is passed and soon !
      This XL1800XT card is insane: The design is such that a PCI DVB cards tuner box almost blocks the fan inlet. Furthermore the ATI fan controller seems to have only two operating points (full speed and idle). Now the damn thing cycles the very noisy fan between full and idle ..

      Well, I won't complain too much - many of those card are freebies from ATI


      • #4
        Let's see... I think radeonhd still disables dri by default and I *think* you need DRI enabled for Xv since it uses the 3D engine. To enable DRI you need to add :

        Option "DRI"

        to the device section of xorg.conf, and you also need a reasonably recent DRM driver. I don't think you mentioned which distro version you are using, did you ?


        • #5
          Originally posted by bridgman View Post
          Let's see... I think radeonhd still disables dri by default and I *think* you need DRI enabled for Xv since it uses the 3D engine.
          But I already had Option "DRI" "true"

          So, maybe there is some Option "yet-another-?ber-magic" to turn on ?
          (I really wonder how difficult it is to update man-page etc. documentation after all the hard coding. This applies especially to the fglrx which seems to lack all imaginable documentation whatsoever. FOSS drivers have the source code at least .. But up-to-date man would be nice )

          If I read right then rhd_driver.c has all options there is (for radeonhd). And there does not seem to be anything related to XV or anything obviously missing from my xorg.conf. (Then also the man page seems to be quite up-to-date.)

          Ah, it complains libdri.a is too old .. (Now I only need to figure out how to fix it )
          Last edited by PWMx; 11-30-2008, 05:46 PM.


          • #6
            Is the problem that you are not seeing any Xv ports defined ?

            EDIT - the thing I don't understand yet is that one of the files seems to be missing - "radeon_textured_video.c". I guess the contents could have been pulled out and merged into other files but I haven't found where that happened yet.

            Ahh, here we go -- it became "rhd_video.c". No problem.

            One more thing in case it helps -- if you run textured video under Compiz with XAA acceleration the video will crap out when you run it because TexVid leverages the memory management from the 2D accel code and the XAA MM code isn't good enough for video plus Compiz. If you switch to EXA acceleration then TexVid should work fine under Compiz.
            Last edited by bridgman; 11-30-2008, 06:04 PM.


            • #7
              Originally posted by bridgman View Post
              Is the problem that you are not seeing any Xv ports defined ?
              Yes, xvinfo doesn?t show any.
              But the problem is probably here:
              (II) LoadModule: "dri"
              (WW) Warning, couldn't open module dri
              (II) UnloadModule: "dri"
              (EE) Failed to load module "dri" (module does not exist, 0)
              (EE) RADEONHD(0): RHDDRIVersionCheck: symbol DRIQueryVersion not available.(libdri.a is too old)
              (WW) RADEONHD(0): RHDDRIPreInit: Version check failed. Disabling DRI.

              Maybe the fglrx install (and remove) broke something
              ("equery belongs -f libdri" gives xorg-server .. so re-emerging it now.)


              • #8
                WHOA ! - That?s it !!

                Now xvinfo gives:
                Adaptor #0: "RadeonHD Textured Video"
                number of ports: 16

                Sorry to waste your time with my stupidity

                BTW / off-topic: Is there persistent xrandr ?
                (Or should I have some script to set the modes each time ?
                The whole legacy xorg.conf modes vs. xrandr is bit unclear to me ..)


                • #9
                  Glad you got it working. I always find it helps if you know whether something is *supposed* to work before you spend a lot of time on it

                  I don't think RandR is persistent yet but I believe you can put RandR options in the conf file these days which is pretty close. Haven't tried it myself, but more info at :



                  • #10

                    I want to get XV running too, but something does not work.
                    I am running Gentoo Linux with a Radeon HD 2400 Pro(RV610).
                    This is a PCI-E version, I have no AGP slot.

                    (WW) RADEONHD(0): Direct rendering for R600 an up forced on - This is NOT officially supported at the hardware
                     level and may cause instability or lockups
                    (II) RADEONHD(0): Found libdri 5.4.0.
                    drmOpenDevice: node name is /dev/dri/card0
                    drmOpenDevice: open result is -1, (No such device or address)
                    drmOpenDevice: open result is -1, (No such device or address)
                    drmOpenDevice: Open failed
                    drmOpenByBusid: Searching for BusID pci:0000:02:00.0
                    drmOpenDevice: node name is /dev/dri/card0
                    drmOpenDevice: open result is -1, (No such device)
                    drmOpenDevice: open result is -1, (No such device)
                    drmOpenDevice: Open failed
                    I checked, /dev/dri/ is empty.
                    Am I missing some kernel module or something?
                    Module                  Size  Used by
                    radeon                134688  0
                    drm                   103912  1 radeon
                    Complete Xorg.0.log
                    I hope you can help me get this working.