No announcement yet.

fixing underscan might crash X

  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Originally posted by mrechte View Post
    I confirm that X start up crashes at the nex start-up unless I reset the default values.

    My config is Fedora 10 on a Gigabyte MA78GPM-DS2H mother boeard (HD3200 chipset with 128MB of dedicated video RAM). Monitor a Samsumg TV (LEA52) on HDMI port.

    Please, if at least I could issue an aticonfig command to restore my parameters automatically when Gnome session is opened, that would be nice (rather than going manually into CCC each time)

    I was having the same issue when fixing underscan using CCC. What worked for me was to fix the underscan in CCC for the display and then clicking the override default button right below it. The settings were saved on the next reboot. No more underscan.

    I could not, however, change the refresh rate from 24Hz to 60Hz.

    Hope this helps.


    • #42
      I am pleased to inform that my HD3200 is now working fine (on Fedora 10) with catalyst 9.5 (including desktop effects and video playback and no more under-scanning).

      Thanks to Fedora and AMD.

      Please don't break it again.


      • #43

        With Catalyst 9.6., you might get Overscan breakage AGAIN. I couldn't find a way to fix it quickly but I will post here again if I do.

        I already tried:

        aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
        And I will now try the other fix. EDIT: The other way (with aticonfig --set-dispattrib) doesn't work, either. Also, in amdcccle, the option is greyed out. Also, I still can only run amdcccle as root, btw (if I run it as a regular user, all it's bits and segments fault terribly).

        Good work AMD!

        If anyone has any suggestions, they are deeply appreciated.
        Last edited by Mr. Hilarious; 16 June 2009, 05:16 AM.


        • #44
          Wondering if it might be some kind of permission issue. Maybe try renaming or deleting the amdpcsdb and running aticonf --initial again. Try not to run aticonfig --initial as root.
          Test signature


          • #45
            Originally posted by Mr. Hilarious View Post
            With Catalyst 9.6., you might get Overscan breakage AGAIN. I couldn't find a way to fix it quickly but I will post here again if I do.
            I was able fix it, but then I was hit by a different bug. The:

            aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
            did eventualy fix the underscan, but I needed to 1) run it when was NOT running (i.e. from a VC), and, also I needed to 2) delete the amdpcsdb file prior to running it. If I didn't do either one of those, then there was the underscan still present next start of Xorg.

            BUT, while figuring that out, I got the other problem. At some point the fonts got all screwy, probably because of deleting the amdpcsdb file. After upgrading to 9.6, initially the fonts were OK (with the underscan), but then, suddenly all the fonts were changed to unreadable size; i.e. 3 pixels high (and at this point I got the underscan fixed). There used to be a very old bug in that caused the same issue (but that was fixed). I got the dimensions of my LCD TV told (or lied, because Xorg does not have settings for viewing distance) in xorg.conf.

            After deleting everything in /etc/ati and re-installing the 9.6, I gave up and downgraded to 9.5 (aka. 8.612 - previosly I had 9.4), and all the fonts are puffy again as they should be. If someone is interested, I got the Xorg.0.log file for 9.6 when the fonts didn't work, and one right after the downgrade to 9.5 (where everything is as it should be).

            Originally posted by bridgman
            Wondering if it might be some kind of permission issue. Maybe try renaming or deleting the amdpcsdb and running aticonf --initial again. Try not to run aticonfig --initial as root.
            Bridgman: I didn't try your suggestion, as I red it after I downgraded. I did run 'aticonfig --initial', but I did so as root. It added one line to my Xorg.conf (a line for PCIID of the card, but that didn't change anything, since the driver did find the card without one). I thought running aticonfig --initial only checks the current xorg.conf (or one given to it on the command line) and makes changes if needed - and as such it would not make sense to run it as non-root. Am I missing something? Maybe I should try it again at some point.

            You might be right in that there might have been some permission issue somewhere for a long time, since suddenly I am able to run amdcccle as a regular user, after this upgrade-downgrade hassle.


            • #46
              Hi again. I've been using 9.5 for a while, but decided to return to this issue. I made some discoveries and thought I'll share my findings here

              It seems, that the issue with the fonts might actually be a bug. With all other drivers than <=9.5 fglrx, I get the same behaviour; the fonts are way too small (1-2 pixel high). By looking at the Xorg.0.log file, I found out, that the DisplaySize option is read correctly by But the EDID information overrides this later on! Here's a snippet from my xorg.log:

              (II) fglrx(0): ***Display: ConnectedDisplayTypes=0x00000080, disabled=0x00000000
              (II) fglrx(0): Connected Display1: DFP on secondary TMDS [tmds2i]
              (II) fglrx(0): Display1 EDID data ---------------------------
              (II) fglrx(0): Manufacturer: SNY  Model: 5c01  Serial#: 16843009
              (II) fglrx(0): Year: 2008  Week: 1
              (II) fglrx(0): EDID Version: 1.3
              (II) fglrx(0): Digital Display Input
              (II) fglrx(0): Max Image Size [cm]: horiz.: 160  vert.: 90
              (II) fglrx(0): Gamma: 2.20
              (II) fglrx(0): No DPMS capabilities specified
              (II) fglrx(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
              (II) fglrx(0): First detailed timing is preferred mode
              (II) fglrx(0): redX: 0.625 redY: 0.340   greenX: 0.280 greenY: 0.595
              (II) fglrx(0): blueX: 0.155 blueY: 0.070   whiteX: 0.283 whiteY: 0.298
              (II) fglrx(0): Supported established timings:
              (II) fglrx(0): 640x480@60Hz
              (II) fglrx(0): 800x600@60Hz
              (II) fglrx(0): 1024x768@60Hz
              (II) fglrx(0): Manufacturer's mask: 0
              (II) fglrx(0): Supported standard timings:
              (II) fglrx(0): #0: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
              (II) fglrx(0): Supported detailed timing:
              (II) fglrx(0): clock: 148.5 MHz   Image Size:  1600 x 900 mm
              (II) fglrx(0): h_active: 1920  h_sync: 2008  h_sync_end 2052 h_blank_end 2200 h_border: 0
              (II) fglrx(0): v_active: 1080  v_sync: 1084  v_sync_end 1089 v_blanking: 1125 v_border: 0
              (II) fglrx(0): Supported detailed timing:
              (II) fglrx(0): clock: 74.2 MHz   Image Size:  1600 x 900 mm
              (II) fglrx(0): h_active: 1280  h_sync: 1390  h_sync_end 1430 h_blank_end 1650 h_border: 0
              (II) fglrx(0): v_active: 720  v_sync: 725  v_sync_end 730 v_blanking: 750 v_border: 0
              (II) fglrx(0): Monitor name: SONY TV XV
              (II) fglrx(0): Ranges: V min: 48 V max: 62 Hz, H min: 14 H max: 70 kHz, PixClock max 150 MHz
              (II) fglrx(0): Number of EDID sections to follow: 1
              (II) fglrx(0): EDID (in hex):
              (II) fglrx(0):  00ffffffffffff004dd9015c01010101
              (II) fglrx(0):  0112010380a05a780a0dc9a057479827
              (II) fglrx(0):  12484c21080081800101010101010101
              (II) fglrx(0):  010101010101023a801871382d40582c
              (II) fglrx(0):  450040846300001e011d007251d01e20
              (II) fglrx(0):  6e28550040846300001e000000fc0053
              (II) fglrx(0):  4f4e592054562058560a2020000000fd
              (II) fglrx(0):  00303e0e460f000a20202020202001e4
              (II) fglrx(0): End of Display1 EDID data --------------------
              (II) fglrx(0): Output CRT1 using monitor section aticonfig-Monitor[0]
              (II) fglrx(0): Output DFP2 has no monitor section
              (II) fglrx(0): Output CRT1 disconnected
              (II) fglrx(0): Output DFP2 connected
              (II) fglrx(0): Using exact sizes for initial modes
              (II) fglrx(0): Output DFP2 using initial mode 1920x1080
              (**) fglrx(0): Display dimensions: (480, 270) mm
              (**) fglrx(0): DPI set to (101, 180)
              Note the size reported by EDID: 160 x 90cm! In addition, that it is not true (the right measurements are around 90cm x 50cm for this 40" display, which would actually give something readable, albeit not comfortably sized when wieving from your couch), one would like to "lie" to that the display is actually smaller than it is, since the viewing distance is longer. So the EDID information makes things even worse than they were with the right measurements. The DisplaySize setting I have in xorrg.conf (480X270, that will give something around ~110DPI'sh), is detected correctly above.

              But with every other driver than fglrx 9.5, the EDID information given by my LCD overrides the option! Somewhat later in the Xorg.0.log file:

              (II) fglrx(0): Setting screen physical size to 1600 x 900
              xdpyinfo also gives the same figures (once I get a usable font size set into a terminal window).

              I got this behavious with the radeonhd driver also (the only one that should work with the 780G / HD3200; well I didn't try vesa), in addition to the fglrx driver 9.6.. For some reason, DisplaySize option DOES work correctly with fglrx 9.5.

              As a workaround, I put "xrandr --dpi 125" into /usr/share/config/kdm/Xsetup (I'm using KDE4 KDM). It was the only way I could figure out to force the DPI setting. For some reason, the login screen doesn't use the DPI setting, even though it should. But, after I login, the KDE session does use the setting.

              Well, I hope this helps, in case someone is hit by the same issue.


              • #47
                Hi once again!

                After upgrading to 9.7 and xorg-server 1.6.2-r1 (among some other, DRM and Mesa libraries), the DisplaySize option started to working again. Now, at the physical size setting part in Xorg.conf, Xorg.0.log says:

                (WW) fglrx(0): Probed monitor is 1600x900 mm, using Displaysize 448x252 mm
                I also cleaned up (made a fresh one) xorg.config. I'm not sure what actually was the culprit, but I'm happy that it works now .

                And sorry for hijacking this old(ish) thread