No announcement yet.

Fglrx and OpenSuse 11.1

  • Filter
  • Time
  • Show
Clear All
new posts

  • Fglrx and OpenSuse 11.1

    I'm going to get my hands on my new machine this week (with HD4850), but I'm not certain about with Distro to put in it.

    Since I do like KDE 4.1 and Suse, in my opinion, is the distro that does a better work at integrating KDE, I'm thinking going to OpenSuse.

    Since I do play a bit, and for that I need FGLRX, I want to know if OpenSuse 11.1 /(the beta) play nice with fglrx. Suse foruns have mixed opinions but I saw in here in a thread or two that users hadn't problems with 8.11.

    So give me your opinion or another distro to chose from (Gentoo is out! Had my time with it already and didn't like it)

    Thx in advance

  • #2
    I had problems installing fglrx 8.11 under opensuse 11.1, so I am running radeonhd for now, which is okay for me since I am not a gamer.


    Actually, the problem's been solved by simply re-installing catalyst 11 (using the automated ATI- installation) and then:

    1. rm /usr/lib/dri/ --- and
    2. ln -s /usr/lib64/dri/ /usr/lib/dri/

    As you can see from the above I am running the AMD 64 Bit version of Opensuse 11.1 RC1, which didn't take it lightly that catalyst had previously tried to load the 32-Bit dri.

    Now fglrx works like a charme. However, after my short stint with rqadeonhd I must admit that I am very impressed with the progress the radeonhd - developers make.
    Last edited by mancunian; 01 December 2008, 05:35 PM.


    • #3
      Now as OpenSUSE 11.1 is officially released, I've got it and ran into some quite nasty problems with fglrx here... Mainly this is what happens: all of the windows lose their borders, so there is no way to move, resize or even close them. But the worst thing is that you can't make any windows active, that is, whatever you write doesn't affect the programs that are open. Somehow the only exception is Firefox - it does get active. And also the copy and paste commands work (but on firefox I have to use the key combination Ctrl+C while on other windows I have to right-click and select Paste). It's extremely difficult to do anything with that as your keyboard almost stops working!
      Is anything known about this problem? Too bad there's no 1-click-install for OpenSUSE 11.1 yet...


      • #4
        The window decorator is crashing. Emerald tends to do that a lot. If you're using Emerald of course. But you didn't say anything about what you're using, so...


        • #5
          Well, I did't quite know what info you need. However, I use Plasma, it's the default window manager of OpenSUSE. Forgot to mention that it also acts strangely: the taskbar with fglrx is not my resolution, it's smaller and leaves gaps where I can see parts of my desktop...
          EDIT: Tried enabling Compiz with Radeonhd and as expected it's no good. Everything's pure white, but I still can see the rotating cube (with it's sides being different shades of white and the background gray). And the taskbar appears to be configurable so it works now. But that window manager corruption now appears on radeonhd just as well!
          How do you switch those managers anyway?
          Last edited by GreatEmerald; 21 December 2008, 06:44 AM.


          • #6
            I am confused: Do you use radeonhd or fglrx? If it is radeonhd, you need to explicitely switch on dri in your xorg.conf.

            Section "Device"
            Option "dri" "on"
            Option "AccelMethod" "EXA"


            • #7
              I used fglrx, but it makes using Linux absolutely impossible, so now I switched back to RadeonHD. And thanks, I'll try your tip.


              • #8
                Yes, that really works. Maybe there's something like that for fglrx as well? What options do I need? That's why I don't like SaX2 - it has no documents about the functions and uses mainly brute changes to the xorg.conf file...
                Figured out how to get the windows work: kwin --replace or just kwin. Seems there's something strange with this... Kwin should work normally as it's the default windows manager...
                Last edited by GreatEmerald; 21 December 2008, 04:09 PM.


                • #9
                  Originally posted by GreatEmerald View Post
                  That's why I don't like SaX2 - it has no documents about the functions and uses mainly brute changes to the xorg.conf file...
                  man sax2

                  If your looking for specific settings for a card you would look at the driver docs and/or the xorg docs.


                  • #10
                    Aha! I updated the KWin to the Factory release, then installed fglrx with aticonfig --initial -f and it works... to some extent. That is, all the windows are OK, I can do everything I could in RadeonHD, but when trying to run anything like glxgears, fgl_glxgears, fglrxinfo etc. it gives me an error:
                    X Error of failed request:  BadRequest (invalid request code or no such operation)
                      Major opcode of failed request:  145 (GLX)
                      Minor opcode of failed request:  19 (X_GLXQueryServerString)
                      Serial number of failed request:  15
                      Current serial number in output stream:  15
                    However, it seems to be known:
                    A lot of pages to read though...

                    EDIT: Oh right, I just had to follow the advice in the 2nd post here! It works! Yay! Have to try it out. As far as I've seen, it doesn't cause screen corruption! Eff yeah!
                    Last edited by GreatEmerald; 21 December 2008, 05:14 PM.