Announcement

Collapse
No announcement yet.

Fglrx and OpenSuse 11.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • GreatEmerald
    replied
    I'd recommend a bit different steps:

    1. Install these packages from Yast2
    2. Install the lastest version of Catalyst (8.561-1)
    3. Run on terminal: aticonfig --initial -f
    5. Restart X
    6. Enjoy

    As if you install those classes earlier, you no longer need to run Kernel Build - it's run automatically. And -f parameter prevents conflicts with RadeonHD and earlier FGLRX versions.

    Leave a comment:


  • ventura10
    replied
    Solved

    Originally posted by GreatEmerald View Post
    Aha! I updated the KWin to the Factory release, then installed fglrx with aticonfig --initial -f and it works... to some extent. That is, all the windows are OK, I can do everything I could in RadeonHD, but when trying to run anything like glxgears, fgl_glxgears, fglrxinfo etc. it gives me an error:
    Code:
    X Error of failed request:  BadRequest (invalid request code or no such operation)
      Major opcode of failed request:  145 (GLX)
      Minor opcode of failed request:  19 (X_GLXQueryServerString)
      Serial number of failed request:  15
      Current serial number in output stream:  15
    However, it seems to be known:
    http://bbs.archlinux.org/viewtopic.php?id=57084&p=2
    A lot of pages to read though...

    EDIT: Oh right, I just had to follow the advice in the 2nd post here! It works! Yay! Have to try it out. As far as I've seen, it doesn't cause screen corruption! Eff yeah!
    Hi guys!

    I was having the same problem, but now is working!

    Steps to sucess...
    1. Install the lastest version of Catalyst (8.561-1)
    2. Run on terminal: aticonfig --initial
    3. Install gcc and kernel-source from Yast2
    4. Run on terminal: fglrx-kernel-build.sh
    5. Restart X
    6. Enjoy

    Some information:

    [email protected]:~/Desktop> uname -a
    Linux mozart 2.6.27.7-9-pae #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

    [email protected]:~/Desktop> fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Mobility Radeon X1400
    OpenGL version string: 2.1.8304 Release

    [email protected]:~/Desktop> glxgears
    7695 frames in 5.0 seconds = 1538.933 FPS
    7982 frames in 5.0 seconds = 1595.943 FPS
    8223 frames in 5.0 seconds = 1643.768 FPS
    7541 frames in 5.0 seconds = 1508.030 FPS

    Good luck!

    Leave a comment:


  • GreatEmerald
    replied
    Aha! I updated the KWin to the Factory release, then installed fglrx with aticonfig --initial -f and it works... to some extent. That is, all the windows are OK, I can do everything I could in RadeonHD, but when trying to run anything like glxgears, fgl_glxgears, fglrxinfo etc. it gives me an error:
    Code:
    X Error of failed request:  BadRequest (invalid request code or no such operation)
      Major opcode of failed request:  145 (GLX)
      Minor opcode of failed request:  19 (X_GLXQueryServerString)
      Serial number of failed request:  15
      Current serial number in output stream:  15
    However, it seems to be known:
    http://bbs.archlinux.org/viewtopic.php?id=57084&p=2
    A lot of pages to read though...

    EDIT: Oh right, I just had to follow the advice in the 2nd post here! It works! Yay! Have to try it out. As far as I've seen, it doesn't cause screen corruption! Eff yeah!
    Last edited by GreatEmerald; 21 December 2008, 05:14 PM.

    Leave a comment:


  • deanjo
    replied
    Originally posted by GreatEmerald View Post
    That's why I don't like SaX2 - it has no documents about the functions and uses mainly brute changes to the xorg.conf file...
    man sax2

    If your looking for specific settings for a card you would look at the driver docs and/or the xorg docs.

    Leave a comment:


  • GreatEmerald
    replied
    Yes, that really works. Maybe there's something like that for fglrx as well? What options do I need? That's why I don't like SaX2 - it has no documents about the functions and uses mainly brute changes to the xorg.conf file...
    Figured out how to get the windows work: kwin --replace or just kwin. Seems there's something strange with this... Kwin should work normally as it's the default windows manager...
    Last edited by GreatEmerald; 21 December 2008, 04:09 PM.

    Leave a comment:


  • GreatEmerald
    replied
    I used fglrx, but it makes using Linux absolutely impossible, so now I switched back to RadeonHD. And thanks, I'll try your tip.

    Leave a comment:


  • mancunian
    replied
    I am confused: Do you use radeonhd or fglrx? If it is radeonhd, you need to explicitely switch on dri in your xorg.conf.

    Code:
    Section "Device"
    ....
    Option "dri" "on"
    Option "AccelMethod" "EXA"
    ....
    EndSection

    Leave a comment:


  • GreatEmerald
    replied
    Well, I did't quite know what info you need. However, I use Plasma, it's the default window manager of OpenSUSE. Forgot to mention that it also acts strangely: the taskbar with fglrx is not my resolution, it's smaller and leaves gaps where I can see parts of my desktop...
    EDIT: Tried enabling Compiz with Radeonhd and as expected it's no good. Everything's pure white, but I still can see the rotating cube (with it's sides being different shades of white and the background gray). And the taskbar appears to be configurable so it works now. But that window manager corruption now appears on radeonhd just as well!
    How do you switch those managers anyway?
    Last edited by GreatEmerald; 21 December 2008, 06:44 AM.

    Leave a comment:


  • RealNC
    replied
    The window decorator is crashing. Emerald tends to do that a lot. If you're using Emerald of course. But you didn't say anything about what you're using, so...

    Leave a comment:


  • GreatEmerald
    replied
    Now as OpenSUSE 11.1 is officially released, I've got it and ran into some quite nasty problems with fglrx here... Mainly this is what happens: all of the windows lose their borders, so there is no way to move, resize or even close them. But the worst thing is that you can't make any windows active, that is, whatever you write doesn't affect the programs that are open. Somehow the only exception is Firefox - it does get active. And also the copy and paste commands work (but on firefox I have to use the key combination Ctrl+C while on other windows I have to right-click and select Paste). It's extremely difficult to do anything with that as your keyboard almost stops working!
    Is anything known about this problem? Too bad there's no 1-click-install for OpenSUSE 11.1 yet...

    Leave a comment:

Working...
X