Announcement

Collapse
No announcement yet.

RAGE & Doom Get Radeon Workarounds In Mesa 18.3-dev

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pal666
    replied
    Originally posted by Qaridarium
    it is really good news... i will buy rage and doom2016 as soon as it runs in linux-steam-clind

    i will not buy if if i had to install the windows steam clind in wine...

    so what i want is wine integration in the linux steam clind.
    same here. it looks like i have to start to populate wishlist with games without current or promised linux port.

    Leave a comment:


  • pal666
    replied
    Originally posted by Danniello View Post
    I'm still little concerned what will be this Steam "compatibility tools"... It could be possibility to start win32 binaries from native Linux Steam and... that's it. No support at all (except community like it is now with "standard" wine).
    valve employee is fixing bugs even before release, what else you need from support?

    Leave a comment:


  • tarceri
    replied
    Originally posted by gukin View Post

    Great, I'll leave my GTX 960 in the drawer and "Git" with the program. Get it? "Git" with the program? Oh I just KILL myself.

    Thanks for reminding me of the obvious, I guess that Mesa 18.1 is getting a little long in tooth. Real men get their code from git.
    18.2 should work too once its released.

    Leave a comment:


  • gukin
    replied
    Originally posted by Masush5 View Post

    You need mesa git for the 4.4 compat work.
    Great, I'll leave my GTX 960 in the drawer and "Git" with the program. Get it? "Git" with the program? Oh I just KILL myself.

    Thanks for reminding me of the obvious, I guess that Mesa 18.1 is getting a little long in tooth. Real men get their code from git.

    Leave a comment:


  • nuetzel
    replied
    Marek (AMD).

    Leave a comment:


  • Masush5
    replied
    Originally posted by gukin View Post

    I must be doing something wrong, when I try to launch I get a blue box with "FATAL ERROR: wglCreatContextAttribsARB failed"

    I'm running wine-3.13 (Staging) on an AMD 2400g using the onboard Vega 11 GPU. Kernel 4.18.3, Mesa 18.1.6, llvm 6.0.1-2.
    You need mesa git for the 4.4 compat work.

    Leave a comment:


  • gukin
    replied
    Originally posted by tarceri View Post

    Those games have been working well for a while now since we added the required compat profile support. No other work arounds needed.
    I must be doing something wrong, when I try to launch I get a blue box with "FATAL ERROR: wglCreatContextAttribsARB failed"

    I'm running wine-3.13 (Staging) on an AMD 2400g using the onboard Vega 11 GPU. Kernel 4.18.3, Mesa 18.1.6, llvm 6.0.1-2.

    Leave a comment:


  • M@yeulC
    replied
    Originally posted by Masush5 View Post

    There is no driconf integration for mesa vulkan drivers yet.
    This actually sounds like something I could try to contribute to

    Leave a comment:


  • tarceri
    replied
    Originally posted by gukin View Post
    How about getting Wolfenstein: The Old Blood and The New Order going? Not that I'm complaining, I can play those games by stuffing in my GTX 960 but I like playing with the Gallium HUD.
    Those games have been working well for a while now since we added the required compat profile support. No other work arounds needed.

    Leave a comment:


  • Masush5
    replied
    Originally posted by PackRat View Post
    Doom 2016 "runs out of the box on Linux"- Bethesda, Kronos group gdc march 23 2018 @ 46:18
    https://youtu.be/0R23npUCCnw?t=2778

    Not released because reasons... or did someone break stuff like libpng12 because reasons.
    Probably means that it runs out of the box on nvidia's and amd's proprietary vulkan drivers.

    Leave a comment:

Working...
X