Announcement

Collapse
No announcement yet.

RadeonSI GL 4.4 Compat Patches Make Wolfenstein & Doom With OpenGL Happy In Wine

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RadeonSI GL 4.4 Compat Patches Make Wolfenstein & Doom With OpenGL Happy In Wine

    Phoronix: RadeonSI GL 4.4 Compat Patches Make Wolfenstein & Doom With OpenGL Happy In Wine

    Timothy Arceri at Valve has been working a lot lately on improving the RadeonSI Gallium3D driver's OpenGL compatibility profile support. While he just posted GL 4.0 compatibility profile patches when he thought it would take a while before getting OpenGL 4.4 compatibility support in order, it turns out it wasn't as bad as anticipated...

    http://www.phoronix.com/scan.php?pag...mpat-Doom-Wolf

  • #2
    This is awesome! I've been waiting for this moment. It would be cool if Intel would work with compatibility profiles as well. Not sure if or when we will see that though. BRB, running Doom on my Ryzen 7 2700u laptop.

    Comment


    • #3
      I would of rather read the title, " Wolfenstein and doom now have native support".

      Comment


      • #4
        Does Dying Light now work without issues on mesa-git with native Steam (runtime deactivated, no Flatpak)?

        Comment


        • #5
          What's the ETA for OpenGL 4.6 core profile support?

          Comment


          • #6
            Originally posted by aufkrawall View Post
            Does Dying Light now work without issues on mesa-git with native Steam (runtime deactivated, no Flatpak)?
            No because these patches are not merged yet.

            Comment


            • #7
              That's strange - I thought for sure that Wolfenstein was Vulkan only.
              Dying Light might work properly now, though.

              Comment


              • #8
                Originally posted by mitch074 View Post
                That's strange - I thought for sure that Wolfenstein was Vulkan only.
                Older Wolfenstein games based on Id Tech 5 are OpenGL games and require compat profiles.

                Comment


                • #9
                  Originally posted by -MacNuke- View Post

                  No because these patches are not merged yet.
                  I don't think that the patches make a difference in Dying Light. So far this game didn't work with the overrides on Mesa (MESA_GL_VERSION_OVERRIDE=4.5 MESA_GLSL_VERSION_OVERRIDE=450 %command%), it just crashes after showing a black loading screen.
                  Last edited by R41N3R; 28 June 2018, 12:09 PM.

                  Comment


                  • #10
                    Originally posted by R41N3R View Post

                    I don't think that the patches make a difference in Dying Light. So far this game didn't work with the overrides on Mesa (MESA_GL_VERSION_OVERRIDE=4.5 MESA_GLSL_VERSION_OVERRIDE=450 %command%), it just crashes after showing a black loading screen.
                    Dying light works pretty well with my Raven Ridge 2400g 4.17.2 Mesa 18.1.2 but there are still problems with water, blocks of color etc.

                    Still, being able to hang out with Fergus without digging out my nVidia 960 is quite tantalizing. Great work Mesa boffins.

                    Comment

                    Working...
                    X