Announcement

Collapse
No announcement yet.

What Linux kernel, packages and drivers are needed for AMD Ryzen 3?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • What Linux kernel, packages and drivers are needed for AMD Ryzen 3?

    I wonder what Linux kernel, packages and drivers are needed for AMD Ryzen 3 to work for gaming.
    Haven't been able to start native and wine games.
    Also wanted to know how it works someone else with similiar system and machine.

    Blender's Cycle works.
    Xonotic(glx/sdl) lags unplayable.

    PC Specs:
    • System: Manjaro Linux 17.1.10 x86_64
    • Motherboard: ASUSTeK PRIME B350-PLUS
    • APU: AMD Ryzen 2200G with Radeon Vega Graphics
    • Memory: 8GiB

  • #2
    With Amd graphics you need a rolling release distribution, latest amd-staging-drm-next kernel and latest Mesa git. My distribution have those: https://www.youtube.com/watch?v=fKJ-IatUfis

    Comment


    • #3
      Actually the mainline kernel git is just fine. I use it and it works just fine. Mesa the same, the newer the better. 18.2 git for example brings (between probably other things) 4k HEVC/VP9 hardware decoding.

      Comment


      • #4
        Kernels before 4.16 do not support the 2200G properly.

        Should work mostly:
        Kernel 4.16
        Mesa 18.0
        LLVM 5.0

        For optimal results:
        Kernel 4.17 (currently in -rc5)
        Mesa 18.2 from git
        LLVM 6.0

        Comment


        • #5
          Originally posted by chithanh View Post
          Kernels before 4.16 do not support the 2200G properly.

          For optimal results:
          Kernel 4.17 (currently in -rc5)
          Mainline kernels do have a partially implemented amdgpu driver, follow the diff column at kernel.org and compare to this this: https://cgit.freedesktop.org/~agd5f/...aging-drm-next

          It is a freeze lottery to use mainline kernels, sometimes they work and very often not.

          For example there is no freesync features in mainline kernels. However freesync requires some open source user space components (not ready yet) and a Display Port monitor to work.

          Code:
          [email protected]:~$ inxi -bM
          System:
            Host: ryzenpc Kernel: 4.16.0-rc7+ x86_64 bits: 64 Desktop: Xfce 4.12.4
            Distro: Debian GNU/Linux buster/sid
          
          [email protected]:~$ DISPLAY=:0 xrandr --prop
          freesync_capable: 0
                  range: (0, 1)
          freesync: 0
                  range: (0, 1)
          I did create new kernel packages for my distribution yesterday, it does even support Vega 20 now.
          Last edited by debianxfce; 05-20-2018, 01:02 AM.

          Comment


          • #6
            debianxfce,

            Do you have a Ryzen CPU, and if so have you been able to get CPU frequency scaling to work? I have a constant difference of ~60W when idle between Windows (even in High Performance mode) and Linux. I enabled powersaver governor by default, but it appears to have no effect.

            Comment


            • #7
              Originally posted by cde1 View Post
              debianxfce,

              Do you have a Ryzen CPU, and if so have you been able to get CPU frequency scaling to work? I have a constant difference of ~60W when idle between Windows (even in High Performance mode) and Linux. I enabled powersaver governor by default, but it appears to have no effect.
              I have Ryzen 5 1600. Remove CPU frequency scaling from the kernel and let the bios and cpu itself control frequencies and power usage. I have no power monitor but when idle, the cpu temp is 28C when the room temperature is 22C.

              Comment


              • #8
                Originally posted by debianxfce View Post

                I have Ryzen 5 1600. Remove CPU frequency scaling from the kernel and let the bios and cpu itself control frequencies and power usage. I have no power monitor but when idle, the cpu temp is 28C when the room temperature is 22C.
                Thanks. I believe the real issue is that the lowest frequency that the kernel accepts is 2.20GHz, and this is higher than what is used in Windows when idling (note I have left C6 enabled in the BIOS).

                Code:
                analyzing CPU 0:
                  driver: acpi-cpufreq
                  CPUs which run at the same hardware frequency: 0
                  CPUs which need to have their frequency coordinated by software: 0
                  maximum transition latency: 4294.55 ms.
                  hardware limits: 2.20 GHz - 3.70 GHz
                  available frequency steps: 3.70 GHz, 3.20 GHz, 2.20 GHz
                  available cpufreq governors: ondemand, userspace, conservative, performance, powersave, schedutil
                  current policy: frequency should be within 2.20 GHz and 3.70 GHz.
                                  The governor "powersave" may decide which speed to use
                                  within this range.
                  current CPU frequency is 2.14 GHz.
                  cpufreq stats: 3.70 GHz:0.04%, 3.20 GHz:0.08%, 2.20 GHz:99.88%  (27)

                Comment


                • #9
                  Originally posted by cde1 View Post

                  Thanks. I believe the real issue is that the lowest frequency that the kernel accepts is 2.20GHz, and this is higher than what is used in Windows when idling (note I have left C6 enabled in the BIOS).
                  So that is probably not the root cause as Windows 10 leaves the frequency at a minimum of 3 GHz. So I tried underclocking and could reduce the voltage to 1.05V (instead of the default which hovers between 1.3 and 1.4V), while forcing the maximum frequency to 3600 MHz. The effect on power consumption is quite large (200W used at the wall instead of 250W when running Prime95).

                  Does anyone have 54945_PPR_Family_17h_Models_00h-0Fh.pdf and 55723_SOG_Fam_17h_Processors_3.00.pdf? (bridgman?) Right now support.amd.com is down and give:

                  Code:
                  Server Unavailable!
                  Server unavailable.Please visit again later
                  URL: support.amd.com/TechDocs/55723_SOG_Fam_17h_Processors_3.00.pdf
                  EDIT: this problem has been fixed as of today
                  Last edited by cde1; 05-21-2018, 06:00 AM.

                  Comment


                  • #10
                    Originally posted by debianxfce View Post

                    I have Ryzen 5 1600. Remove CPU frequency scaling from the kernel and let the bios and cpu itself control frequencies and power usage. I have no power monitor but when idle, the cpu temp is 28C when the room temperature is 22C.
                    Have you checked wether the value you set in the BIOS for the CPU frequency is actually used? I have set 3600 MHz but this does not change the behavior in Linux.

                    Code:
                    CPU MHz:             3940.747
                    CPU max MHz:         3600.0000
                    CPU min MHz:         2200.0000
                    As you can see above frequency goes above the recommended value, with or without cpufreq compiled in the kernel. I'm thinking frequency scaling is currently not implemented for fam 17h. Perhaps Michael has more insight on this?

                    Comment

                    Working...
                    X