Announcement

Collapse
No announcement yet.

Ryzen freeze or AMDGPU+GCN 1.1 bug?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Quick update:
    I upgraded to Ubuntu 18.04LTS and also installed kernel 4.17rc3. Then I white-listed AMDGPU and configured grub to use it again. The system is rock solid. I left it several times alone to go idle and it didn't freeze. It also successfully shut down both monitors when it had to (It used to hang while trying to do this).

    Thanks!

    Comment


    • #12
      Originally posted by debianxfce View Post

      Buy Asus mobos only. I did return the gigabyte b350 gaming 3 mobo after updating the "fail safe" bios and the mobo did not boot anymore. Asus Prime B350 series is good.
      Don't know how to use the duel bios then take it

      Built several without issue

      Comment


      • #13
        Originally posted by pete910 View Post

        Don't know how to use the duel bios then take it

        Built several without issue
        Duel bios does not work in gigabyte b350 gaming 3. I got my money back from that shit.

        Comment


        • #14
          Originally posted by debianxfce View Post

          Duel bios does not work in gigabyte b350 gaming 3. I got my money back from that shit.
          So, No then

          Comment


          • #15
            I don't know if this will help, but I've experienced a similar system lockup with my R7 260x and AMDGPU and not with Radeon (processor is Dual Xeon X5687). What was causing my lockups was the "Lock the screen when going to sleep" tick box in the XFCE Power Manager. Unticked that and my desktop is working great again. That's not a good solution if your PC is somewhere public. I'm the only person who uses my PC or who has access to it so it's just fine for me. I'm not sure if it's a Light Locker, AMDGPU, or XFCE bug, but I know how to trigger it -- let it idle, blank, security kicks in, and then wait more than 20 mins...if it just kicks in and I catch it, it doesn't freeze up, but if it sits for more than 10 or 20 mins, it'll freeze up.

            What sucks is I'm having such great results with gaming on AMDGPU these days that I'd rather deal with this bug versus switch drivers.

            Comment


            • #16
              Originally posted by skeevy420 View Post
              What was causing my lockups was the "Lock the screen when going to sleep" tick box in the XFCE Power Manager.
              The Xfce power manager and screensavers can cause freeze, i noticed that several months ago. The xorg server has dpms built in, my screen blanks in 30 minutes or so without the xfce power manager and a screen saver installed. My system wakes ups nicely. You can control dpms with xorg.conf, see Arch Linux wiki.

              Comment


              • #17
                Originally posted by debianxfce View Post

                The Xfce power manager and screensavers can cause freeze, i noticed that several months ago. The xorg server has dpms built in, my screen blanks in 30 minutes or so without the xfce power manager and a screen saver installed. My system wakes ups nicely. You can control dpms with xorg.conf, see Arch Linux wiki.
                I'm using LXDE, but it has exactly the same problem and had to do the same workaround before.

                About this issue: I used 4.17rc3 for a few weeks, and I no longer saw the hangs while going idle and turning off the screens. However, I got random lockups and no panic messages. Even REISUB didn't work. So I went back to my reliable fix: blacklist AMDGPU and use radeon only. It's very disappointing, but it's the only thing that seems to work. The power management does work OK with the radeon module. From what I remember when I started with this thread, the fix only works while AMDGPU is completely blacklisted and it hangs if it's loaded, even if it's not in use.

                Comment


                • #18
                  same problem with gcn 1.0 + ryzen 1700 + ubuntu 18.04 generic kernel 4.15.4

                  problem first appeared when i i upgrad to ryzen 1700

                  Comment


                  • #19
                    Originally posted by paupav View Post
                    same problem with gcn 1.0 + ryzen 1700 + ubuntu 18.04 generic kernel 4.15.4

                    problem first appeared when i i upgrad to ryzen 1700
                    All I can say is:
                    1) Update your motherboard BIOS, and search for a setting like this: "Typical Current Idle". Make sure you change it to ON (do not leave it in "Auto". It must be manually enabled)
                    I have a Gigabyte motherboard, and the setting can be found here:
                    M.I.T->
                    Advanced Frequency Settings ->
                    Core Settings ->
                    *Power Supply Iddle Control = Typical

                    The names can be different from one motherboard brand to the other.

                    2) Edit /etc/modprobe.d/blacklist.conf and add "blacklist amdgpu" to the bottom. After that run "sudo update-initramfs -u -k all". This way you will make sure it won't be loaded.


                    I was able to ahve a 100% reliable system by doing those two steps. The first step "fixes" this very public and widespread bug: https://bugs.launchpad.net/ubuntu/+s...x/+bug/1690085
                    The second step (I think) is related to the power management with AMDGPU on some cards (I own an AMD 390x, which is GCN 1.1). I'm going to enable AMDGPU again right after they release kernel 4.19, which is supposed to have new power management features (and I hope they fixed this bug as a side effect)

                    Comment

                    Working...
                    X