No announcement yet.

Mobility 3650 and Linux.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Mobility 3650 and Linux.

    Hey dudes.

    I'm working on getting a Mobility 3650 working with a Lenovo T500. Using Suse 11.0.

    I've got the Radeonhd 1.2.3 driver.

    One difficult part is figuring out all the package dependencies.

    Anyone know where I can find a list of these?

    Or anyone know some tutorials that will walk someone through all the basics when it comes to installing drivers?


  • #2
    I just got an Asus F8Va (still in the mail), I would like to know of a guide to configure the Mobility 3650.


    • #3
      I'm not sure about SuSe, but there is a guide for Ubuntu here that might give you the idea: (I've also used this procedure successfully with other Debian-based distros, though I didn't have to manually edit the build files for m4 macros as suggested in the guide.)

      In general, you'll need your distro's Xorg development packages/libs, autoconf/make, the mesa development packages/libs, PCI(access) libs, m4 macros, and basic development tools (gcc, binutils, gawk, etc.)
      Last edited by DanL; 12-18-2008, 10:50 AM.


      • #4
        There are pre-built RPM's for several distros here:
        OpenSuSe 11.0:


        • #5
          My computer (F8Va with HD3650) won't work with neither radeon or radeonhd driver, not even with the vesa driver, all I get is a white screen. I'm using Kubuntu 8.10 AMD64. I had to install in text mode and install the ATI propietary so I could use X.


          • #6
            I also have a T500 with a mobility 3650 and have been unable to get it working. I've tried drivers from different sources and nothing works. As best as I can tell the 3650 isn't supported in Linux (Ubuntu).

            Can anyone prove otherwise?



            • #7
              Are you running Intrepid (Ubuntu 8.10) ? What happens when you boot up after a fresh install ?

              You may just have a PCI ID that none of the devs have run across yet. I think the lspci command will tell you the plug & play IDs.


              • #8
                01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3650

                So, at least it's there, I was beginning to have doubts.

                I'm reinstalling XP and Ubuntu 8.10 which will take a couple days. Will keep looking around the net for clues.



                • #9
                  Hmm my hd3650 mobility works wonderfully in Ubuntu 8.10. Just had to install it through safe graphic mode.

                  When Im in the freshly installed Ubuntu (in safe graphic mode, as the radeonhd shipped with 8.10 doesn't work), I just download the latest fglrx driver, and do this:

                  Install fglrx dependencies:
                  sudo apt-get install dpkg-dev debhelper libstdc++5 dkms build-essential cdbs fakeroot

                  Now in the directory where you downloaded fglrx, do:
                  chmod +x
                  ./ --buildpkg
                  sudo dpkg -i *.deb

                  Voila... Then just add:

                  Driver "fglrx"

                  under "Device" settings in xorg.conf. Nothing else. No need for running aticonfig --initial as it might segfault.

                  Reboot, and enjoy fglrx running.


                  • #10

                    It... Just... Doesn't... Work...

                    New install, followed your instructions. But, there was no selection for 'safe mode' at boot. I did a search for keys to press at boot for safe mode but found nothing that worked.

                    I think I'll just wait a while, maybe updated drivers will appear sometime soon.

                    Thanks for the help.