Announcement

Collapse
No announcement yet.

How to enable AMDGPU driver for Radeon HD 7850?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by bridgman View Post
    That looks like dmesg output - it's the X log that will show which X driver is being started.

    I'm not sure if that 20-amdgpu.conf file is active, since you were previously running the radeon driver not amdgpu.
    I used to have a 20-radeon.conf for enabling things like DRI3, but I renamed the file to 20-amdgpu.conf to try out amdgpu. Not sure if I have to chmod it or something.

    This is what's in there.
    Code:
    Section "Device"
            Identifier  "AMD"
            Driver "modesetting"
            #Option "AccelMethod"           "Glamor" #valid options are XAA, EXA and Glamor. Default value varies per-GPU.
            #Option "AccelMethod"           "XAA" #valid options are XAA, EXA and Glamor. Default value varies per-GPU.
            #Option "AccelMethod"           "EXA" #valid options are XAA, EXA and Glamor. Default value varies per-GPU.
            Option "DRI3"                  "on" #enable DRI3 instead of the default DRI2-mode
    EndSection
    Also lately Padoka PPA is holding back some packages. Not sure why.

    Code:
    The following packages have been kept back:
      xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-radeon

    Comment


    • #12
      Removed Padoka and installed Oibaf PPA. No difference in trying to get AMDGPU running. But I may have been posting the wrong Xorg log. This time here's the log from Xorg.0.log.old. Show's my grub commands working but it still goes back to RadeonSI I believe.

      https://pastebin.com/CgA4z4EE

      Comment


      • #13
        Ok, I figured out the problem. Some reason there was a 20-radeon.conf that sat in the /usr/share/X11/xorg.conf.d/ directory that was set to Radeon. That's what the system was using instead of the 20-amdgpu.conf I put in the /etc/X11/xorg.conf.d/ . So I just renamed the 20-radeon.conf and copied the 20-amdgpu.conf and fixed the grub and rebooted and now I'm using amdgpu. Dolphin now works with Vulkan and it's so much faster than using OpenGL. RPCS3 is also much faster using the Vulkan API over the OpenGL. Frame rates are much higher and everything is smoother.

        Code:
        lshw -c video
        WARNING: you should run this program as super-user.
          *-display               
               description: VGA compatible controller
               product: Pitcairn PRO [Radeon HD 7850 / R7 265 / R9 270 1024SP]
               vendor: Advanced Micro Devices, Inc. [AMD/ATI]
               physical id: 0
               bus info: [email protected]:04:00.0
               version: 00
               width: 64 bits
               clock: 33MHz
               capabilities: vga_controller bus_master cap_list rom
               configuration: driver=amdgpu latency=0
               resources: irq:39 memory:c0000000-cfffffff memory:fe800000-fe83ffff ioport:c000(size=256) memory:c0000-dffff
        WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

        Comment

        Working...
        X