Announcement

Collapse
No announcement yet.

How to enable AMDGPU driver for Radeon HD 7850?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to enable AMDGPU driver for Radeon HD 7850?

    I'm running Mint 18.3 with Padoka PPA and Kernel 4.14.12 and put GRUB_CMDLINE_LINUX="radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1" in Grub. I reboot my machine and it says Failed to Start X server. Log says, "AddScreen/ScreenInit failed for driver 0". I had to put # in from of that GRUB line to boot back up to Cinnamon. What am I doing wrong here?

  • #2
    Originally posted by Dukenukemx View Post
    I'm running Mint 18.3 with Padoka PPA and Kernel 4.14.12 and put GRUB_CMDLINE_LINUX="radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1" in Grub. I reboot my machine and it says Failed to Start X server. Log says, "AddScreen/ScreenInit failed for driver 0". I had to put # in from of that GRUB line to boot back up to Cinnamon. What am I doing wrong here?
    Can you pastebin your dmesg output and put a link here ? First question is whether your kernel was built with SI/CI support enabled.

    BTW I think you only need the radeon.si_support and amdgpu.si_support boot parms, not the CIK ones...

    Comment


    • #3
      How do go that far back in Mint 18.3? I used command journalctl -b and it doesn't go that far back.

      Comment


      • #4
        Make a custom kernel, see how to: https://www.youtube.com/watch?v=G3AxgH2bbsE

        Comment


        • #5
          I'm using Xanmod 4.14.12. Don't know if that's fine for AMDGPU. I've also tried the 4.15 RC7 with the same results.

          Comment


          • #6
            Here's a Pastebin of my kern.log, or at least some of it.

            https://pastebin.com/Bi59ee3x

            Here's my Xorg.0.log if that helps.

            https://pastebin.com/9dDY8BX2

            Comment


            • #7
              Originally posted by Dukenukemx View Post
              Here's a Pastebin of my kern.log, or at least some of it.
              Thanks. Looks like you are running the radeon X driver - can you switch to modesetting or amdgpu ? Recommend you try modesetting first.

              Comment


              • #8
                Not sure how I switch to modesetting. I have this file called 20-amdgpu.conf with this inside it under /etc/X11/xorg.conf.d/ . So do I change the Driver "amdgpu" to modesetting?
                Code:
                Section "Device"
                        Identifier  "AMD"
                        Driver "amdgpu"
                        #Option "AccelMethod"           "Glamor" #valid options are XAA, EXA an$
                        #Option "AccelMethod"           "XAA" #valid options are XAA, EXA and G$
                        #Option "AccelMethod"           "EXA" #valid options are XAA, EXA and G$
                        Option "DRI3"                  "on" #enable DRI3 instead of the default$
                EndSection

                Comment


                • #9
                  I changed the 20-amdgpu.conf to Driver "modesetting", then changed the grub and rebooted and same shit. Here's the pastebin. I do see that it says "[drm] amdgpu kernel modesetting enabled" but x server still complains. I do have "R600_DEBUG=sbcl,hyperz,llvm,sisched,forcedma" in the /etc/environment . Maybe I should remove that?

                  https://pastebin.com/4erQ8Wgr

                  Comment


                  • #10
                    That looks like dmesg output - it's the X log that will show which X driver is being started.

                    I'm not sure if that 20-amdgpu.conf file is active, since you were previously running the radeon driver not amdgpu.

                    Comment

                    Working...
                    X