Announcement

Collapse
No announcement yet.

21-Way NVIDIA Fermi/Kepler/Maxwell/Pascal OpenCL GPU Comparison

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 21-Way NVIDIA Fermi/Kepler/Maxwell/Pascal OpenCL GPU Comparison

    Phoronix: 21-Way NVIDIA Fermi/Kepler/Maxwell/Pascal OpenCL GPU Comparison

    On Monday I posted a 28-way NVIDIA GeForce Linux GPU comparison for fun going from the GeForce 8 series through the high-end GeForce GTX 1080 Ti. For those not interested in OpenGL but more into OpenCL compute, these benchmarks are for you. With the GPUs I had available for testing from Fermi and newer, some fresh OpenCL benchmarks were carried out.

    http://www.phoronix.com/vr.php?view=24714

  • #2
    Well, in spite of installing a huge number of files on my HTPC build I'm testing, most of the OpenCL tests didn't install with a complaint about no usable OpenCL library found. I think I need additional info beyond the otherwise convenient PTS test designation to feed PTS. What library do you use?

    Darktable installed but one test was abnormally short and these two results were not integrated with the other bar charts.

    The only useful output was that my 1080Ti beat your 1080Ti by a smidgen in Luxmark (perhaps due running a Ryzen 1800X at 3.8 GHz on all cores).

    Comment


    • #3
      Originally posted by kaseki View Post
      Well, in spite of installing a huge number of files on my HTPC build I'm testing, most of the OpenCL tests didn't install with a complaint about no usable OpenCL library found. I think I need additional info beyond the otherwise convenient PTS test designation to feed PTS. What library do you use?

      Darktable installed but one test was abnormally short and these two results were not integrated with the other bar charts.

      The only useful output was that my 1080Ti beat your 1080Ti by a smidgen in Luxmark (perhaps due running a Ryzen 1800X at 3.8 GHz on all cores).
      if the version of darktable installed is different from the one used in this testing, it will render to separate chart.

      The system has just standard OpenCL packages + NVIDIA driver on Ubuntu, did you have the OpenCL headers and such present on your system?
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #4
        I have a relatively standard Mint 18.1 but upgraded to kernel 4.10.0-21 (Ubuntu-speak for some modification of kernel changes beyond 4.10.0) in order to deal with my Ryzen CPU and get nVidia drivers that have ever heard of the 1080Ti. In the list of PTS freshly installed software is opencl-headers (2.0-...).

        I'm about to run it again to see if anything changes.

        Comment


        • #5
          Here is an example from JuliaGPU install-failed.log. Scroll down to very bottom.

          Code:
          JuliaGPU-v1.2pts/juliaGPU
          JuliaGPU-v1.2pts/juliaGPU.c
          JuliaGPU-v1.2pts/displayfunc.h
          JuliaGPU-v1.2pts/rendering_kernel.cl
          JuliaGPU-v1.2pts/renderconfig.h
          JuliaGPU-v1.2pts/README.txt
          JuliaGPU-v1.2pts/preprocessed_rendering_kernel.cl
          JuliaGPU-v1.2pts/LICENSE.txt
          JuliaGPU-v1.2pts/Makefile
          JuliaGPU-v1.2pts/vec.h
          JuliaGPU-v1.2pts/camera.h
          JuliaGPU-v1.2pts/01-JuliaGPU-PTS.patch
          JuliaGPU-v1.2pts/build.sh
          JuliaGPU-v1.2pts/displayfunc.c
          JuliaGPU-v1.2pts/
          juliaGPU.c: In function 'SetUpOpenCL':
          juliaGPU.c:323:2: warning: 'clCreateCommandQueue' is deprecated [-Wdeprecated-declarations]
            commandQueue = clCreateCommandQueue(
            ^
          In file included from juliaGPU.c:37:0:
          /usr/include/CL/cl.h:1359:1: note: declared here
           clCreateCommandQueue(cl_context                     /* context */,
           ^
          /usr/bin/ld: cannot find -lOpenCL
          collect2: error: ld returned 1 exit status

          Comment


          • #6
            Originally posted by kaseki View Post
            Here is an example from JuliaGPU install-failed.log. Scroll down to very bottom.

            Code:
            JuliaGPU-v1.2pts/juliaGPU
            JuliaGPU-v1.2pts/juliaGPU.c
            JuliaGPU-v1.2pts/displayfunc.h
            JuliaGPU-v1.2pts/rendering_kernel.cl
            JuliaGPU-v1.2pts/renderconfig.h
            JuliaGPU-v1.2pts/README.txt
            JuliaGPU-v1.2pts/preprocessed_rendering_kernel.cl
            JuliaGPU-v1.2pts/LICENSE.txt
            JuliaGPU-v1.2pts/Makefile
            JuliaGPU-v1.2pts/vec.h
            JuliaGPU-v1.2pts/camera.h
            JuliaGPU-v1.2pts/01-JuliaGPU-PTS.patch
            JuliaGPU-v1.2pts/build.sh
            JuliaGPU-v1.2pts/displayfunc.c
            JuliaGPU-v1.2pts/
            juliaGPU.c: In function 'SetUpOpenCL':
            juliaGPU.c:323:2: warning: 'clCreateCommandQueue' is deprecated [-Wdeprecated-declarations]
            commandQueue = clCreateCommandQueue(
            ^
            In file included from juliaGPU.c:37:0:
            /usr/include/CL/cl.h:1359:1: note: declared here
            clCreateCommandQueue(cl_context /* context */,
            ^
            /usr/bin/ld: cannot find -lOpenCL
            collect2: error: ld returned 1 exit status
            Looks like for some reason the OpenCL library isn't on your system or found.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Software manager shows an awful lot of openCL related files. Is this an nVidia library?

              Comment


              • #8
                What software manager shows in an opencl search as being installed are:


                nvidia-opencl-icd-381
                ocl-icd-libopencl1
                opencl-headers

                Comment


                • #9
                  Here is the initial installation action of the specific test suite on the first run. Please note that I am not trying to get you to debug my PC; but I am hoping that you may see an embedded assumption in your test installation code that doesn't apply to Mint 18.1 (which I think is derived from Ubuntu 16.10).

                  Code:
                  The following dependencies are needed and will be installed: 
                  
                  
                  
                  
                  - opencl-headers
                  
                  - ocl-icd-libopencl1
                  
                  - cmake
                  
                  - cmake-data
                  
                  - darktable
                  
                  
                  
                  
                  This process may take several minutes.
                  
                  Reading package lists...
                  
                  Building dependency tree...
                  
                  Reading state information...
                  
                  ocl-icd-libopencl1 is already the newest version (2.2.8-1).
                  
                  ocl-icd-libopencl1 set to manually installed.
                  
                  The following package was automatically installed and is no longer required:
                  
                  xserver-xorg-legacy
                  
                  Use 'sudo apt autoremove' to remove it.
                  
                  The following additional packages will be installed:
                  
                  libcolord-gtk1 libcurl3 libflickcurl0 libgraphicsmagick-q16-3
                  
                  libjs-prototype libjs-scriptaculous libjsoncpp1 liblensfun-data liblensfun0
                  
                  libosmgpsmap-1.0-1 libpugixml1v5
                  
                  Suggested packages:
                  
                  codeblocks eclipse ninja-build graphicsmagick-dbg
                  
                  Recommended packages:
                  
                  javascript-common
                  
                  The following NEW packages will be installed:
                  
                  cmake cmake-data darktable libcolord-gtk1 libcurl3 libflickcurl0
                  
                  libgraphicsmagick-q16-3 libjs-prototype libjs-scriptaculous libjsoncpp1
                  
                  liblensfun-data liblensfun0 libosmgpsmap-1.0-1 libpugixml1v5 opencl-headers
                  
                  0 upgraded, 15 newly installed, 0 to remove and 18 not upgraded.
                  
                  Need to get 8,458 kB of archives.
                  
                  After this operation, 41.5 MB of additional disk space will be used.
                  
                  Get:1 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 cmake-data all 3.5.1-1ubuntu3 [1,121 kB]
                  
                  Get:2 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 libcurl3 amd64 7.47.0-1ubuntu2.2 [186 kB]
                  
                  Get:3 http://archive.ubuntu.com/ubuntu xenial/main amd64 libjsoncpp1 amd64 1.7.2-1 [73.0 kB]
                  
                  Get:4 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 cmake amd64 3.5.1-1ubuntu3 [2,623 kB]
                  
                  Get:5 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libflickcurl0 amd64 1.25-3 [134 kB]
                  
                  Get:6 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libcolord-gtk1 amd64 0.1.26-1 [16.6 kB]
                  
                  Get:7 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libgraphicsmagick-q16-3 amd64 1.3.23-1build1 [1,103 kB]
                  
                  Get:8 http://archive.ubuntu.com/ubuntu xenial/universe amd64 liblensfun-data all 0.2.8-3 [82.0 kB]
                  
                  Get:9 http://archive.ubuntu.com/ubuntu xenial/universe amd64 liblensfun0 amd64 0.2.8-3 [45.7 kB]
                  
                  Get:10 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libosmgpsmap-1.0-1 amd64 1.1.0-1 [39.2 kB]
                  
                  Get:11 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libpugixml1v5 amd64 1.7-2 [82.9 kB]
                  
                  Get:12 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libjs-prototype all 1.7.1-3 [44.2 kB]
                  
                  Get:13 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libjs-scriptaculous all 1.9.0-2 [107 kB]
                  
                  Get:14 http://archive.ubuntu.com/ubuntu xenial/universe amd64 darktable amd64 2.0.3-1 [2,745 kB]
                  
                  Get:15 http://archive.ubuntu.com/ubuntu xenial/main amd64 opencl-headers all 2.0~svn32091-2 [56.0 kB]
                  
                  Fetched 8,458 kB in 3s (2,449 kB/s)
                  
                  Selecting previously unselected package cmake-data.
                  
                  (Reading database ... 406506 files and directories currently installed.)
                  
                  Preparing to unpack .../cmake-data_3.5.1-1ubuntu3_all.deb ...
                  
                  Unpacking cmake-data (3.5.1-1ubuntu3) ...
                  
                  Selecting previously unselected package libcurl3:amd64.
                  
                  Preparing to unpack .../libcurl3_7.47.0-1ubuntu2.2_amd64.deb ...
                  
                  Unpacking libcurl3:amd64 (7.47.0-1ubuntu2.2) ...
                  
                  Selecting previously unselected package libjsoncpp1:amd64.
                  
                  Preparing to unpack .../libjsoncpp1_1.7.2-1_amd64.deb ...
                  
                  Unpacking libjsoncpp1:amd64 (1.7.2-1) ...
                  
                  Selecting previously unselected package cmake.
                  
                  Preparing to unpack .../cmake_3.5.1-1ubuntu3_amd64.deb ...
                  
                  Unpacking cmake (3.5.1-1ubuntu3) ...
                  
                  Selecting previously unselected package libflickcurl0:amd64.
                  
                  Preparing to unpack .../libflickcurl0_1.25-3_amd64.deb ...
                  
                  Unpacking libflickcurl0:amd64 (1.25-3) ...
                  
                  Selecting previously unselected package libcolord-gtk1:amd64.
                  
                  Preparing to unpack .../libcolord-gtk1_0.1.26-1_amd64.deb ...
                  
                  Unpacking libcolord-gtk1:amd64 (0.1.26-1) ...
                  
                  Selecting previously unselected package libgraphicsmagick-q16-3.
                  
                  Preparing to unpack .../libgraphicsmagick-q16-3_1.3.23-1build1_amd64.deb ...
                  
                  Unpacking libgraphicsmagick-q16-3 (1.3.23-1build1) ...
                  
                  Selecting previously unselected package liblensfun-data.
                  
                  Preparing to unpack .../liblensfun-data_0.2.8-3_all.deb ...
                  
                  Unpacking liblensfun-data (0.2.8-3) ...
                  
                  Selecting previously unselected package liblensfun0.
                  
                  Preparing to unpack .../liblensfun0_0.2.8-3_amd64.deb ...
                  
                  Unpacking liblensfun0 (0.2.8-3) ...
                  
                  Selecting previously unselected package libosmgpsmap-1.0-1:amd64.
                  
                  Preparing to unpack .../libosmgpsmap-1.0-1_1.1.0-1_amd64.deb ...
                  
                  Unpacking libosmgpsmap-1.0-1:amd64 (1.1.0-1) ...
                  
                  Selecting previously unselected package libpugixml1v5:amd64.
                  
                  Preparing to unpack .../libpugixml1v5_1.7-2_amd64.deb ...
                  
                  Unpacking libpugixml1v5:amd64 (1.7-2) ...
                  
                  Selecting previously unselected package libjs-prototype.
                  
                  Preparing to unpack .../libjs-prototype_1.7.1-3_all.deb ...
                  
                  Unpacking libjs-prototype (1.7.1-3) ...
                  
                  Selecting previously unselected package libjs-scriptaculous.
                  
                  Preparing to unpack .../libjs-scriptaculous_1.9.0-2_all.deb ...
                  
                  Unpacking libjs-scriptaculous (1.9.0-2) ...
                  
                  Selecting previously unselected package darktable.
                  
                  Preparing to unpack .../darktable_2.0.3-1_amd64.deb ...
                  
                  Unpacking darktable (2.0.3-1) ...
                  
                  Selecting previously unselected package opencl-headers.
                  
                  Preparing to unpack .../opencl-headers_2.0~svn32091-2_all.deb ...
                  
                  Unpacking opencl-headers (2.0~svn32091-2) ...
                  
                  Processing triggers for man-db (2.7.5-1) ...
                  
                  Processing triggers for libc-bin (2.23-0ubuntu7) ...
                  
                  Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
                  
                  Processing triggers for mime-support (3.59ubuntu1) ...
                  
                  Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
                  
                  Setting up cmake-data (3.5.1-1ubuntu3) ...
                  
                  Setting up libcurl3:amd64 (7.47.0-1ubuntu2.2) ...
                  
                  Setting up libjsoncpp1:amd64 (1.7.2-1) ...
                  
                  Setting up cmake (3.5.1-1ubuntu3) ...
                  
                  Setting up libflickcurl0:amd64 (1.25-3) ...
                  
                  Setting up libcolord-gtk1:amd64 (0.1.26-1) ...
                  
                  Setting up libgraphicsmagick-q16-3 (1.3.23-1build1) ...
                  
                  Setting up liblensfun-data (0.2.8-3) ...
                  
                  Setting up liblensfun0 (0.2.8-3) ...
                  
                  Setting up libosmgpsmap-1.0-1:amd64 (1.1.0-1) ...
                  
                  Setting up libpugixml1v5:amd64 (1.7-2) ...
                  
                  Setting up libjs-prototype (1.7.1-3) ...
                  
                  Setting up libjs-scriptaculous (1.9.0-2) ...
                  
                  Setting up darktable (2.0.3-1) ...
                  
                  Setting up opencl-headers (2.0~svn32091-2) ...
                  
                  Processing triggers for libc-bin (2.23-0ubuntu7) ...
                  
                  
                  
                  
                  Phoronix Test Suite v7.0.1
                  
                  
                  
                  
                  To Install: pts/shoc-1.1.0
                  
                  To Install: pts/juliagpu-1.3.0
                  
                  To Install: system/darktable-1.0.0
                  
                  To Install: pts/cl-mem-1.0.1
                  
                  To Install: pts/viennacl-1.0.0
                  
                  To Install: pts/mandelgpu-1.3.1
                  
                  To Install: pts/luxmark-1.1.0
                  
                  
                  
                  
                  Determining File Requirements ..........................................
                  
                  Searching Download Caches ..............................................
                  
                  
                  
                  
                  7 Tests To Install
                  
                  7 Files To Download [197MB]
                  
                  835MB Of Disk Space Is Needed
                  
                  
                  
                  
                  pts/shoc-1.1.0:
                  
                  Test Installation 1 of 7
                  
                  1 File Needed [2.77 MB / 1 Minute]
                  
                  Downloading: shoc-20151110.zip [2.77MB]
                  
                  Estimated Download Time: 1m ........................................
                  
                  Installation Size: 408 MB
                  
                  Installing Test @ 12:05:19
                  
                  The installer exited with a non-zero exit status.
                  
                  ERROR: OpenCL support was requested, but no usable OpenCL library was fund
                  
                  LOG: ~/.phoronix-test-suite/installed-tests/pts/shoc-1.1.0/install-failed.log

                  Comment

                  Working...
                  X