Announcement

Collapse
No announcement yet.

NVIDIA 177.80 Display Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • phoronix
    started a topic NVIDIA 177.80 Display Driver

    NVIDIA 177.80 Display Driver

    Phoronix: NVIDIA 177.80 Display Driver

    Over the course of the past few months we have seen several NVIDIA Linux drivers that have all been marked as beta with the last official release appearing in April. Today though NVIDIA has released the 177.80 Linux driver, which is an official update and christens the changes made with the 177.67, 177.68, 170.70, 177.76, and 177.78 beta drivers. Among the changes are RENDER extension improvements, finally officially supporting the GeForce GTX series, text rendering fixes, and there are 25 official changes in total.

    http://www.phoronix.com/vr.php?view=12922

  • Mota_boy
    replied
    I borrowed Ati card from my friend some time ago and didn't have problems with it. No matter - fglrx or open drivers it worked very well. My nvidia card is slow in KDE4 like a turtle, fonts are corrupted etc. etc....

    Hmm well i have use ati`s and nvidias card too, but i still like to thing in both cases why doesn`t something work, or works nto so good
    and not make it sweeping ( hope the word is rigth one, sorry bit lack english ) way , still happy to hear this progress from nvidia

    Leave a comment:


  • Redeeman
    replied
    Originally posted by b15hop View Post
    I think the days of bad ATi drivers are over. I think my next machine I'll try another ATi card. Mainly because the tide is turning, with open source support now available for ATi cards.
    that is, available, for _SOME_ cards, not the newer.

    Leave a comment:


  • b15hop
    replied
    I think the days of bad ATi drivers are over. I think my next machine I'll try another ATi card. Mainly because the tide is turning, with open source support now available for ATi cards.

    PS: I use Arch Linux. Seems to be a pretty good distro. Although the arch package nvidia driver doesn't always work so I just download the driver from the nvidia website. That's probably the only problem I've really ever had with nvidia at a driver level. Otherwise it would be nice if the card itself was a little quieter.

    Leave a comment:


  • Milyardo
    replied
    Originally posted by Porter View Post
    I did that, it still threw a fit.
    run level 3 in ubuntu still runs GDM. The best way to stop X in ubuntu is to just stop GDM with its init script. First switch to any TTY then:

    Code:
    sudo /etc/init.d/gdm stop
    Then
    Code:
    sudo /etc/init.d/gdm start
    to start it again.

    Leave a comment:


  • Porter
    replied
    Originally posted by deanjo View Post
    All you had to do is boot to runlevel 3 or invoke it by typing init 3 into your console.
    I did that, it still threw a fit.

    Leave a comment:


  • gzahl
    replied
    Oh yeah, don't buy ATI its a pain... I'm reading this thread, because i think of buying a nvidia card *g*, because after 2 or 3 years of ATI i'm done..

    If there would only be an PciE Intel Card...

    Leave a comment:


  • deanjo
    replied
    Originally posted by Kano View Post
    @deanjo

    thats the SuSE way (and would also work on Kanotix), but the default Debian/Ubuntu runlevels are the same from 2 to 5.

    My script knows that and does not require to shutdown X, you should only to use a text console, like you get when you press CTRL+ALT+F1. It shuts down X using gdm/kdm/xdm - whatever it was used.

    In the very rare case that it is impossible to get into a textconsole - maybe due to screen corruption, it is possible to disable the check and use nohup like:

    sudo -i
    DISPLAY= nohup sh install-nvidia-debian.sh

    notice that there MUST be a space behind the =.
    Good to know.

    Leave a comment:


  • Kano
    replied
    @deanjo

    thats the SuSE way (and would also work on Kanotix), but the default Debian/Ubuntu runlevels are the same from 2 to 5.

    My script knows that and does not require to shutdown X, you should only to use a text console, like you get when you press CTRL+ALT+F1. It shuts down X using gdm/kdm/xdm - whatever it was used.

    In the very rare case that it is impossible to get into a textconsole - maybe due to screen corruption, it is possible to disable the check and use nohup like:

    sudo -i
    DISPLAY= nohup sh install-nvidia-debian.sh

    notice that there MUST be a space behind the =.

    Leave a comment:


  • deanjo
    replied
    Originally posted by Porter View Post
    I did read the README... In my case I kept having trouble with the Nvidia script screaming about X running even though I was booting directly to a console. The driver's in the repos now though, so no worries.
    All you had to do is boot to runlevel 3 or invoke it by typing init 3 into your console.

    Leave a comment:

Working...
X