No announcement yet.

My Nvidia laptop is locked up because I tried kernel 4.9-rc1 as a shot in the dark.

  • Filter
  • Time
  • Show
Clear All
new posts

  • My Nvidia laptop is locked up because I tried kernel 4.9-rc1 as a shot in the dark.

    I've already tried not getting any help there. Tried IRC channel kde-devel no one answers, could be different time zones. I tried KDE Neon users facebook group, no help there. I'm totally willing to go back to official highest supported kernel which is 4.4.something. I'm totally willing to go to a lesser driver or wipe nvidia and use nouveau, whatever it takes. It's going be a real pain in the butt if I have to do a fresh install because I'll have to redownload all those steam games so that's the last option.

    I'm using KDE Neon. My laptop is an i5 with a GTX 960m driver 370. This happened on Neon 5.8.1 they are now on 5.8.2 and I believe they fixed the bug I was trying to solve.
    My problem used to be that I could not see my laptop screen unless I had an external monitor hooked up to it. I tried various regular solutions and then I took a shot in the dark and tried out kernel 4.9rc1 which worked, I got my screen back. But then I moved from nvidia driver 367 to 370 and reinstalled nvidia settings then I tried to install laptop-mode-tools and that's when my laptop locked up.

    It won't boot to any kernel, it won't let me install or uninstall anything. I'm getting something like init-rc d: cannot determine current run level. I don't have the laptop with me, it's at home so if there is anything you can suggest I can do it when I get home from work.

  • #2
    Seems like booting into text mode would be a good first step ?
    Test signature


    • #3
      By booting into text mode do you mean drop to root shell in recovery, because I can do that. I can regenerate grub, I can apt-get update but if I try to install, uninstall or dist-upgrade it says dpkg was interrupted I have to sudo dpkg --configure -a and then when I do it tells me it can't determine current run level.


      • #4
        This guy has the same situation. As soon as I follow that command it gets stuck trying to install laptop-mode-tools which I would like to stop that installation and remove the lock so i can do an upgrade.
        The guy here says the solution is to delete some lock files but trying to cd into that first directory just to see if it is there in my system, it's not there.
        He says:
        sudo rm /var/lib/apt/lists/lock sudo rm /var/cache/apt/archives/lock cd /var/lib/dpkg/updates sudo rm * sudo apt-get update


        • #5
          Wait I think I got it. Except for that first file that I don't have I have the rest. I followed that and it worked I think. I'm doing a dist-upgrade. I might have this whole thing fixed.


          • #6
            That link doesn't work^
            I think I got the problem solved but now I'm running into this bug.
            When I do what that guy suggests it tells me that the program "at" is not installed. Is that correct or did I make a typing mistake? Also If I try to install anything it's going to tell me dpkg was interrupted and to run dpkg --configure - a which will send it right back into trying to install snapd and it will get stuck.
            If the answer is the other one he suggests to open another console while it says setting up snapd and send that command how would I be able to do that in recovery. I did not think that was possible.

            If the answer is to remove snapd as the other guy said he did how would I do that while it is locked into installing it?

            Maybe I am able to boot to a desktop now I haven't even checked. If so I could run that second Kinsale and issue that command to unstick it.


            • #7
              That problem is solved now and now I'm back to the same bug as before, after logging in I have a black screen. This has to be an Nvidia problem as I have 2 laptops on KDE Neon both are the same except one has Nvidia.