No announcement yet.

What's the status of the binary nvidia driver with (U)EFI systems?

  • Filter
  • Time
  • Show
Clear All
new posts

  • What's the status of the binary nvidia driver with (U)EFI systems?

    Hi all!

    First of all, I did try to find relevant information regarding this issue, both in the forums and the Internet, but I have not been successuful, so if this has been (as I'm sure it has) posted here already, and already answered. I apologize for posting again.

    Second, here's what I (first hand) know:
    • Installation is still not supported under this configuration, for you to be able to install the drivers, you have to have an MBR disk layout (partition table) and boot with BIOS mode (as I did when migrating my old system to the new one, only when reinstalling I realized I couldn't make the drivers work).
    • There seems to be some sort of conflict with (U)EFI and modesetting, which KMS we know is not supported in the nvidida blob.


    Case 1 - Main workstation

    ASUS motherboard (M5-A97 R2.0) latest firmware update UEFI 2.0 and BIOS mode
    AMD 6-core CPU
    MSI nVidia GTX 760 4Gb
    Rest of the specs are really not relevant.
    Operating System - Fedora Linux, originally installed fresh as Fedora 15 upgraded up to 19 through the various releases with fedup and yum.

    With this system, when migrating the very first time to this rig, I came from a much older ASUS motherboard with only BIOS and hence the HDD and OS had been previously installed with this configuration, when migrating the hardware nothing was needed to be reconfigured/reset. With Fedora at version 20, and me getting a new SSD somewhere around April this year, I decided it was time for a fresh install (that and the many different issues I had with some programs, such as The Witche 2 due to pre-link still being default in Fedora up to 19). The Live USB booted into EFI mode, as I noticed due to not seeing the familiar syslinux graphics and menu, and while the live session worked just fine, the install process was a bit more laborious (with a custom partition scheme) due to me not having into account the needed FAT EFI partition, and Anaconda complaining about the partitioning scheme I chose (the regular three parts for /, /home and swap). The resulting installation "worked" just fine, so long I kept the nouveau driver, as trying to install the proprietary drivers did not succeed. In the end, after a few hours trying to figure things out, out of frustration and rage, I decided to reinstall in BIOS mode with an MBR partition table, and lo and behold, the nVidia drivers worked like a charm. I then got back the machine into booting in dual mode (UEFI and BIOS) from the frimware screen, and the machine has been working just fine.

    Case 2 - Laptop computer - MacBook Pro mid 2010 (7.1) 13"

    Core2Duo 2.4 GHz - some Intel MoBo
    nVidia GeForce 320M graphics with dedicated 256Mb vRAM (you may laugh now) at firmware version MBP71.0039.B0E, SMC 1.62f7
    Apple's custom-crippled EFI 0.99 implementation (I really cannot say this to even be EFI 1.0 compliant, though I know they claim it to be 1.1 compliant)

    This one is a much more frustrating case, as I wanted to keep OS X alongside Linux (an utter nightmare) and to which end I started distro-hopping in the search for the best option, in the end they all ended with the same result: Utter frustration. Trying to even attempt installation of anything other than OSX on these machines is one hell of a bumpy ride, forcing you to try several different "boot" managers (EFI applications to start a different system) with different degrees of success... the best option being to use BIOS mode so you could try and get GRUB 1.99 to run (at least in theory, I was never successful with this), so I was never able to install in this mode, much less to boot and hence attempt the installation of the blob; but I did manage to get GRUB 0.99 to boot in EFI mode and complete an installation of an asorment of distributions from Ubuntu, to Arch to settling down again with Fedora, only this time I only attempted to boot up in this machine Fedora 16 and Fedora 17.

    Fast forward to these past weeks, and I have kept this machine Mac Kosher as much as I have managed. So OS X 10.8 and 10.9 came and gone since my last attempt, and have had not felt the need to "break" it... that is until I dared upgrading to Yosemite... Or as I call it Apple's version of Windows Millenium Vista... A horrid iteration of its operating system... and I'm not only talking from my experience with this "dated" machine (but still much capable given its hardware configuration). Certainly capable enough to handle very well just the OS... Or so I thought... Anyway, this is not intended as a totally biased, subjective review of MudMound, err Yosemite; but rather about my latest attempt at getting things better for this poor lappy.

    In the end my only question is this: How well do nvidia drivers support deployment in EFI configured systems nowadays? Especially with the latest BETA drivers. Given I was never successful to boot the Mac in BIOS mode, and only was able to boot in EFI mode. Any pointers? I'm pondering a fresh install of the Worksation with F21 and will deffinitely attempt to install some sort of Linux into this MacBook Pro, before Yosemite makes me throw it into a river.

  • #2
    I see no problem using nvidia binary drivers with uefi. Maybe there is an uefi gop firmware update for your card available, if so, installiert that first. Use latest firmware for your board too! After that you can even disable CSM. Our Kanotix 64 Special ISO images allow the use of binary drivers even in live mode with gfxdetect. Currently the preinstalled xbmc is not patched to disable vaapi with nvidia (needed to try fglrx vaapi) but will do that next week. Put it onto USB key 1:1.


    • #3
      Thanks for the reply, Kano.

      What do you mean by EFI GOP for my GPU? From what I have been able to make out of the EFI description, is a means for the graphics stack to be abstracted, the other being UGA, which I assume is the one used in the Mac, so my guess is that support for this should be installed in the ESP and should support my GPU?

      What about the MacBook, do this also applies for it? Do you have experience installing the blob in Mac hardware? I'willing to attempt Kanotix and report success, issues or bugs I encounter. But deffinitely would like to know a bit more before I jump in.



      • #4
        Sorry for cross-posting, but it seems there a lot of people around searching for this and I would like to involve as many as possible.

        I am quite confident about having found a working solution to boot my Macbook Pro 7.1 (mid-2010) in EFI mode with Nvidia drivers. SERIOUSLY!
        Please review my article including Xorg.0.log and the solution. Enjoy a little taste of AHCI and Powermizer as well as brightness controls...
        Feedback appreciated.

        My approach is described in detail here:

        An active discussion is already evolving here on Arch Linux forums:

        I will however also follow this thread here.

        best regards,