No announcement yet.

NVIDIA 169.04 Beta Linux Driver

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I usually start compiz by typing this into the console:
    compiz --replace ccp &
    It always fell back to Indirect Rendering but if I added --no-libgl-fallback it went away. Both ways worked perfectly and I didn't see any difference.

    With the new driver it crashes/gives up with both. I even tried to enter it exactly like yours and it still doesn't work.

    By the way, what does the export __GL_YIELD="NOTHING" do?


    • #12
      It's what these auto-loaders such as Fusion Icon and Compiz Manager do before running Compiz when they detect that an MVidia card is being used. So I just copied that when doing the starting of Compiz from a terminal myself. It also has appeared in Forum posts on the Compiz Fusion forum and in the Compiz Fusion wiki as a recommended way to start up Compiz Fusion with an NVidia card. Think I saw it at forum as well.

      As to your situation, perhaps try uninstalling and reinstalling the NVidia driver:

      On OpenSUSE:
      su -
      put the root password
      init 3
      login as root
      nvidia-installer --uninstall
      cd to your NVidia installer script
      sh -q
      sax2 -r -m 0=nvidia
      save and exit sax2 after adjusting the monitor
      nvidia-xconfig --composite
      shutdown -a -r now
      kdesu kate /etc/X11/xorg.conf
      gnomesu gedit /etc/X11/xorg.conf
      change HWCursor from off to on
      save, close, exit the editor
      logout, ctrl-alt-backspace, login
      kdesu or gnomesu nvidia-settings
      save to configuration file
      logout, ctrl-alt-backspace, login
      Try to run Compiz Fusion

      On Debian systems do the same except:
      login as root
      /etc/init.d/kdm or gdm stop
      The rest is the same except not needing to deal with the HWCursor blinky mouse cursor and having a drop-down link to click in KDM to restart the X server without needing to ctrl-alt-backspace, and instead of the sax2 stuff doing:

      dpkg-reconfigure -phigh xserver-xorg
      (phigh makes it start with a clean auto-detection)
      dpkg-reconfigure xserver-xorg
      nvidia-xconfig --composite

      If that doesn't work then try reinstalling and/or purging all the compiz stuff and installing it again.

      That's what I would try. Other than that stuff I wouldn't know what to do and would post to the Compiz Fusion forum for help from all those developer and expert Compiz folks.