Announcement

Collapse
No announcement yet.

NVIDIA 313.09 Linux Driver Packs New Features

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ninez
    replied
    Originally posted by johnc View Post
    When I moved to 12.04, I just set all of my compiz plugins back to the 10.10 configurations I had. lol. Like the Expo plugin, I went with the old-school zoom-out style.
    Well, i don't use Ubuntu - but changing your settings the way you did, doesn't really address any of the bugs in compiz that i mentioned. I used to interact with the compiz-devs a fair bit, with bug reporting, a few fixes, etc but after a few of the showstopper bugs not being addressed (after a long time) i pretty much gave up on compiz (which was fairly recent).

    Originally posted by johnc View Post
    I think in due time I'll give Cinnamon and maybe even Elementary a look. Unity is "okay" but some things are annoying and ugly.
    Yeah, aside from switching to KDE and settling on cinnamon ~ i had also given elementary a try.... It's pretty good too, but personally, i like cinnamon better, as it seems a little more customizable and feels less like the DE is trying to force a certain workflow, but instead just allows the user to do what he/she wants. Imo, Cinnamon is probably the best DE (for me) given the choices.

    Leave a comment:


  • johnc
    replied
    Originally posted by ninez View Post
    I may take a look, but i got sick of all of the nvidia problems with compiz and switched to KDE (which i couldn't get used too) and then settled on cinnamon, which is great and has a much better implementation of expo than compiz does. (compiz has had the same few ugly bugs for years and years - dragging/wrapping windows results in the workspace being drawn above the window, the window-edges/aliasing is terrible in not only expo, but also scale too).
    When I moved to 12.04, I just set all of my compiz plugins back to the 10.10 configurations I had. lol. Like the Expo plugin, I went with the old-school zoom-out style.

    I think in due time I'll give Cinnamon and maybe even Elementary a look. Unity is "okay" but some things are annoying and ugly.

    Leave a comment:


  • ninez
    replied
    Originally posted by johnc View Post
    Well this is cool... there's already an experimental compiz w/ support for the new GLX_EXT_buffer_age extension:

    http://smspillaz.wordpress.com/2012/...-improvements/
    yeah, i saw that too - i actually linked to the same article in the 6-way gfx benchmarks thread (just now).

    I may take a look, but i got sick of all of the nvidia problems with compiz and switched to KDE (which i couldn't get used too) and then settled on cinnamon, which is great and has a much better implementation of expo than compiz does. (compiz has had the same few ugly bugs for years and years - dragging/wrapping windows results in the workspace being drawn above the window, the window-edges/aliasing is terrible in not only expo, but also scale too).

    But on the brightside, according to Sam's blog, that experimental ppa, has fixes for the long standing show-stopper of window-dragging (when using certain gl app, like xbmc) resulting in your whole desktop moving at a crawl (basically unusable). Which is one of the reasons i dropped compiz + the 'nvidia blank window' bug, which hasn't been fixed in the 1yr 1/2 that the bug report has existed ~ even though it makes using compiz with nvidia annoying.

    Leave a comment:


  • johnc
    replied
    Well this is cool... there's already an experimental compiz w/ support for the new GLX_EXT_buffer_age extension:

    http://smspillaz.wordpress.com/2012/...-improvements/

    Leave a comment:


  • ninez
    replied
    Originally posted by kokoko3k View Post
    I just tried those drivers, but nvidia failed (again) to provide gradient acceleration to cairo.
    As a result if your gtk theme is not *VERY* basic and you use vanilla cairo, you'll get a really slow scrolling when native widgets (buttons, input boxes) are displayed in the page.
    Workarounds are to use an ugly gtk theme or to rely entirely on the cpu by patching cairo source.
    Can you give an example of such an application? ...I ask because i am using the latest nvidia driver, with a not_so_basic gtk theme, cairo 12.4 (not patched) and i haven't noticed any slow scrolling in any application... The only time i would ever see slow scrolling is in Firefox watching flash videos using vdpau ~ which doesn't even really happen anymore (since nvidia started including vdpau).

    System tested on; Nvidia 313.09 / Nvidia GT440 / AMD Phenom II 965 X4 / 16gig RAM / Archlinux 64bit / Cinnamon (built weekly from git)

    that being said, if i can reproduce this issue, it would probably be worth reporting, or adding myself to your existing report (which i assume you have made, otherwise you are just wasting your breathe complaining here ).

    cheerz

    As a side not to my earlier comment about the traces in dmesg; they have returned, so that bug still exists, although it isn't causing me issues...

    Leave a comment:


  • kokoko3k
    replied
    Cairo and missing acceleration

    I just tried those drivers, but nvidia failed (again) to provide gradient acceleration to cairo.
    As a result if your gtk theme is not *VERY* basic and you use vanilla cairo, you'll get a really slow scrolling when native widgets (buttons, input boxes) are displayed in the page.
    Workarounds are to use an ugly gtk theme or to rely entirely on the cpu by patching cairo source.

    For the record, nouveau or even ati drivers on a poor 9500se scrolls better.

    Leave a comment:


  • nir2142
    replied
    The direction that nvidia going its very coool i hope that they keep going this way also in GL 3 and 4

    and there is a few 3d application that use gl 2.0 or 2.1 like Autodesk maya (i think) and Softimage , yes?

    Leave a comment:


  • Marc Driftmeyer
    replied
    Originally posted by mark45 View Post
    Also, glDrawPixels() is for GL 2.1 and earlier versions, the newer ones: GLES 2.0/3.0 and GL 3.3/4.x (core profile) don't support glDrawPixels().
    Which is quite relevant seeing as Kwin and other compositors aren't even using OpenGL 2.1 yet.

    Leave a comment:


  • scix
    replied
    Originally posted by blackout23 View Post
    Good to know. I was testing SS3 a lot and I get 50-53 FPS on average on Ultra and 1920x1200 which is quite OK. Problem is that as soon as I enable VSync it of course limits itself to 30 FPS to align it with the refreshrate but doesn't do a good job at this. So you have worse performance which feels a lot more laggy and still get screen tearing. So I thought this feature was missing. On Windows I was able to get >30 and <60 FPS without tearing and V Sync would just cap it at 60 most of the time since it is a bit faster there in general. So there is no reason to not enable V Sync in Windows but on Linux the way it is handled now can dramatically change the performance. So I hope to see an override setting in nvidia-settings soon.
    Turn on triple buffering by putting this in the Device section of /etc/X11/xorg.conf :

    Code:
    Option "TripleBuffer" "true"
    You should get pretty much the same framerate as with VSync disabled, at the cost of slight increase in input lag (which will will probably be less severe than normal vsync)

    Also make sure FXAA isn't forced on in nvidia-settings as it will disable triple buffering. In game supported FXAA seems to work fine.

    Leave a comment:


  • e8hffff
    replied
    Installing off ppa xorg edgers, system restarted into commandline rather than gfx. Had to clean out all nvidia files of the older driver 310.19 from /var and /usr directories and then install using the installer from nvidia.com. I used Krusader(root) to delete the files. Once done gfx worked but not 3D. Just reinstalled the packages in package-manager(synaptic) for 313.09 and the 3D worked straight after.

    Note, to install NVIDA drivers close down all gfx session and goto a root CLI.
    'killall lightdm' is if it's still running.
    'bash NVIDIA-Linux-x86_64-313.09.run' to install

    Leave a comment:

Working...
X