No announcement yet.

NVIDIA Quadro NVS 290 and Linux - cannot make it work

  • Filter
  • Time
  • Show
Clear All
new posts

  • NVIDIA Quadro NVS 290 and Linux - cannot make it work

    I hope this is the right place to post my problem. I hope someone here can help me, for official NVidia forums are not working for a long time now.

    I cannot make my Linux workstation work under NVidia binary drivers. For I have a Quadro NVS 290 in it, I cannot use nouveau drivers (card is not correctly supported) and all is left are slow nv drivers. If I try to use the binary drivers (I've tried many recent versions, they all behave the same), all I get is a blank screen (the monitor powers off). In the same time, Xorg starts to eat 100% of one core, while kernel produces more and more kworker processes (which stay in the system). The box becomes les and less responsive. Even if I manage to login to it via ssh, I cannot reboot it, for kernel eats up more and more resources and the initscripts have no time to do their job. Finally, the machile locks.

    I can provide you with both Xorg log file, dmesg part, file with strace -vf Xorg output or whatever you wish. I just hope that anyone can help me. I don't know where to look for the solution any more.

  • #2
    From wikipedia your card is just a G86 variant (similar to 8500GT), should work with the latest nv binary and nouveau. The quadro bios just acts as "copyprotection" for some extra opengl features, should not affect nouveau at all. You say nothing about the distro you use and how you tried to install the drivers - multiarch systems should only be used with official distro packages (or a ppa if needed in case of U).


    • #3
      Thanks for reply.
      My machine is a Dell T5400 workstation.
      I'm using a PLD distro, which not that popular (rpm-based). I've tried using our distro kernel (in 32-bit architecture with PAE), as well as a vanilla kernel (same settings). I've compiled the binary NVidia drivers myself both from out distro package, as well as from the binary installer downloaded from the NVidia site. The results were all the same. I remember, that I was able to use binary NVidia drivers a year ago or something like that, but then I've expected some problems and was forced to switch to nv, becouse nouveau was very unstable on my machine (I'd also given it a try then).

      I've just tried running nouveau (version 1.0.2) with kernel 3.5.7. With acceleration enabled, I'm getting a segfault:
      [  5235.680] (II) LoadModule: "nouveau"
      [  5235.680] (II) Loading /usr/lib/xorg/modules/drivers/
      [  5235.681] (II) Module nouveau: vendor="X.Org Foundation"
      [  5235.681]    compiled for 1.13.0, module version = 1.0.2
      [  5235.681]    Module class: X.Org Video Driver
      [  5235.681]    ABI class: X.Org Video Driver, version 13.0
      [  5235.681] (II) NOUVEAU driver 
      [  5235.681] (II) NOUVEAU driver for NVIDIA chipset families :
      [  5235.681]    RIVA TNT        (NV04)
      [  5235.681]    RIVA TNT2       (NV05)
      [  5235.681]    GeForce 256     (NV10)
      [  5235.681]    GeForce 2       (NV11, NV15)
      [  5235.681]    GeForce 4MX     (NV17, NV18)
      [  5235.681]    GeForce 3       (NV20)
      [  5235.681]    GeForce 4Ti     (NV25, NV28)
      [  5235.681]    GeForce FX      (NV3x)
      [  5235.681]    GeForce 6       (NV4x)
      [  5235.681]    GeForce 7       (G7x)
      [  5235.681]    GeForce 8       (G8x)
      [  5235.681]    GeForce GTX 200 (NVA0)
      [  5235.681]    GeForce GTX 400 (NVC0)
      [  5235.681] (--) using VT number 6
      [  5235.769] (II) Loading sub module "dri"
      [  5235.769] (II) LoadModule: "dri"
      [  5235.769] (II) Module "dri" already built-in
      [  5235.769] (II) NOUVEAU(0): Loaded DRI module
      [  5235.770] (II) [drm] DRM interface version 1.4
      [  5235.770] (II) [drm] DRM open master succeeded.
      [  5235.770] (--) NOUVEAU(0): Chipset: "NVIDIA NV86"
      [  5235.770] (**) NOUVEAU(0): Depth 24, (--) framebuffer bpp 32
      [  5235.770] (==) NOUVEAU(0): RGB weight 888
      [  5235.770] (==) NOUVEAU(0): Default visual is TrueColor
      [  5235.770] (==) NOUVEAU(0): Using HW cursor
      [  5235.770] (==) NOUVEAU(0): GLX sync to VBlank disabled.
      [  5235.770] (==) NOUVEAU(0): Page flipping enabled
      [  5235.770] (==) NOUVEAU(0): Swap limit set to 2 [Max allowed 2]
      [  5235.882] (II) NOUVEAU(0): Output DVI-I-1 using monitor section Monitor0
      [  5235.912] (II) NOUVEAU(0): Output DVI-I-2 has no monitor section
      [  5236.006] (II) NOUVEAU(0): EDID for output DVI-I-1
      [  5236.035] (II) NOUVEAU(0): EDID for output DVI-I-2
      [  5236.035] (II) NOUVEAU(0): Manufacturer: SAM  Model: 2f  Serial#: 1095840057
      [  5236.038] (II) Loading sub module "exa"
      [  5236.038] (II) LoadModule: "exa"
      [  5236.038] (II) Loading /usr/lib/xorg/modules/
      [  5236.038] (II) Module exa: vendor="X.Org Foundation"
      [  5236.038]    compiled for 1.13.0, module version = 2.6.0
      [  5236.038]    ABI class: X.Org Video Driver, version 13.0
      [  5236.040] (II) NOUVEAU(0): Opened GPU channel 2
      [  5236.047] (II) NOUVEAU(0): [DRI2] Setup complete
      [  5236.047] (II) NOUVEAU(0): [DRI2]   DRI driver: nouveau
      [  5236.047] (II) NOUVEAU(0): [DRI2]   VDPAU driver: nouveau
      [  5236.048] (II) EXA(0): Driver allocated offscreen pixmaps
      [  5236.048] (II) EXA(0): Driver registered support for the following operations:
      [  5236.048] (II)         Solid
      [  5236.048] (II)         Copy
      [  5236.048] (II)         Composite (RENDER acceleration)
      [  5236.048] (II)         UploadToScreen
      [  5236.048] (II)         DownloadFromScreen
      [  5236.048] (==) NOUVEAU(0): Backing store disabled
      [  5236.048] (==) NOUVEAU(0): Silken mouse enabled
      [  5236.048] (II) NOUVEAU(0): [XvMC] Associated with Nouveau GeForce 8/9 Textured Video.
      [  5236.048] (II) NOUVEAU(0): [XvMC] Extension initialized.
      [  5236.048] (**) NOUVEAU(0): DPMS enabled
      [  5236.049] (II) NOUVEAU(0): RandR 1.2 enabled, ignore the following RandR disabled message.
      [  5236.049] (WW) NOUVEAU(0): Option "DPI" is not used
      [  5236.049] (--) RandR disabled
      [  5236.121] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
      [  5236.121] (II) AIGLX: enabled GLX_INTEL_swap_event
      [  5236.121] (II) AIGLX: enabled GLX_ARB_create_context
      [  5236.121] (II) AIGLX: enabled GLX_ARB_create_context_profile
      [  5236.121] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
      [  5236.121] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
      [  5236.121] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
      [  5236.121] (II) AIGLX: Loaded and initialized nouveau
      [  5236.121] (II) GLX: Initialized DRI2 GL provider for screen 0
      [  5236.252] (II) NOUVEAU(0): NVEnterVT is called.
      [  5236.279] (II) NOUVEAU(0): Setting screen physical size to 423 x 317
      [  5236.279] resize called 1600 1200
      [  5239.505] (EE) 
      [  5239.505] (EE) Backtrace:
      [  5239.505] (EE) 0: /usr/bin/Xwrapper (xorg_backtrace+0x49) [0x81c884d]
      [  5239.505] (EE) 1: /usr/bin/Xwrapper (0x8047000+0x185224) [0x81cc224]
      [  5239.505] (EE) 2: (__kernel_rt_sigreturn+0x0) [0xb77c140c]
      [  5239.505] (EE) 3: /lib/ (0x47e4c000+0x122310) [0x47f6e310]
      [  5239.505] (EE) 4: /usr/lib/xorg/modules/ (0xb7643000+0x4af1) [0xb7647af1]
      [  5239.505] (EE) 5: /usr/lib/xorg/modules/ (0xb7643000+0x5007) [0xb7648007]
      [  5239.506] (EE) 6: /usr/lib/xorg/modules/ (0xb7643000+0x5251) [0xb7648251]
      [  5239.506] (EE) 7: /usr/lib/xorg/modules/ (0xb7643000+0x7688) [0xb764a688]
      [  5239.506] (EE) 8: /usr/lib/xorg/modules/ (0xb7643000+0x3fb2) [0xb7646fb2]
      [  5239.506] (EE) 9: /usr/lib/xorg/modules/ (0xb7643000+0x10c95) [0xb7653c95]
      [  5239.506] (EE) 10: /usr/bin/Xwrapper (miImageText8+0x96) [0x81b5e0e]
      [  5239.506] (EE) 11: /usr/bin/Xwrapper (0x8047000+0x10b20a) [0x815220a]
      [  5239.506] (EE) 12: /usr/bin/Xwrapper (doImageText+0x32e) [0x807b5f8]
      [  5239.506] (EE) 13: /usr/bin/Xwrapper (ImageText+0x69) [0x807c97f]
      [  5239.506] (EE) 14: /usr/bin/Xwrapper (0x8047000+0x2fa64) [0x8076a64]
      [  5239.506] (EE) 15: /usr/bin/Xwrapper (0x8047000+0x32556) [0x8079556]
      [  5239.506] (EE) 16: /usr/bin/Xwrapper (0x8047000+0x214c5) [0x80684c5]
      [  5239.506] (EE) 17: /lib/ (__libc_start_main+0xf5) [0x47e656d1]
      [  5239.506] (EE) 18: /usr/bin/Xwrapper (0x8047000+0x2186d) [0x806886d]
      [  5239.506] (EE) 
      [  5239.506] (EE) Segmentation fault at address 0x0
      [  5239.506] 
      Fatal server error:
      [  5239.506] Caught signal 11 (Segmentation fault). Server aborting
      I know, that it may be distribution-speciffic, but I have to know, which part to recompile (if any). Without acceleration, Xorg runs but it is veeery slooow... Maybe even slower than using nv.


      • #4
        I do not know how pld linux handles blacklisting and what bootmanager it uses. But most common cause of blackscreen after nvidia binary plop installation is kms, so you should find a way disable modesettings from i.e. grub by kernel boot parameter nomodeset. Do you have old Xorg logs while you are trying to use nvidias plop.

        Second is nouveau driver which is conflicting with plop, so you have to blacklist it before loading nvidia's plop. For blacklisting it you should check the nvidia driver readme(scroll down to chapter 8.1):

        For nouveau I don't really know, my only pc with nvidia card does not even boot without blacklisting nouveau and removing kms(So I never had even change of use it). I have used for old radeon thinkpad some exa related options which make it more fluent, but dont really know does them have any use with nouveau. Check also gentoo wiki if there are any help for you.


        • #5
          Originally posted by tuke81 View Post
          For nouveau I don't really know, my only pc with nvidia card does not even boot without blacklisting nouveau and removing kms(So I never had even change of use it). I have used for old radeon thinkpad some exa related options which make it more fluent, but dont really know does them have any use with nouveau. Check also gentoo wiki if there are any help for you.
          8300 and 9800 (when I had it) were also hanging in 2010. I disabled them as well (and that means nouveau too) by means of kernel cheatcode.
          Right now, 8300 and gtx260(similar to 9800) work effortlessly with nouveau. Things change..

          Also, the segfault with nouveau due to incorrectly built kernel/drm/xorg could be tested out, if you just get recent fedora livecd and try to boot it.

          It would also be extremely cool if you help provide information and communicate with nouveau project, because at specific time... well, nvidia will stop releasing new driver for your card.


          • #6
            I've managed to fi the things, but in a bit different manner than I'd expected. I... updated the BIOS (it appeared, that there were 11 updates since my workstation was bought). And all the problems just disapeared. Now both nouveau and nvidia drivers work like a charm. I must say that I've given a try to nouveau and I almost liked it. Almost, becouse under KDE fonts in terminal (KDE terminal or Yaquake) are rendered in unacceptable way. No matter which fornt size I choose and no matter what DPI is set (by the way, nouveau still setd DPI to 96x96 by default and is not obeying any rules from xorg.conf, only xrandr --dpi is able to fix it). In standard xterm everything is OK, but I'm not using it. As far as I rememner, it was the same some time ago, when I'd tried nouveau for the first time. Therefore now I'm using nvidia. I will switch back to nouveau to make some screenshots and post it to [email protected] on monday, probably.

            Anyway, case is closed. Thank you for your willing to help me anyway.