No announcement yet.

Nvidia proprietary driver regresses after I reinstall it

  • Filter
  • Time
  • Show
Clear All
new posts

  • Nvidia proprietary driver regresses after I reinstall it

    Okay, this is a weird one.

    I realize that this post is light on technical info, but that's because I'm so unfamiliar with this topic that I'm not sure where to look for technical info. Anyone more knowledgeable, please feel free to ask me to post config files, etc. that might be relevant.

    TL;DR: After installing the latest proprietary Nvidia drivers, performance regressed quite severely in some games, but even after reinstalling the obsolete driver from the repos I'd been using before, performance hasn't gone back to previous levels.

    Hardware: Thinkpad T510, Nvidia NVS 3100M PCI-E 512 Mib GDDR3, Core i5 @2.53 Ghz, hyperthreading enabled (4 logical cores, 2 physical,) RAM upgraded to 4 GiB.

    Software: Linux Mint 10, 32-bit Linux 2.6.35-32-generic-pae kernel, Gnome 2.32 w/ Metacity, no compositing window manager effects, various versions of the Nvidia proprietary driver.

    Long version:
    I'm running Linux Mint 10 (= Ubuntu Maverick.) I know, I know, not supported anymore. I'll upgrade it when I have time. It's not really relevant for this question. I've been using that distro's version of the nvidia-current drivers for a while now. That package contains the 260.19.06 beta drivers.

    I decided to give the 304.51 drivers a shot, and discovered that my gaming framerates had decreased by about 10-20%. I tried tweaking all the settings in the Nvidia GUI: sync to vblank, "image settings" slider, even pegging the GPU clock at max performance. I concluded that this must be a regression in the nvidia drivers, so I decided to be a good citizen and figure out what version had introduced the regression so I could write a good bug report.

    However, every version I tried still had that same performance hit. I tried 304.22, 270.41.06, 260.19.44-- I even dug up the same 260.19.06 beta version I'd installed from the repositories on Nvidia's FTP server, and it was still slower! I made sure to check the settings in the Nvidia GUI each time.

    Okay fine, so the Ubuntu packagers must do something special to make it faster than Nvidia's .run package. No problem, I thought, I'll just go back to the version from the repositories. So I did that, and it certainly was a hassle-- it involved manually removing files from /var/lib/dkms and .ko files from /lib/modules, then reinstalling the package. But it worked, and I'm now back to Ubuntu's version, I think.

    Except performance hasn't improved. In one scene, it's still 205 FPS where it should be 260.

    I'm stumped. Does anyone have any idea what's going on?
    Last edited by MaxToTheMax; 09-30-2012, 05:04 AM.

  • #2
    Not sure if this is the issue, but it might be worth a try:

    VSync is enabled by default in 3xx drivers. This interferes with the desktop compositor. Even if you disable VSync in nvidia-settings, it's still enabled at the point the compositor runs. Ubuntu loads the settings through a start-up *.desktop file (XDG). But *.desktop files load too late, so the compositor starts up with GL VSync. GL apps loaded later have VSync disabled, but the compositor still runs with VSync, and that costs FPS.

    This is why Gentoo switched from XDG to an /etc/X11/xinitrc.d/ script to restore driver settings *prior* to loading the compositor. You can try saving the below as /etc/X11/xinit/xinitrc.d/95-nvidia-settings:

    /opt/bin/nvidia-settings --load-config-only
    And make it executable:

    chmod +x /etc/X11/xinit/xinitrc.d/95-nvidia-settings
    Adjust the path to the nvidia-settings binary if it's not installed in /opt/bin. Make sure VSync is off in nvidia-settings and "Allow flipping" is on. Then restart X and see if it helped.


    • #3
      Would the symptoms of this problem result in FPS limited to the monitor's refresh rate? Because my framerates were already far in excess of that. And I'm not even using the 304.x drivers anymore-- would these effects be lasting? And what exactly qualifies as a compositor in this context? I'm using Metacity with desktop effects disabled, I thought that means there was no compositing.
      Last edited by MaxToTheMax; 09-30-2012, 02:34 PM.


      • #4
        I'm an idiot. Forgot to "override application settings" when disabling anti-aliasing.

        The 304.51 drivers are still slower than the 260.19.06 ones, but the regression is much less severe. I'll now resume my original plan of going back through old versions of the drivers until I find one that's at least as fast as the 260 one.

        EDIT: 270.41.06 seems to be working great.
        Last edited by MaxToTheMax; 09-30-2012, 05:46 PM.