Announcement

Collapse
No announcement yet.

Adobe's Flash Video Acceleration On Linux Uses VDPAU

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mlau
    replied
    Originally posted by PsynoKhi0 View Post
    Or other vendors getting their stuff together. I'd much rather the latter actually. Not too keen on the one-size-fits-all approach.
    This is why Windows is so much better: Microsoft provides ONE interface spec (DxVA) and driver and player software writers only have to worry about ONE interface (nevermind that DxVA isn't the perfect system).

    The current VDPAU/VAAPI/XvBA situation in the linux world is ridiculous: Just pick one and fix it up so that all parties are satisfied instead of having every vendor invent their own.

    Personally, I favor VDPAU: a lot of thought has been put into the overall
    design, and the developers are responsive to inquiries and suggestions.

    Leave a comment:


  • Kano
    replied
    Well i see no huge problem to use nvidia accelleration via vdpau-video wrapper - just the apps need to be fine tuned ab bit like xbmc. vlc has got only problems with vc1 and ion - but there even on win...

    Leave a comment:


  • deanjo
    replied
    Originally posted by PsynoKhi0 View Post
    Or other vendors getting their stuff together. I'd much rather the latter actually. Not too keen on the one-size-fits-all approach.
    The last thing needed is a different API for every vender. It serves no purpose.

    Leave a comment:


  • PsynoKhi0
    replied
    Originally posted by deanjo View Post
    Maybe this will be finally the push that gets vdpau adopted in other drivers.
    Or other vendors getting their stuff together. I'd much rather the latter actually. Not too keen on the one-size-fits-all approach.

    Leave a comment:


  • gbeauche
    replied
    Originally posted by ChrisXY View Post
    I have read like 70 posts and there were only people complaining that their older cards are not supported or discussing when video acceleration will come to the open source driver. One person had a problem that was solved quickly.
    I am sorry but I have never seen any XvBA bug fixed quickly. I remind there was a stupid and crashing bug that prevented *any* XvBA based application (or library) to function properly without appropriate workaround. The fix was as trivial as a 10 characters (yes, ten!) change in the Makefile or whatever is used in the build system. However, this was only done 8 months later, yes, months...

    Leave a comment:


  • cl333r
    replied
    I wonder when does Flash get support for webm, I thought they'd do that asap.
    And yes, I also hope that now AMD driver devs might consider supporting vdpau.

    Leave a comment:


  • FunkyRider
    replied
    xvba is crap, just like all other AMD proprietary stuff. get over it.

    Leave a comment:


  • deanjo
    replied
    Originally posted by ChrisXY View Post
    I also don't understand why people like to have to have so many pages all the time. With my forum settings it are only 12 pages.
    Ever try to load a page with 100 posts on one page on a cell phone?

    Leave a comment:


  • ChrisXY
    replied
    I have read like 70 posts and there were only people complaining that their older cards are not supported or discussing when video acceleration will come to the open source driver. One person had a problem that was solved quickly. Post 60 finally named some issues.
    I'm not currently running catalyst but I think deinterlacing worked...
    h264 l5.1 doesn't play. I said that, but few, very few videos I have encountered use it (actually 2).
    I have only managed to crash X with a broken video once in a long time... Certainly this is not the reason for saying it is "half broken".
    I have never encountered wrong colors on h264, only said problems with above videos. Does someone have a screenshot or something?

    Is there more to come? Do I have to read all posts of which only a a small minority is about the problems?

    I also don't understand why people like to have to have so many pages all the time. With my forum settings it are only 12 pages.

    Leave a comment:


  • deanjo
    replied
    Originally posted by ChrisXY View Post
    Can someone explain the "next-to-broken state thanks to bugs in the X-Video Bitstream Acceleration driver" to me?

    I have used catalyst for some time with my HD 4670. It worked very good for most videos. There were some (x264 encoded, level 5 @ high I think) that had huge block artifacts but the vast majority of the videos just played flawless.
    Here is a nice 105 page write up on the various issues.

    http://www.phoronix.com/forums/showt...ewpost&t=19983

    Leave a comment:

Working...
X