Announcement

Collapse
No announcement yet.

Overclocking via xorg.conf or command line

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    hedron
    Junior Member

  • hedron
    replied
    Originally posted by a7v-user View Post
    The attribute you're looking for is 'GPU3DClockFreqs', at least with GF 9800 GT. 'GPUCurrentClockFreqs' is changed whenever the card slows down to save power (or switches to the 2D frequencies).
    Also I'm not sure if the overclocking state is saved into ".nvidia-settings-rc" so you might have to enable overclocking first. Just checked on my system, none of the overclocking variables is saved into ".nvidia-settings-rc"
    Ie try:
    Code:
    nvidia-settings -a GPUOverclockingState=1 -a GPU3DClockFreqs=400,300
    Then you'd only need to put that into a script somewhere and make sure it's run whenever you start your desktop environment.
    Thanks, that worked great.

    Hmm... Well, it was working great but it doesn't work with fluxbox's start up script and I had to do:

    Code:
    chmod -w .nvidia-settings-rc
    To stop it from overwriting my edits, but I guess having it working the way I want it should be enough.
    hedron
    Junior Member
    Last edited by hedron; 22 July 2009, 06:32 PM.

    Leave a comment:

  • a7v-user
    Phoronix Member

  • a7v-user
    replied
    The attribute you're looking for is 'GPU3DClockFreqs', at least with GF 9800 GT. 'GPUCurrentClockFreqs' is changed whenever the card slows down to save power (or switches to the 2D frequencies).
    Also I'm not sure if the overclocking state is saved into ".nvidia-settings-rc" so you might have to enable overclocking first. Just checked on my system, none of the overclocking variables is saved into ".nvidia-settings-rc"
    Ie try:
    Code:
    nvidia-settings -a GPUOverclockingState=1 -a GPU3DClockFreqs=400,300
    Then you'd only need to put that into a script somewhere and make sure it's run whenever you start your desktop environment.
    a7v-user
    Phoronix Member
    Last edited by a7v-user; 21 July 2009, 10:03 AM.

    Leave a comment:

  • Kano
    Kanotix Developer

  • Kano
    replied
    Why don't you use nvclock? Or if the setting is saved:

    nvidia-settings -l

    Leave a comment:

  • hedron
    Junior Member

  • hedron
    started a topic Overclocking via xorg.conf or command line

    Overclocking via xorg.conf or command line

    I've found stable settings, but I'm sick of going into the control panel and setting them everytime. However, when I try this:

    Code:
    nvidia-settings -a GPUCurrentClockFreqs=400,300
    I get:

    Code:
    ERROR: The attribute 'GPUCurrentClockFreqs' specified in assignment
           'GPUCurrentClockFreqs=400,300' cannot be assigned (it is a read-only
           attribute).
    What's the problem?

    I'd prefer via xorg.conf, but I figure it's the same issue as to why it's not working.
Working...
X